RTX 2070

1234689

FAQ & Answers

  • ven98ven98 ACE Posts: 4,076 Pathfinder
    It is technically possible to cause damage. If you connect a switch to the LED connectors it can potentially cause damages. If you connect the LED + to - and - to + it won't light up. Connecting a reset switch to pw will make it work as power switch. Overall it depends on what you connect wrong and even if you do causing damage is very rare.
    Always post the following characterisitcs of the device:
    -Model number
    -Part number(not required, but helpful)
    -CPU
    -GPU
    -Operating system

    Helios 300 and Nitro 5 users DO NOT update the BIOS to version 1.22 if you don't want the keyboard's backlight to turn off after 30 seconds even when the device is plugged in.


    Hit 'Like' if you find the answer helpful!   
    Click on 'Yes' if the comment answers your question!

  • SaliwarriorSaliwarrior Member Posts: 94

    Tinkerer

    Still not working :(
  • ven98ven98 ACE Posts: 4,076 Pathfinder
    Try swapping the places of power button and LED.
    Always post the following characterisitcs of the device:
    -Model number
    -Part number(not required, but helpful)
    -CPU
    -GPU
    -Operating system

    Helios 300 and Nitro 5 users DO NOT update the BIOS to version 1.22 if you don't want the keyboard's backlight to turn off after 30 seconds even when the device is plugged in.


    Hit 'Like' if you find the answer helpful!   
    Click on 'Yes' if the comment answers your question!

  • ven98ven98 ACE Posts: 4,076 Pathfinder
    By the way what is the reason for you to think that you have damaged the motherboard? Is it because you have done something that you shouldn't have?
    Always post the following characterisitcs of the device:
    -Model number
    -Part number(not required, but helpful)
    -CPU
    -GPU
    -Operating system

    Helios 300 and Nitro 5 users DO NOT update the BIOS to version 1.22 if you don't want the keyboard's backlight to turn off after 30 seconds even when the device is plugged in.


    Hit 'Like' if you find the answer helpful!   
    Click on 'Yes' if the comment answers your question!

  • SaliwarriorSaliwarrior Member Posts: 94

    Tinkerer

    Unfortunately it's still not working. I swapped the led and pw with their positions the same +with - and - with + could the mother board be fried
  • ven98ven98 ACE Posts: 4,076 Pathfinder
    Why do you think the motherboard could be fried? 

    Did you connect the CPU fan?
    Always post the following characterisitcs of the device:
    -Model number
    -Part number(not required, but helpful)
    -CPU
    -GPU
    -Operating system

    Helios 300 and Nitro 5 users DO NOT update the BIOS to version 1.22 if you don't want the keyboard's backlight to turn off after 30 seconds even when the device is plugged in.


    Hit 'Like' if you find the answer helpful!   
    Click on 'Yes' if the comment answers your question!

  • SaliwarriorSaliwarrior Member Posts: 94

    Tinkerer

    Yes. I think the motherboard might be fried because it's nothing is working. Everything is plugged in. 
  • ven98ven98 ACE Posts: 4,076 Pathfinder
    Try removing the GPU to see if it will turn on.
    Always post the following characterisitcs of the device:
    -Model number
    -Part number(not required, but helpful)
    -CPU
    -GPU
    -Operating system

    Helios 300 and Nitro 5 users DO NOT update the BIOS to version 1.22 if you don't want the keyboard's backlight to turn off after 30 seconds even when the device is plugged in.


    Hit 'Like' if you find the answer helpful!   
    Click on 'Yes' if the comment answers your question!

  • SaliwarriorSaliwarrior Member Posts: 94

    Tinkerer

    But you know when you plug in the psu cable and the electricity is on you kind of here this static. The switch is on but I can't hear the static
  • ven98ven98 ACE Posts: 4,076 Pathfinder
    I wonder what is the possibility for a PSU to arrive dead. 

    Did you connect the 4pin connector for the CPU?
    Always post the following characterisitcs of the device:
    -Model number
    -Part number(not required, but helpful)
    -CPU
    -GPU
    -Operating system

    Helios 300 and Nitro 5 users DO NOT update the BIOS to version 1.22 if you don't want the keyboard's backlight to turn off after 30 seconds even when the device is plugged in.


    Hit 'Like' if you find the answer helpful!   
    Click on 'Yes' if the comment answers your question!

  • SaliwarriorSaliwarrior Member Posts: 94

    Tinkerer

    Let me show you how the picture looks with all cables plugged
  • SaliwarriorSaliwarrior Member Posts: 94

    Tinkerer

    Yes I connected the 4 pin. There is two of them and they are wrapped closely together.
  • ven98ven98 ACE Posts: 4,076 Pathfinder
    Try disconnecting everything from the front panel header and leave the PW wires for power button connected only to the place shown on the diagrams from my previous post. If that doesn't help leave it like that and remove the GPU and then try to power on. 

    If that doesn't work turn off the PSU, then remove CMOS battery, wait 30 seconds and put it back again. If that doesn't work try connecting the old power supply(just connect the 24pin and 4pin to CPU) and power on.
    Always post the following characterisitcs of the device:
    -Model number
    -Part number(not required, but helpful)
    -CPU
    -GPU
    -Operating system

    Helios 300 and Nitro 5 users DO NOT update the BIOS to version 1.22 if you don't want the keyboard's backlight to turn off after 30 seconds even when the device is plugged in.


    Hit 'Like' if you find the answer helpful!   
    Click on 'Yes' if the comment answers your question!

  • SaliwarriorSaliwarrior Member Posts: 94

    Tinkerer

    You mean psw I don't hv pw
  • ven98ven98 ACE Posts: 4,076 Pathfinder
    Can you post photos of each front panel cable that you have connected to the front panel header(number 8 from the diagram)? Also write where you have connected each cable according to the diagram of the front power header as following:
    LED+ - LED +
    LED- - LED -
    PW - PW +-
    Always post the following characterisitcs of the device:
    -Model number
    -Part number(not required, but helpful)
    -CPU
    -GPU
    -Operating system

    Helios 300 and Nitro 5 users DO NOT update the BIOS to version 1.22 if you don't want the keyboard's backlight to turn off after 30 seconds even when the device is plugged in.


    Hit 'Like' if you find the answer helpful!   
    Click on 'Yes' if the comment answers your question!

  • SaliwarriorSaliwarrior Member Posts: 94

    Tinkerer

    Sure I'll draw it sense I plugged them off
  • SaliwarriorSaliwarrior Member Posts: 94

    Tinkerer

    Since* ok so here we have the + pled on the end side. I placed them horizontally. The - is next to it.then the PSW positive which is next to the pled -. Opposite to the Pled is the HD. The positive HD is opp to the + of the PLED and - HD is op of - Pled. The RS - is opp of the PSW + and the RS + is opp of - psw
  • ven98ven98 ACE Posts: 4,076 Pathfinder
    This is the correct way.
    Always post the following characterisitcs of the device:
    -Model number
    -Part number(not required, but helpful)
    -CPU
    -GPU
    -Operating system

    Helios 300 and Nitro 5 users DO NOT update the BIOS to version 1.22 if you don't want the keyboard's backlight to turn off after 30 seconds even when the device is plugged in.


    Hit 'Like' if you find the answer helpful!   
    Click on 'Yes' if the comment answers your question!

  • SaliwarriorSaliwarrior Member Posts: 94

    Tinkerer

    also the psu that comes with acer aspire is weirdly wired onto the case.
  • ven98ven98 ACE Posts: 4,076 Pathfinder
    ven98 said:
    Try disconnecting everything from the front panel header and leave the PW wires for power button connected only to the place shown on the diagrams from my previous post. If that doesn't help leave it like that and remove the GPU and then try to power on. 

    If that doesn't work turn off the PSU, then remove CMOS battery, wait 30 seconds and put it back again. If that doesn't work try connecting the old power supply(just connect the 24pin and 4pin to CPU) and power on.
    Try this.
    Always post the following characterisitcs of the device:
    -Model number
    -Part number(not required, but helpful)
    -CPU
    -GPU
    -Operating system

    Helios 300 and Nitro 5 users DO NOT update the BIOS to version 1.22 if you don't want the keyboard's backlight to turn off after 30 seconds even when the device is plugged in.


    Hit 'Like' if you find the answer helpful!   
    Click on 'Yes' if the comment answers your question!

Sign In or Register to comment.

Who's Online2.6K

6kapserg
6kapserg
Acer-Harvey
Acer-Harvey
batmalin
batmalin
BrunoEscobar2020
BrunoEscobar2020
Delonte
Delonte
Ephrem
Ephrem
Ice44
Ice44
JackE
JackE
layal12
layal12
Lionfast123
Lionfast123
pablorlf
pablorlf
PEDREX171
PEDREX171
RodolfoRiedel
RodolfoRiedel
schw1ftyxd
schw1ftyxd
TimGoodman
TimGoodman
TnTechTeacher
TnTechTeacher
vishnuvamsi
vishnuvamsi
Zee12490
Zee12490
ダージリン様
ダージリン様
+2.5K Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos