image

OJO 500 left controller batteries always low.

ThanatewaThanatewa Member Posts: 3 New User
 OJO 500 left controller batteries are always low even I try to used new batteries but it did not work. I can use it for a few minutes and it over again.
May be, battery level has some error.
What can I do?
Reset the controller? or
Update firmware?
Please, help.

Best Answer

  • billseybillsey ACE Posts: 21,250 Trailblazer
    Accepted Answer
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.

FAQ & Answers

  • billseybillsey ACE Posts: 21,250 Trailblazer
    Accepted Answer
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • ThanatewaThanatewa Member Posts: 3 New User
    billsey said:
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    thanks, I cannot see any corrosion but I will try cleaning it first.
  • ThanatewaThanatewa Member Posts: 3 New User
    Thanatewa said:
    billsey said:
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    thanks, I cannot see any corrosion but I will try cleaning it first.
    It's WORK!! I cleaned it follow this link  and it's solved.
    Thank you so much.
  • sammorrissammorris Member Posts: 2 New User
    Thanatewa said:
    Thanatewa said:
    billsey said:
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    thanks, I cannot see any corrosion but I will try cleaning it first.
    It's WORK!! I cleaned it follow this link  and it's solved.
    Thank you so much.
    Thanks for the detailed video, it really help me out!
Sign In or Register to comment.

Who's Online1.2K

Adaenie
Adaenie
Apolivo
Apolivo
BElchi
BElchi
BetoK
BetoK
billsey
billsey
Birtieddu
Birtieddu
BMassacesi
BMassacesi
brummyfan2
brummyfan2
Chomchom
Chomchom
Cussof54
Cussof54
etrusco
etrusco
Extreme666
Extreme666
infomarc2003
infomarc2003
JackE
JackE
Jamesd22
Jamesd22
Joabecf1
Joabecf1
Jumuu
Jumuu
Katar
Katar
Kdizzle
Kdizzle
Kev0806
Kev0806
KevinEsquea
KevinEsquea
lochgman
lochgman
Optimistic
Optimistic
OttawaT1660
OttawaT1660
Reiny
Reiny
Scribea
Scribea
sergihejo
sergihejo
toothless02
toothless02
xapim
xapim
+1.1K Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos