OJO 500 left controller batteries always low.

ThanatewaThanatewa Member Posts: 3 New User
 OJO 500 left controller batteries are always low even I try to used new batteries but it did not work. I can use it for a few minutes and it over again.
May be, battery level has some error.
What can I do?
Reset the controller? or
Update firmware?
Please, help.

Best Answer

  • billseybillsey ACE Posts: 20,484 Trailblazer
    Accepted Answer
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.

FAQ & Answers

  • billseybillsey ACE Posts: 20,484 Trailblazer
    Accepted Answer
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • ThanatewaThanatewa Member Posts: 3 New User
    billsey said:
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    thanks, I cannot see any corrosion but I will try cleaning it first.
  • ThanatewaThanatewa Member Posts: 3 New User
    Thanatewa said:
    billsey said:
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    thanks, I cannot see any corrosion but I will try cleaning it first.
    It's WORK!! I cleaned it follow this link  and it's solved.
    Thank you so much.
  • sammorrissammorris Member Posts: 2 New User
    Thanatewa said:
    Thanatewa said:
    billsey said:
    Do you see any corrosion on the battery contacts? Sometimes when a battery has leaked the contacts get corroded and that can act like a low battery.
    thanks, I cannot see any corrosion but I will try cleaning it first.
    It's WORK!! I cleaned it follow this link  and it's solved.
    Thank you so much.
    Thanks for the detailed video, it really help me out!
Sign In or Register to comment.

Who's Online1.3K

Acer-Erick
Acer-Erick
Acer-Ingrid
Acer-Ingrid
ArnLay67
ArnLay67
aspireUser12
aspireUser12
azsharon
azsharon
biodanilo
biodanilo
brummyfan2
brummyfan2
CAPSINGE
CAPSINGE
Danick17
Danick17
drale
drale
evandrofriedri
evandrofriedri
EvidentRecker
EvidentRecker
JackE
JackE
JesusCA
JesusCA
JrJau
JrJau
kevincusba
kevincusba
Kingmarrk
Kingmarrk
LachlanGunson
LachlanGunson
Legalev
Legalev
Masquirrel
Masquirrel
RAGExGAMING
RAGExGAMING
sage83
sage83
Sangeeth
Sangeeth
Sebastian140980
Sebastian140980
Spotnik
Spotnik
Strini86
Strini86
ThatIcyPolarBear
ThatIcyPolarBear
wbzb
wbzb
xapim
xapim
Yuri15
Yuri15
+1.3K Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos