Examples: Monday, today, last week, Mar 26, 3/26/04

Linux Install on Acer Predator Helios 300 (G3-571)

vicky92vicky92 Posts: 1Member Newbie
edited March 2018 in Predator Laptops
I want to install Linux mint alongside windows 10 in the SSD, without messing up anything. Please suggest the best way to do the same.

FAQ & Answers

  • wesruvwesruv Posts: 5Member New User
    I think that'd get tricky without reinstalling everything.

    You'd want to boot from a linux install disk, wipe out the partitions on the SSD, then install linux with half (or whatever size) of the hard drive, then reinstall Windows.
  • JackEJackE Posts: 15,931ACE Trailblazer
    You should be OK with a Ubuntu dual boot configuration along side Windows. Follow these steps. Keep the UEFI bootstrapper --- Do  NOT try to configure to Legacy mode or you won't have dual boot capability. Jack E/NJ

    ( 0) Pre-shrink Windows partition to desired unallocated space for Linux installation.
    ( 1) Make bootable GPT/FAT32(default) stick from the Linux installation iso with Rufus.
    ( 2) Set BIOS supervisor password(SECURITY), disable secure boot(BOOT)& enable F12 Windows boot mgr (MAIN). Save BIOS settings & exit. May not be needed with some Linux installations like Mint.
    ( 3) Shutdown & insert bootable Linux stick
    ( 4) Turn back on while immediately tapping F12. Select Linux stick to run.
    ( 5) Preferrably select a default Linux install option
    ( 6) Follow on-screen instructions to install alongside Windows.
    ( 7) Let Linux automatically set & resize partitions for Linux & its swap. Adjust for more or less space only if absolutely necessary.
    ( 8) Shutdown & remove Linux stick.
    ( 9) Turn back on while tapping F2.
    (10) Re-enable secure boot(BOOT) & select UEFI file as trusted(MAIN). Select HDD0, SSD0 or eMMC0, then <EFI>, then <ubuntu>, then grubx64.efi the UEFI file. Enter grubx64.efi in the space provided if selecting it doesn't automatically enter it. Save BIOS setting and exit.
    (11) Boot into Windows. Then shutdown again.
    (12) Turn back on while tapping F12.
    (13) If desired, put grubx64.efi ahead of Windows boot manager in UEFI bootstrapper


  • SidSid Posts: 1Member New User
    I am unable to install linux using this process

  • GawainGawain Posts: 160Member Skilled Fixer
    might be an idea to elaborate on where the mint install falls over.
  • LandevLandev Posts: 3Member New User
    Installation of Ubuntu works: https://marclandolt.ch/ml_buzzernet/2018/07/04/installation-ubuntu-auf-acer-predator-helios-300-nh-q3eez-001-ph317-52-7919/

    but I was not able to install Debian with dual screen. After i installed the Proprietary NVIDIA Driver the xorg xserver does not start and the console just flickers dark but no graphical envorionment... https://devtalk.nvidia.com/default/topic/1037322/acer-predator-helios-300/#5269958
  • JackEJackE Posts: 15,931ACE Trailblazer
    As mentioned previously by @Gawain , >>>might be an idea to elaborate on where the mint install falls over.>>> before trying anything else. Even trying to re-do the install a few times sometimes is a success. Dual booting with Mint is well worth the effort especially on a Win10 system. Jack E/NJ
  • pskalipskali Posts: 1Member New User
    sri369 said:
    @vicky92
    Out of curiosity, why not use a VM to install Linux on?
  • EvgenyPEvgenyP Posts: 3Member New User
    I used Rufus according one of suggestions above and was able to boot Debian live usb. But there is trick in Bios, have to enable network booting, otherwise usb option after push F12 is not visible
  • EvgenyPEvgenyP Posts: 3Member New User
    Finally, I installed Debian 9 on Predator Helios 300, dual boot with windows 10. I tried Ubuntu, Kubuntu, OpenSuse, LinuxMint.
    Ubuntu (Kubuntu, LinuxMint) has problem with switching off and restarting, and in next start I just got empty screen after login. I did not figure out what is wrong. In Debian 9 I got problem with wifi, finally found solution, which is working! I just need upgrade everything to backports-stretch, including newer kernel, which has correspondent driver for intel wifi chipset. If someone needs more details, let me know.
  • JackEJackE Posts: 15,931ACE Trailblazer
    EvgenyP Thanks for the report. It's very unusual that Mint didn't install. Did you get any help from the Mint forums? User Altair4 was very good at helping other users with issues like this. Jack E/NJ
  • EvgenyPEvgenyP Posts: 3Member New User
    I am not fan of any particular linux distribution (Debian, Mint, Ubuntu, OpenSuse are just most popular and most supported), but like and need linux for everything except games :).  I suppose the problem of Ubuntu and Linux Mint (derived from Ubuntu) have the same problems:
    1) Even they start without any problem from live usb, but for some reason they both freeze after I tried to restart or power off after
    installation on hard disk.
    2) When I start both of them from hard disk, they freeze after login with empty purple (Ubuntu) or black (Mint) screen.
    3) After long path of trials, I just installed Debian Buster with firmware-iwlwifi package (fix wifi problem) and bumblebee-nvidia (make all fancy graphical effects available through OpenGL 2.0). Current release Debian Stretch unfortunately has too old kernel which physically does not support my Intel wifi chipset.
    4) Debian Stretch with backports does not roll for me, because after bumblebee-nvidia installed I got problems with Firefox and Okular submenus (I am using KDE mostly), they just not appear. This problem does not appear in Debian Buster 10.
    5) Dual boot with Windows 10 worked for all distributions just fine.
    So now I have good working Linux (debian 10), so I do not want make other trials again. Hope it can be helpful to someone.
  • karan316karan316 Posts: 12Member

    Tinkerer

    How am i suppose to fix the issue of Ubuntu getting frozen during installation?

  • JackEJackE Posts: 15,931ACE Trailblazer
    karan316>>>fedora and mint are getting installed but get stuck after logging in. whats the problem with the predator series?? >>>

    Which specific predator model PHxxx-xx? How is it getting stuck --- black screen, frozen, etc? Which Mint flavor? If the BIOS main tab has a touch set to advanced mode, try changing it to basic. Jack E/NJ 

  • karan316karan316 Posts: 12Member

    Tinkerer

    its the PH315-51. Fedora and Mint are stuck on the log in page. Does not work even after changing touch set to basic
  • JordanBJordanB Posts: 3,321ACE Pathfinder
    edited February 19
    @karan316

    In the link below, @kaboume explains that when he installed Ubuntu, he had to set the touchpad to basic, and also how to install the Nvidia driver so it doesn't freeze.

    https://community.acer.com/en/discussion/comment/637350#Comment_637350

    sudo add-apt-repository ppa:graphics-drivers/ppa
    sudo apt update
    sudo apt install nvidia-384 nvidia-settings


    If you still have problems, take a look at links below.....


    https://towardsdatascience.com/my-portable-ubuntu-18-deep-learning-setup-66151fe78da9

    https://marclandolt.ch/ml_buzzernet/2018/07/04/installation-ubuntu-auf-acer-predator-helios-300-nh-q3eez-001-ph317-52-7919/

    https://askubuntu.com/questions/996015/cannot-switch-to-nvidia-gpu-despite-downloading-proprietary-driver-acer-ubunt

    I'm not sure if @kaboume has the exact same mainboard/hardware as you or what BIOS version he was using.

    Note: I don't have a Helios 300 so I can't really help you any more than just searching this forum and google searching.
    I'm not an Acer employee.
  • JackEJackE Posts: 15,931ACE Trailblazer
    karan316
    Which Mint? 19.x? 18.x? Cinnamon? Jack E/NJ
  • karan316karan316 Posts: 12Member

    Tinkerer

    mint cinnamon
  • karan316karan316 Posts: 12Member

    Tinkerer

    All the distros work perfectly fine when I use a virtual machine on windows only while dual booting it is creating problems
  • JackEJackE Posts: 15,931ACE Trailblazer
    Have you tried Cinnamon 18.3. It's fairly well polished relative to 19.x? Jack E/NJ
Sign In or Register to comment.

Who's Online184

ayush6968
ayush6968
Moderig
Moderig
Trustnone
Trustnone
vampirelordX2
vampirelordX2
Vindicus
Vindicus
+179 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.