next@acer 2020

Acer Predator Helios 300 Audio Echo? No Sound Enhancements Tab

arosenarosen Member Posts: 2 New User
Hi,everyone

There is an annoying audio echo whenever I use my headphones. It sounds like everyone i'm listening to on youtube is in a giant empty room. Normally you can fix this by turning off audio enhancements, but there is no audio enhancements tab when I look at speaker properties? This echo is driving me absolutely insane and making listening experiences quite poor. I also noticed the drivers are realtek(r). Is this the right one? Don't most computers have realtek high definition audio, or is this the same thing? 

I'd appreciate any guidance.

Best Answers

  • arosenarosen Posts: 2 New User
    Accepted Answer
    Found the issue. It was the dang waves maxx audio completely distorting everything. 
  • ltaaa2ltaaa2 Posts: 1 New User
    Accepted Answer
    Type Waves Maxx audio in your search bar. Turn it off unless you have 10 speakers surrounding you.............
  • BrunoFS7BrunoFS7 Posts: 39 Die Hard
    Accepted Answer
    That is it boys, I got crazy today. After a W10 update with Realtek, a echo started to be around my earphones. I unistalled drivers, downgraded, used realtek old drivers and everythings else. But no change.

    The solution is: keep windows enhancements audio ENABLED, just go to the WAVES software (search for it) and DISABLE THE WAVES NX AUDIO, just keep the Maxxaudio enabled to the sound effects.

    That is it guys!

FAQ & Answers

  • JackEJackE ACE Posts: 21,900 Trailblazer
    What is your full helios model number PH31x-xx and your headphone model and number? Have you instead right clicked on the speaker tray icon and checked for the enhancements tab under playback devices there? It should be there. If not, we can check for updated drivers for you particular helios model at this link if you haven't done so already https://www.acer.com/ac/en/US/content/drivers    Jack E/NJ

    Jack E/NJ
  • arosenarosen Member Posts: 2 New User
    Accepted Answer
    Found the issue. It was the dang waves maxx audio completely distorting everything. 
  • JackEJackE ACE Posts: 21,900 Trailblazer
    Good detective work. Jack E/NJ
    Jack E/NJ
  • Big_MikeBig_Mike Member Posts: 2 New User
    I'm having the same issue, how did you fix it?arosen said:
    Hi,everyone

    There is an annoying audio echo whenever I use my headphones. It sounds like everyone i'm listening to on youtube is in a giant empty room. Normally you can fix this by turning off audio enhancements, but there is no audio enhancements tab when I look at speaker properties? This echo is driving me absolutely insane and making listening experiences quite poor. I also noticed the drivers are realtek(r). Is this the right one? Don't most computers have realtek high definition audio, or is this the same thing? 

    I'd appreciate any guidance.
    I'm having the same problem, how did you fix it?
  • JackEJackE ACE Posts: 21,900 Trailblazer
    arosen  said>>>Found the issue. It was the dang waves maxx audio completely distorting everything. >>>

    Jack E/NJ


    Jack E/NJ
  • ltaaa2ltaaa2 Member Posts: 1 New User
    Accepted Answer
    Type Waves Maxx audio in your search bar. Turn it off unless you have 10 speakers surrounding you.............
  • touchesPlantstouchesPlants Member Posts: 1 New User
    OMG!! Thank you!! I've been trying to figure this out for a while and turning off the Waves Maxx audio fixed it!! This was driving me crazy!!
  • BrunoFS7BrunoFS7 Member Posts: 39 Die Hard
    Accepted Answer
    That is it boys, I got crazy today. After a W10 update with Realtek, a echo started to be around my earphones. I unistalled drivers, downgraded, used realtek old drivers and everythings else. But no change.

    The solution is: keep windows enhancements audio ENABLED, just go to the WAVES software (search for it) and DISABLE THE WAVES NX AUDIO, just keep the Maxxaudio enabled to the sound effects.

    That is it guys!
  • WillTheTitanWillTheTitan Member Posts: 1 New User
    I have deleted the Waves Maxxaudio thinking that I could just get rid of the problem this way (as it turned itself back on every Windows update), but instead I am stuck without the ability to fix the echoing. Even worse, I can't figure out how to reinstall it which isn't as straight-forward as it seems. Can anyone provide a link or tell me how I can reinstall it?
Sign In or Register to comment.

Who's Online1.7K

Acer-Michi
Acer-Michi
Allibuh
Allibuh
batmalin
batmalin
brummyfan2
brummyfan2
depthcontrol
depthcontrol
dnyaneshwar
dnyaneshwar
gigiH
gigiH
Hewzee
Hewzee
Hochwill
Hochwill
luchin6229256652
luchin6229256652
Lynxi_
Lynxi_
MaxCapie
MaxCapie
MissMilena
MissMilena
mmw6314
mmw6314
stanhaus
stanhaus
StevenGen
StevenGen
techiekhan
techiekhan
Vince714
Vince714
+1.7K Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We want to recognize GAMING6698's dedicated efforts in the Acer Community. GAMING6698 has become one of the main collaborators since joining the Community in November of 2019.
On behalf of all our users and the Acer Team, we thank you for your dedication!

Total Posts and Comments: 3319

Total Points:5757

Total Accepted Answers: 290

GAMING6698 Mainframe Wrangler