EFI dual boot not seeing Linux on Nitro 5 AN515-51-78C6

KrellanKrellan Member Posts: 5


edited March 2022 in Nitro and Aspire Gaming
Hi there! I have an Acer laptop, Nitro 5, AN515-51-78C6 model. It came with Windows 10 Home. I want to dual boot it with Linux.

I'm using Linux Mint 18.3 Cinnamon, 64-bit. This distribution is EFI friendly and Secure Boot friendly, at least they claim to be.

It booted up from USB stick (and DVD) without a problem. I shrank the size of the NTFS partition, to make room for Linux, and added a Linux ext4 partition. The installation completed OK. The bootloader should have been installed within the "EFI System Partition" that I had selected.

However, nothing seems to have happened. The laptop only boots Windows 10. It isn't giving me the choice of Linux or Windows.

On the Acer screen as it is booting, repeatedly pressing F2 will eventually enter the BIOS, and F12 will eventually enter the boot menu. These work well. However, nothing here is giving me the choice, either. The only boot choice is "Windows Boot Manager".

I tried using various recommended EFI tools to point the selection at Linux instead, such as "efibootmgr" under Linux Mint. I can set the choice to "ubuntu" (the EFI name that Linux Mint installs under, for various reasons). However, this choice doesn't stick, and when rebooting the laptop, it gets forcefully set back to Windows 10.

Changing boot type to "Legacy" instead of "UEFI" kills Windows 10. It can't find itself anymore, so it can't boot. So, looks like I'm stuck with UEFI, or the alternative of reformatting the entire disk under the old MBR way of doing things, and only having Linux, and losing the ability to dual boot.

Anybody else have this problem? Any suggestions?

Best Answer

FAQ & Answers

  • padgettpadgett ACE Posts: 4,532 Pathfinder
    Where did you install Grub ? On one machine I put GRUB on the Linux partition then had to redirect the BIOS to boot there. Am using LEGACY for both it and Win 10.
  • KrellanKrellan Member Posts: 5


    padgett said:
    Where did you install Grub ? On one machine I put GRUB on the Linux partition then had to redirect the BIOS to boot there. Am using LEGACY for both it and Win 10.

    Thanks, but I'm using UEFI, not Legacy. That makes a huge difference. How did you get Windows 10 to boot up successfully in Legacy mode? Was it a fresh installation that you did? I'm just using the default installation that came bundled with the Acer laptop.

    When I tried Legacy mode, Windows couldn't find itself, so all I got was the old Intel PXE network boot (which is normal to see when the BIOS can't boot from any disks so it falls back to Intel PXE as a last resort).


  • JordanBJordanB ACE Posts: 3,729 Pathfinder
    edited May 2018
    Is something preventing you from clicking on the link I gave you and following Jici79's step-by-step-instructions for UEFI mode?   Why in the world would you still be asking questions about legacy mode after I gave you step-by-step instructions on how to dual boot windows and mint?
    I'm not an Acer employee.
  • KrellanKrellan Member Posts: 5


    JordanB said:
    Thanks for the links, will try them. I think the answer lies somewhere in the BIOS settings. I'm still unsure why setting a supervisor password in the BIOS is necessary to disable Secure Boot. Probably a BIOS bug, oh well. I hope that it will allow me to access the other EFI settings and bless the Linux GRUB choice as being bootable, so the BIOS will choose it, instead of Windows 10.

    As for Rufus, here's another good USB stick creator to try, and it's cross-platform too:

    I checked, and my Linux USB stick was successfully booted in EFI mode, so I don't think that was the problem here.


  • JordanBJordanB ACE Posts: 3,729 Pathfinder
    edited May 2018
    Huh?  Don't disable secure boot.  You must create a UEFI supervisor password so you can add Grub to the Trusted secure boot settings in the UEFI settings.
    I'm not an Acer employee.
  • JordanBJordanB ACE Posts: 3,729 Pathfinder
    You might want to create a factory USB recovery drive before you go any further....and then put it a safe place like a desk drawer.
    I'm not an Acer employee.
  • KrellanKrellan Member Posts: 5


    JordanB said:
    You might want to create a factory USB recovery drive before you go any further....and then put it a safe place like a desk drawer.
    Thanks! I found the factory USB creator option, in Windows 10: Start / Acer / Acer Recovery Management / Backup / Create Factory Default Backup. I inserted a 16GB USB stick, and let it run for a few hours, and it seemed to work. I tested it by booting from it (not choosing any of the recovery options, though, just seeing that it would boot).


  • JordanBJordanB ACE Posts: 3,729 Pathfinder
    Good job man.  I knew you could do it.  All of it can be summarized in eelcoherder's post ( which was in the link I gave you)..

    I'm not an Acer employee.
  • madcpuscientistmadcpuscientist Member Posts: 2 New User
    Following these instructions, I run into 2 bumps.  First is I do not see the grubx64.efi option in bios, only bootx64.efi.  When following the instructions I just selected the bootx64.efi option as it was the only one there. This results in me being able to push it ahead of windows in boot order which leads to my second bump. It doesn't actually boot into Linux, just goes to windows.  Would anyone have any idea what I can do here?  Thanks for your assistance.
  • madcpuscientistmadcpuscientist Member Posts: 2 New User
    Oh yes, I am also doing this on a Nitro AN515-51, with a sandisk USB with ubuntu studio 18.04 mounted on it.
  • JordanBJordanB ACE Posts: 3,729 Pathfinder
    edited June 2018

    I understand your confusion.  I'm going to be honest with you.  @Krellan post is really about how you "fix" things after you didn't follow the correct procedure the first time.

    Let me give you the correct procedure on how to do it right the first time.  Hint: You'll be finding grubx64.efi on your USB drive when you add grubx64.efi to the trusted secure boot UEFI settings..  USB1 or USB0    Hint2: It will say 'Ubuntu' when you use F6 in the boot tab if that's the name you gave it.....i.e. "Give it a proper name like Ubuntu"

    Read my post in link below.  @JordanB

    Edit: If you've already installed Ubuntu, then you might as well go ahead follow Krellan's post as he explains it pretty well.  Eelcoherder's post explains it pretty well too, if you don't like my instructions.

    If you notice in Krellan's 6 steps, he never mentions installing Ubuntu.  That's because he's already installed it.......whoops. (cart/horse)  His instructions fix the problem of Ubuntu not booting.  Ideally, you want to add grubx64.efi to the trusted secure boot settings before you install Ubuntu.

    On some Acer laptop models, if you don't add grubx64.efi to the trusted secure boot settings before you install Ubuntu, you'll get locked out of the UEFI and it'll cause you a little grief.
    I'm not an Acer employee.
  • paledreadpaledread Member Posts: 1 New User
    Brilliant. Krellan post of May 7th just worked on an Acer E5-575 for me, after wasting several hours pursuing other wild geese.
  • KolskiKolski Member Posts: 1 New User
    Krellan said:
    Yay, after combining some ideas from other forum posts, I got it to work! I can now successfully boot it into Linux. It was not necessary to disable Secure Boot, it seems to work just fine with Secure Boot still enabled.

    It was all within the BIOS, accessible by repeatedly hitting F2 at the black screen (just before the Acer screen, as the laptop is rebooting).

    The BIOS is called "InsydeH20 Setup Utility" and it's a classic text-based BIOS (appears little changed from the early 1990's). You don't have a mouse pointer, just a text cursor, which you will be using for moving around. Use arrow keys to move, ENTER key to go in, ESC key to back out, just as if it was a quarter of a century ago.

    Here's what worked, for anybody searching on this question later (perhaps myself in the future):

    1) Go to the "Security" page (cursor to the right). You have to set a BIOS password (supervisor password) before it will let you use most of the items farther down on this page, unfortunately. Choose something short and easy to remember, because you will need it every time you are going into the BIOS again. I'm not sure how to recover from a forgotten password on a laptop (on a desktop, the little battery on the motherboard can be removed, or a jumper on the motherboard can be set, usually).

    2) Once you have set a supervisor password, move the cursor down, and choose "Select an UEFI file as trusted for executing". On the new empty screen that appears, choose "HDD0". Then choose "EFI". Then choose "ubuntu" or whatever the name of your Linux distribution is (for various reasons, "ubuntu" often has to be used, even if you're not installing Ubuntu itself). Inside "ubuntu", choose "grubx64.efi" file. It will pop up a dialog box. Give it a name in "Boot Description", you have to type a name, I simply chose "ubuntu" again. Finally, choose "Yes" to save it.

    3) You should return to the "Security" page. Notice that "Secure Boot Mode" is now changed to Custom, even though Secure Boot is still on. Hit F10 to save and exit. This BIOS requires that you reboot in order to make your EFI changes take effect, even though you're not done yet. The laptop will still boot into Windows. You have to choose "Restart" again, in Windows, and then hit F2 again to re-enter the BIOS.

    4) When you're in the BIOS again, check the "Security" page to make sure it still says Custom, and then go to the "Boot" page (farther right). Make sure "Boot Mode" is still set to "UEFI", and "Secure Boot" is still "Enabled". You shouldn't need to disable Secure Boot, which is good. The boot menu, containing Windows Boot Manager, should be below. If the BIOS successfully recognizes your Linux installation now, then "EFI File Boot 0: ubuntu" should appear as one of your choices below.  

    5) Move the cursor down to "EFI File Boot 0: ubuntu" and while you're on that line, hit F6 to move it up in the list. Keep hitting F6 until it reaches the top of the list. This will finally make the laptop default to booting Linux instead of Windows.
    Thanks! Spent past few days trying to install Linux Mint in dual boot. After multiple tries I ran across your solution. Worked like a charm!
  • kathirkathir Member Posts: 7


    Hey guys i solved it .
    Thereby i installed linux over windows 10 in nitro 5 and successfully boot into it.
    Here is the clear guide of how I did this..
  • Simo998Simo998 Member Posts: 35 Enthusiast
    Sorry for bringing up old thread but seems alot people like me  want dual boot in their new Asus Nitros (or Helios or Predators) 
    but thanks @JordanB ,this is what was missing for me in all I was reading about dual boot.(ie  The reason it has to be done "before" installation)

    Because I can boot the Ubuntu live disk no problem and I just need be clear before proceeding installation.
     I have the new Nitro 5 AN5-15-55, and plan to dual boot Ubuntu 20.04 and windows 10 in two different nvme drives....I have done before on other laptops but...

    just 2 questions:
    >Some people mentioned a "shimx64.efi" file , and many same as you instead mentioned set Uefi "secure trusted file" to "grubx64.efi file" in ? Is there a difference?

    >do we need to set "secure boot" back to "enabled " right after Ubuntu is Installed "before" first boot, or Secure boot disabled is still ok? Some people are saying it doesn't matter and some are saying we must do it? Appreciate any advice.

    thanks again.

     Acer Nitro 5 AN5-15-55, 16Gb RAM, i7 10750H, GTX1650Ti , 2x nvme drives + 1tb SATA SDD, dual boot 2xdrives Ubuntu 20.10 and Windows 10
  • storfot51storfot51 Member Posts: 24 Troubleshooter
    when rebooting the GNU GRUB menu presenting following options:
    -Linux Minmt 20.3 Cinnamon
    -Advaced choise for Linux Mint 20.3 Cinnamon
    -UEFI Firmvare settings
    Iused the topp choise: Linux Mint Cinnamon.
    Then a following message appeared:
    error: /boot/vmlinuz-5.4.0-91-generic has invalid signature.
    error: you need to load the kernel first

Sign In or Register to comment.

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer

Drivers &