ES1-132 cannot install other OS than Windows 10, BIOS options missing

fabplfabpl Member Posts: 7


last week i bought the ES1-132, first i tried to install Ubuntu and afer installing i always got the message "No bootable device". Then i tried to install Windows 7 64Bit, which froze during the installation proccess after the "Starting Windows" screen. I researched both problems and all narrowed down to change the Boot Mode in the BIOS.

But the option to change the Boot Mode or "Select an UFEI file as trusted for execution" is not there. I set all the passwords but the option didn't show up.Installing Windows 10 works without a problem.


Is there any other solution to my problem?


FAQ & Answers

  • IronFlyIronFly ACE Posts: 18,415 Trailblazer

    Ubuntu x64 (64 bit) boots under UEFI settings, so probably something went wrong (if you tried a dual boot OS) on windows boot manager or linux grub.


    about Windows 7, you need to disable UEFI and set legacy.


    remember also to check your BIOS version and update it:

    1.08 is the latest:

    I'm not an Acer employee.
  • fabplfabpl Member Posts: 7

    Thanks for the fast answer.

    To Windows 7: I already updated the BIOS to 1.08. But the option to disable UEFI and set legacy in the BIOS is MISSING.

    To Ubuntu (64 Bit): i checked this several times( with "[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS"), Ubuntu booted under UEFI Settings.


  • IronFlyIronFly ACE Posts: 18,415 Trailblazer

    So, under Boot BIOS tab, there's not BOOT Mode option available?


    if it's available, and UEFI is locked, you need to set a supervisor password to switch to Legacy.


    if it's need to wait another BIOS version, hoping Boot menu will be enabled.

    I'm not an Acer employee.
  • IronFlyIronFly ACE Posts: 18,415 Trailblazer

    ok, double checked and your laptop model is missing the Boot mode option...

    I'm not an Acer employee.
  • fabplfabpl Member Posts: 7

    yes, boot mode option is missing and i set the supervisor password.

    I hope the retailer where i bought it takes it back, i just bought to use it with Linux...

  • vpetervpeter Member Posts: 3

    Hi All,


    Have You already solved the problem?

    I want to install Ubuntu this laptop.



  • fabplfabpl Member Posts: 7


    Thanks for your answer. Installing is not the problem, it installs without a problem. The problem is that you can not set trusted UEFI files in the BIOS, therefore the netbook only allows booting into the windows bootloader and not into grub or any other bootloader.

    Also you cannot add grub to the windows bootloader with BCDedit, it's somehow restricted, i don't know why.

    Even more annoying: If you delete the windows bootloader it will install it self automatically on next boot.

    I think ACER just wants you to use Windows 10 with it...



    Yes i found a solution, i posted it here:


    I found this instruction to add the UEFI entry with the rEFIind bootloader:

    That didn't work for me because the netbook reinstalls the Windows Bootloader automatically after it's deleted.

    My solution:
    I installed the rEFInd boot loader into /boot/efi/EFI/Microsoft/Boot (where Windows bootloader files are located on my machine).
    Then i deleted bootmgfw.efi and renamed refind_x64.efi to bootmgfw.efi.
    After that it booted into the rEFInd bootloader and from there you can boot in any bootloader you want.
    (Documentation for rEFInd:

    Maybe one of those approaches will work for you. Took me way too long to figure it out...



  • vpetervpeter Member Posts: 3

    Hi Fabpl,


    Thanks your soultion. (Nice work Smiley Happy)

    Do Your laptop contains preinstalled Windows 10 and do You want to use dual boot?


    I ordered "Acer Aspire ES1-132-P3MK" (with SSD) without preinstalled Windows. I think Limpus linux is preinstalled only.

    After I get my laptop I try to install ubuntu, and I will write my experiences to you.





  • fabplfabpl Member Posts: 7

    Yes, the laptop contained preinstalled windows 10. I got the ES1-132-C0VW with a 32gb emmc, so there is not enough disk space for dual boot. But it is certainly possible with a bigger hd.


    I think, with preinstalled Linux, you will not run into the problems i had.

    But it would be interesting to hear how it went with your model.

  • S1024BS1024B Member Posts: 2

    Did you manage to install any linux distribution ?


    I got a ES1-132 couple of days back with pre-loded command line linux. I have not been able to install any Linux distribution on it. 


    Ubuntu installation doesn't even start. Debian intallation works ok untill the install grub step and fails at that.


    I have set superviosr password and disabled secure boot.


    Any help would be much apppreciated. 

  • vpetervpeter Member Posts: 3

    I am still waiting my laptop. (Acer Aspire ES1-132-P3MK)

    After I get it, I try to install ubuntu 16.10, and I will write my expreiences to you.





  • fabplfabpl Member Posts: 7

    S1024B wrote:

    Did you manage to install any linux distribution ?


    I got a ES1-132 couple of days back with pre-loded command line linux. I have not been able to install any Linux distribution on it. 


    Ubuntu installation doesn't even start. Debian intallation works ok untill the install grub step and fails at that.


    I have set superviosr password and disabled secure boot.


    Any help would be much apppreciated. 

    For Debain:

    Ignore the grub error, with lubuntu i had the same issue. Install rEFInd bootloader on a usb stick ( Boot from it and try to start Debain from there.

    If it works intall refind as your new bootloader.(Not a very nice solution, but it worked for me).

    For Ubutnu:

    You didnt provide us with enough information what happens if you try to install ubnutu.

    I assume you get a black screen if you try to boot ubuntu from a usb stick.

    Try to set nomodeset in grub.:

  • S1024BS1024B Member Posts: 2
    Thanks for the reply.

    If I ignore the debian error then on next boot, I end up on grub command line. Trying to boot from grub command line results on some error ( I can't remember the error, will try to fill it in later).

    Is installing rEFInd a permanent solution or would u require the USB stick every time you boot?

    Ubuntu 16.10 installation didn't report any errors. However, booting after installation ends up at 'no bootable device' screen. Tried using boot-repair after that but was of no help.

    Will install debian again and see if rEFInd will make it work.

  • fabplfabpl Member Posts: 7

    You can use refind permanently as bootloader.

    Also you can try to boot your ubnutu installation with it(i had the same problem with the no bootable device screen).

    If you post the output of "efibootmgr -v" i can help you with your ubuntu installation.


  • MegaParsecMegaParsec Member Posts: 100 Skilled Fixer



    Following should work without using rEFInd.


    1. Create an EFI-Shell bootable Stick
    2. Disable secure boot and boot up the efi shell
    3. make sure your Ubuntu usb-stick is also connected
    4. Map the efi partition (ESP) with FS0: or FS1: or FS2:, ……
    5. You can check if you mapped the ESP partition with the command vol.
    6. run the following commands

    cd EFI

    mkdir Linux

    cd Linux

    mkdir Boot

    cp FS0:\EFI\BOOT\bootx64.efi FS1:\EFI\Linux\Boot\bootx64.efi


    In this example you copy the bootx64.efi of your Ubuntu usb drive to the esp partition.

    Please check your partiton label "FS0", "FS1", "FS2" and so on, this could be different on your system.


    Please install Ubuntu. Make sure secure boot is still disabled.

    After the installation is finished open a terminal and run following command.


    sudo efibootmgr --create --disk /dev/mmcblk0 --Part 1 --label "ubuntu"  -- loader "\\EFI\Linux\BOOTX64.efi "

    mmcblk0 <- could be different on your system


    Unfortunately I can’t attach the files needed to create a bootable efi-usb-stick but you can download it here.





  • spektro37spektro37 Member Posts: 3 New User



    I have the same problem with my Aspire ES1-132-C22B.


    I have tried to follow your instructions and have copied over the bootx64.efi file to \EFI\Linux\Boot\, but when I try to run the last command I get an error message which is saying that 'Part 1' is an unknown command. If I remove the '--Part 1', the command is successfully executed. Could you please advise if I am doing something wrong?




    I have managed to execute that command by replacing the uppercase 'P' with a lowercase 'p' (--part 1), but the system still doesn't see any other bootable device, except the flash drive.


    The only difference of the steps I gone through from your instructions is that I didn't use the EFI bootable media to get the bootx64.efi to /EFI/Linux/Boot/.


    Also I have tried a different version of your command, but with no luck:


    sudo efibootmgr --create --disk /dev/mmcblk0 --part 1 --label "ubuntu"  -- loader "\\EFI\Linux\Boot\bootx64.efi"

    In my case "mmcblk0" is mmcblk0p1.


    When I first run the command, the new entry is added as the first one in the boot order, according to efibootmgr, but after the first attempt to boot, it is disappearing from the boot order. And like I already mentioned, it is not seen in BIOS at any time.

  • MegaParsecMegaParsec Member Posts: 100 Skilled Fixer



    You are right, the P must be lower case, sorry for that.


    Could you please check your bios version?

    I figured out that my advice only works with bios 1.06 or newer.

  • spektro37spektro37 Member Posts: 3 New User



    sorry for a delayed reply. My BIOS version is 1.08.


    I have found a way to boot Ubuntu on a russian linux forum, where the reason why does this problem exist is explained. The reason for it is that someone naughty has hardcoded all possible paths you can use to boot your system ('thanks a lot'). The paths are:


    \EFI\Linux\BOOTX64.efi (Linux)
    \EFI\Microsoft\Boot\bootmgfw.efi (Windows Boot Manager)
    \EFI\ubuntu\shim.efi (ubuntu SECURE)
    \EFI\ubuntu\shim$cpu$.efi (ubuntu SECURE)
    \EFI\ubuntu\grub.efi (ubuntu NORMAL)
    \EFI\fedora\shim.efi (Fedora)
    \EFI\android\bootx64.efi (Android)
    \EFI\opensuse\grubx64.efi (topenSUSE)
    \EFI\redhat\grub.efi (Red Hat Linux)
    \EFI\SuSE\elilo.efi (SuSE Linux)
    \EFI\ubuntu\grub$cpu$.efi (ubuntu NORMAL)


    In my case, after installing Ubuntu as usually (my goal was to have Ubuntu as the only OS), I have booted Ubuntu from my flash drive and using the Terminal:

    1. Mounted the EFI partition;

    2. Created the Linux folder (/EFI/Linux/);

    3. Copied everything over from the default intallation directory into that Linux folder;

    4. Copied the bootx64.efi from the flash drive (not sure if this was needed);


    After that I have restarded the system, a new boot option "Linux" has appeares in BIOS.


    That's it. I hope this information will be useful to anyone else.

  • AmrutaAmruta Member Posts: 1
    Could you please give a bit more description of the steps you took? Although I have used ubuntu before, I am not very comfortable with programming it so much. I can't seem to be able to mount the efi partition. It shows up when I run fdisk, but when I try to mount it, I get an error message.
Sign In or Register to comment.

Who's Online792

+785 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

  • By Acer-Ingrid -
    3D Artist Catelloo invites us to meditate on his #ConceptDo creative process when making his most recent animation ‘Donate’.When ConceptD approached me to create a 3D looping animation with the (Read more…)
    0 20

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer

Drivers &


Get Product Information
( only)

Acer Support

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1114

Total Points:3892

Total Accepted Answers: 153

Leostat High-End Contributor