Examples: Monday, today, last week, Mar 26, 3/26/04

ES1-132 cannot install other OS than Windows 10, BIOS options missing

2»

FAQ & Answers

  • spektro37spektro37 Posts: 3Member New User

    To mount the EFI partition, you need to:

    1. Install Ubuntu;

    2. Boot using Ubuntu USB and select "Try without installing";

    3. Launch Gparted to get the EFI partition address. In my case it's "/dev/mmcblk0p1";

    4. Open the Terminal (ctrl + alt + T);

    5. In the Terminal execute the following to create a directory in the "media" folder and to mount the EFI partition to that folder:

    sudo mkdir /media/EFI
    sudo mount {replace_this_with_the_address_from_step_3} /media/EFI

    In my case it would look like:

    sudo mkdir /media/EFI
    sudo mount /dev/mmcblk0p1 /media/EFI

    That's it.

     

    After that, you need to create the /EFI/Linux/ folder. This can be done with the following command:

    sudo mkdir /media/EFI/EFI/Linux

    When you will have the folder ready, you can copy all the existing files from the folder that was created during Ubuntu instalation. In my case, the default folder was /EFI/ubuntu/. To do so, you can use the following command:

    sudo cp -R /media/EFI/EFI/ubuntu /media/EFI/EFI/Linux

     

    I hope this helps.

  • arayanarayan Posts: 2Member

    1a. could someone please explain what is the bootloader, 1b. where it is stored on the C drive ?

    A. bootloader comes after the bios and is used to boot the operating system.  This is where the issue is on this computer.    / = root directory. a bit different with linux http://www.linfo.org/root_directory.html

     

    2. if you use refind as a bootloader, what is the original bootloader that you are replacing ?

     

    3. when you type

    /media/EFI

     is that basically C:/media/EFI ?

     

    A. kind of but not really   - The root directory is the directory on Unix-like operating systems that contains all other directories and files on the system and which is designated by a forward slash ( / ).

     

    4. is there any way to replace the bios on the machine. I have been in contact with people at acer, and they implied they have no intention of changing the bios and don't see this as a fault.  I can copy paste the conversation here. I know there are alternative bioses out there like coreboot, but has anyone tried or managed to successfully complete this ?   thankyou

  • PetrPigPetrPig Posts: 1Member

    New BIOS 1.09

     

    1.Support new MXIC25L64 bios flash part.

    2.Support WMI serial number and UUID.

  • gpyragpyra Posts: 1Member

    Dear Acer,

     

    Please make a "Legacy Boot" BIOS option available on Acer Aspire ES1-132 series laptops.

    I don't like to have a separate partition for EFI on my disk.

     

    Thank you!

  • OneManOneMan Posts: 2Member New User
    i have a same problem of everyone here. 
    my aspire es1-132-CONU dont have also a legacy or uefi options on (boot tab).
    1. first i tried to set a password on superv.password then disable the secure boot on (boot tab). 
    2.then i enable the f12 boot on (security tab). then f10.

    after try rebooting again it still show [no bootable device].

    i tried to removed the hdd of my unit and put it on other unit then install there the os/win10. then after installing it. i put it back on. but it still shows the same problem. 

    NOTE:
     i tried to install win10 on my unit. but checking the bios I didn't find my bootable flashdrive. it only shows the hdd of my laptop. 
    rebooting it i press f12 to go to boot manager. but it didn't show any bootable devices there. 

    please help!  thanks in advace. 
  • OneManOneMan Posts: 2Member New User
    OneMan said:
    i have a same problem of everyone here. 
    my aspire es1-132-CONU dont have also a legacy or uefi options on (boot tab).
    1. first i tried to set a password on superv.password then disable the secure boot on (boot tab). then 
    disable the superv. password. 
    2.then i enable the f12 boot on (security tab). then f10.

    after try rebooting again it still show [no bootable device].

    i tried to removed the hdd of my unit and put it on other unit then install there the os/win10. then after installing it. i put it back on. but it still shows the same problem. 

    NOTE:
     i tried to install win10 on my unit. but checking the bios I didn't find my bootable flashdrive. it only shows the hdd of my laptop. 
    rebooting it i press f12 to go to boot manager. but it didn't show any bootable devices there. 

    please help!  thanks in advace. 

  • PandabearPandabear Posts: 1Member New User
    Hi Guys. I would like to ask with the same problem but instead of installing linux or ubunto. 

    I would like to change Endless linux to windows OS. How can i install that on my laptop? I brought it yesterday and i tried to boot using pendrive and also on CD but the Legacy option is missing on the boot menu. Please help guys thanks
  • vbnvbn Posts: 2Member New User
    Install ubuntu 

    for who comes to ask for help and does not receive it in this site, I will leave a simple solution, I walked through this site of Acer without help, for a problem created by them.
    I've been days, weeks until trying to find out how to install and use Ubuntu 16.04 lts, ​​and I think I managed to solve my problem, I hope it serves you as well, within the possible.
    First, install mkusb.
    Second, get a high capacity micro pen drive in my case I use a sandisk nano micro 128gb
    Third, with gparted, create a 32 fat partition, with about 100 mb and another using the rest of the ext4 space.
    Fourth, use mkusb to install (the iso refind) on the fat 32 100mb partition.
    Fifth, use mkusb to create an installation pen, with ubuntu 16.04 lts, ​​do not use unetbootin, because this program has a bug that gives problems in some debian distros.
    After the installation pen is created, insert it into the usb port and start a live session, enter gparted, and delete everything on the disk (32gb emmc) mmcblábláblá ...
    Shutdown, and restart the menu to install ubuntu, distro or whatever, go configuring and when it appears on the board erase everything and install ubuntu 16.04 lts .... is what you have to choose.
    After the installation pen is created, insert it into the usb port and start a live session, enter gparted, and delete everything on the disk (32gb emmc) mmcblábláblá ...
    After this reboot the system, remove the pen with the distro, enter the other pen nano where they installed (refind), load the power button, a refind menu appears, with two boot options, choose any one, and will start ubuntu 16.04 lts on the internal emmc drive.
    As the space is little on the internal drive, the pen partition (ext4) will be to store date.
    Create the folders downloads, video ... etc in the ext4 partition of the pen drive, and trim these folders from the location (home) replacing them with shortcuts.

    I hope it helps you ...
  • vbnvbn Posts: 2Member New User
    ps ...........

    i forgot to tell, need secure boot desabled.


  • Robert0818Robert0818 Posts: 1Member New User
    A mi no me muestra boot mode para elegir la opción legacy para instalar con cd' (DVD) QUE HAGO YO HAY 
    Mi pc es aspire ES1-432
  • ronaldstronaldst Posts: 4Member New User

    Please make a "Legacy Boot" BIOS option available on Acer Aspire ES1-132 series laptops.

    I don't like to have a separate partition for EFI on my disk.


  • postingterus168postingterus168 Posts: 2Member New User

    I am still waiting my laptop. (Acer Aspire ES1-132-P3MK)

    After I get it, I try to install ubuntu 16.10, and I will write my expreiences to you Capsa Susun.


  • postingterus168postingterus168 Posts: 2Member New User
    edited April 1

    I am still waiting my laptop. (Acer Aspire ES1-132-P3MK)

    After I get it, I try to install ubuntu 16.10, and I will write my expreiences to you.

  • eddiebelfasteddiebelfast Posts: 11Member

    Tinkerer

    I have the same model but with the eMMC drive. When I first got it I couldn't get it to change to legacy mode.  I eventually got it to change but it required TWO changes on two different screens.
    Go the Security tab and set the Supervisors password, then got to the Boot tab and set the secure boot to disabled.
    Make sure you write down the password and keep it safe. I wrote mine on a piece of paper and taped it to the bottom of the comp.
  • mr66pmr66p Posts: 1Member New User
    edited April 3
    For ubuntu:
    solution by fpl2 on ubuntuforums

    The "refind" solution works on my ES1-132 crap.
    BIOS 1.15., hdd replaced with ssd, Supervisor password set ( not sure if any of this matters but you`ll need Windows to update your BIOS so do it if you can - thank Acer for this too)

    It goes like this:
    - enable secure boot
    - install ubuntu - if secure boot is not enabled the installation won`t create EFI partition
    - after install the ubuntu won`t boot
    - disable secure boot - (not sure if this is needed but I`ve done so many things that this is how it was left on my successful run )
    - boot from the flash drive using "try ubuntu..."
    - mount the efi partition somewhere  - in my case /mnt/efissd
    - download and extract the "refind" package somewhere else
    - go to /mnt/efissd/EFI/
    - create Microsoft/Boot dir - endresult should be /mnt/efissd/EFI/Microsoft/Boot
    - copy refind_x64.efi from "refind" package to EFI/Microsoft/Boot/bootmgfw.efi
    - reboot

    Thanks to all the good people who found this solution in this and other threads







  • The_LoudSpeakerThe_LoudSpeaker Posts: 11Member

    Tinkerer

    spektro37 said:

    To mount the EFI partition, you need to:

    1. Install Ubuntu;

    2. Boot using Ubuntu USB and select "Try without installing";

    3. Launch Gparted to get the EFI partition address. In my case it's "/dev/mmcblk0p1";

    4. Open the Terminal (ctrl + alt + T);

    5. In the Terminal execute the following to create a directory in the "media" folder and to mount the EFI partition to that folder:

    sudo mkdir /media/EFI
    sudo mount {replace_this_with_the_address_from_step_3} /media/EFI

    In my case it would look like:

    sudo mkdir /media/EFI
    sudo mount /dev/mmcblk0p1 /media/EFI

    That's it.

     

    After that, you need to create the /EFI/Linux/ folder. This can be done with the following command:

    sudo mkdir /media/EFI/EFI/Linux

    When you will have the folder ready, you can copy all the existing files from the folder that was created during Ubuntu instalation. In my case, the default folder was /EFI/ubuntu/. To do so, you can use the following command:

    sudo cp -R /media/EFI/EFI/ubuntu /media/EFI/EFI/Linux

     

    I hope this helps.

    Hii I have tried this but it's not working. Any Suggestions?
2»
Sign In or Register to comment.

Who's Online213

Acer-Harvey
Acer-Harvey
Acer-Jose
Acer-Jose
Acer-Manny
Acer-Manny
Acer-Tim
Acer-Tim
Amortis
Amortis
BERTROP
BERTROP
christy1
christy1
Dadyngwie
Dadyngwie
egydiocoelho
egydiocoelho
GVH
GVH
Hastings
Hastings
Jack22
Jack22
JulianDimov
JulianDimov
kilari_helios_300
kilari_helios_300
Kingkishor
Kingkishor
Kozidis
Kozidis
MaClane
MaClane
Myll3r
Myll3r
pranshu626
pranshu626
Rudy21
Rudy21
Svenkn89
Svenkn89
System
System
Vindy17
Vindy17
+190 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.