image

Aspire V 17 Nitro (VN7-791G-792A) won't power on?

Hi all.  Purchased this laptop in July '15, installed Windows 10, everything has been fine.  Until yesterday... pressed the power button, and ...nothing.  I always keep it plugged in, the battery light is on (blue) showing a full charge.

I removed the power cord, hoping to let the battery run down, but as yet the light has only gone to yellow (meaning low power).  Other than that, it is totally unresponsive.  I tried holding down the power button for different lengths of time, but still nothing.

 

Besides this, are there any suggestions?  Anyone else experienced this?

FAQ & Answers

  • Hello,

     

    I would try resetting the battery using the pinhole reset button located in the bottom.

    France
  • stardogchampstardogchamp Member Posts: 2

    Today I learned...

    Thanks for the reply!  That worked, I hadn't noticed the reset.  Powered on just fine!

  • You're welcome

     

     

     

     

    ... The paperclip is the best tool of IT! Smiley Very Happy

    France
  • jwgoleyjwgoley Member Posts: 1

    I have an Acer Chromebook 11 and need to reset the battery, but I don't see a pinhole on the bottom to do so.  Do you know where it is located for this particular Acer product.  (CB3-111)

  • Hi jwgoley,

     

    What is your issue exactly? Could you describe it?

     

    France
  • gardnergardner Member Posts: 2 New User
    I am having the same problem.  I was using my laptop the other day, same model.  It turned itself off and now it wont power up or even charge.  The blue and orange LEDs dont even come on when the power adapter is plugged in.  Got a new adapter thinking maybe it was fried, but that wasnt it.  I tried the battery reset as well, nothing.  Any thoughts?
Sign In or Register to comment.

Who's Online1.5K

1nside
1nside
Acer-Jose
Acer-Jose
Acer-Samuel
Acer-Samuel
Alejandro_AC
Alejandro_AC
BrunoPolli
BrunoPolli
D0oonnna
D0oonnna
egydiocoelho
egydiocoelho
FMC_
FMC_
Goldlack60
Goldlack60
JayVessey
JayVessey
Jheisson_Sierra
Jheisson_Sierra
NFurlan
NFurlan
VictorAugustoOpieko
VictorAugustoOpieko
+1.5K Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers