Examples: Monday, today, last week, Mar 26, 3/26/04

Elan Touchpad not recognized after Anniversary Update

Aspire ES1-711-P14W with Elan touchpad. Worked before the update now it does not function at all and is not seen by the OS. Windows 10 Pro Version 1607 Build 14393.10, Install drivers and issue remains:

  • Chipset Intel Chipset Driver
  • IO Drivers Intel Serial IO Driver 604.10135.1001.53001
  • MBI Intel Sideband Fabric Device Driver 1.70.305.16316
  • TXE Intel Intel TXE Driver
  • TouchPad ELANTECH Touchpad Driver


FAQ & Answers

  • GoddessOfCarbsGoddessOfCarbs Posts: 2Member

    This exact same thing is happening to me as well.  I just bought the Acer Aspire V-15 a few days ago, and after the Windows updates, the touchpad would stop working a few minutes after start-up, or it would be working fine, but not work after it came out of sleep mode.  If Acer doesn't come up with a fix for this soon, I am returning the computer.  Thank goodness for Costco's generous 90-day return policy.  I am not tech-savvy enough to figure this out on my own!

  • AvidSurvivalistAvidSurvivalist Posts: 24Member

    Well my warrenty is up so I have a $500 paper weight... Every single Acer electronic I have ever owned was a **bleep**, Acer Aspire 5534 laptop gave me 2nd degree burns and almost burnt down my house because it got so hot and it started smoking and sparks flew out the charger port.


    [inappropriate content removed]

  • Acer-JoseAcer-Jose Posts: 821Administrator Community Administrator

    Hello everyone,


    I'm sorry that you've ran into this issue.  We show this ES1-711-P14W model shipped with 8.1 and is eligible for Windows 10 Home. Windows 10 Pro is not an eligible upgrade path so we would be unable to support that operating system. If you are running the latest available Elan touchpad driver the best way to eliminate this being a hardware problem is to restore the system back to factory configuration. If the touchpad works, then it likely is the Windows Update that caused this. With the release of any major Windows update there is always a possibility of drivers malfunctioning but these issues should be resolved with the regular following updates.



    Acer Technician Acer-Jose

  • GoddessOfCarbsGoddessOfCarbs Posts: 2Member

    Well my computer shipped with Windows 10, so where's the solution?



  • AvidSurvivalistAvidSurvivalist Posts: 24Member

    I have no idea how I even got Windows 10 Pro! That's what it downloaded when I upgraded! It's practically the same as Home, it just has remote desktop and a few other things. I don't have unlimited internet so I can't just download Windows 8.1... It cost me $80 worth of data just to download Windows 10! If it is not elligible than how did it activate? Also if you can't update YOUR drivers for YOUR MACHINES YOU SELL, I'll keep that in mind when I replace this computer! My next computer WILL NOT BE AN ACER! What kind of company doesn't support their practially new product?!?

  • AvidSurvivalistAvidSurvivalist Posts: 24Member

    There is nothing wrong with the touchpad, to get it to work you have to set it to basic in the BIOS, but it won't scroll which is very annoying, If it is set to advanced, Windows 10 will not recognise it, It doesn't have anything to do whether it is Windows 10 Home or Pro! They don't use different drivers for the editions of the OS! I am not going back to the downgrade Windows 8.1 was! It's not the Elantech driver it is either the IO driver or the TXE driver.

  • MoresbyMoresby Posts: 29Member

    Did you try uninstalling the touchpad from device manager and rebooting the laptop?


    This old school fix often solves these problems.


    Anyway, it's worth a try.

  • padgettpadgett Posts: 3,923ACE Pathfinder

    Posted it before but you can uninstall the driver then reinstall using "compatability" mode for the driver and set to Windows 8.


    Unfortunately I do not have the model you do and have not had the issue.


    ps the only difference between home and pro is that certain features are turned on/off. No difference in the base driver set.

  • AvidSurvivalistAvidSurvivalist Posts: 24Member

    The problem is when the touchpad is set to advanced in the bios, windows does not detect it at all... I could set and install the driver all day long but it's not detected.

  • padgettpadgett Posts: 3,923ACE Pathfinder

    Is the touchpad working in the BIOS but not found in Windows. Is there an "unknown device", possibly under USB, in Device Manager ?

  • andyrewkirkandyrewkirk Posts: 5Member

    Worked on my ES1-512, go into bios, change touchpad to basic, log on, install IO drivers from acer site, restart, go in bios, change touchpad back to advanced.

  • Acer-JoseAcer-Jose Posts: 821Administrator Community Administrator

    Hello everyone,


    First I would like to thank you for your patience regarding the touchpad issue that you reported on the ES1-711.  Microsoft has released a fix for this model; please run Windows Updates to install update KB3201845 to resolve the touchpad lag.


    Thank you,

    Acer CrewAcer-Jose

Sign In or Register to comment.

Who's Online164

+160 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!


Acer Community is now available in French! We are delighted to announce the addition of French to the list of supported languages in order to reach more users and expand on our mission to break the barriers between people and technology. You can access the French community from the drop down language menu located next to your username on the top right corner.

Participez aux discussions !

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.