Examples: Monday, today, last week, Mar 26, 3/26/04

Acer Aspire e5-573g. You can not install any one Linux distribution. The problem BIOS 1.25.

valbogovvalbogov Posts: 8Member

Linux not install UEFI and LEGACY. as I understand - not loading the kernel
Windows install in UEFI and LEGACY
reason - BIOS 1.25. BIOS version 1.15, there is no problem.

how to get back on the 1.15 BIOS?

why users should suffer because of the mistakes of Acer?

«1

FAQ & Answers

  • slowfoobarslowfoobar Posts: 3Member

    Wow, same problem with e5-573g-56rg which came with 1.25 already installed. After spending hours trying to install linux, I finally discovered this post. Please fix this.

  • OrekhovOrekhov Posts: 1Member

    I have the same problem. I've upgraded BIOS from 1.10 to 1.25 and my Ubuntu stopped working. It gives error: ACPI: Unable to load the System Description Tables. Also when I'm trying to install Ubuntu, Debian, Elementary OS it gives me the same error.
    When I was trying to install BIOS 1.11 from official acer website it gives the error like downgrade is not possible, because you have already install newer version.

  • digitalrendigitalren Posts: 7Member

    Hmmm...  Apparently, this issue has been identified since at least a few months ago by others:

     

    http://community.acer.com/t5/E-and-M-Series/Aspire-E5-573G-BIOS-downgrade/m-p/371730#M2050

     

    Incidentally, I'm having trouble getting Clonzilla (linux-based disk imaging distro) to run on my new E5-573G-56RG.  Chat support was able to show me how to create recovery media to return my machine to factory condition.  However, I wanted to be able to image my HDD after removing all the bloatware and installing my own programs and applications.  With BIOS set to "Legacy", I appeared to have been able to boot through to the splash screen, but could not load all the necessary components of the live CD.  I suspect the issues are all BIOS related.

     

    A whole bunch of folks got this computer taking advantage of good pricing at newegg.com recently.  At least three of us new owners over at reddit are running into snags of one sort or another.  It would be wise of Acer to escalate this and help us all find a solution.  Otherwise, I can see a whole bunch of negative reviews rolling in.

     

    For what its worth, I do hope a good solution is forthcoming.  I really would like to turn this competatively priced laptop into a poorman's linux programming workstation.

  • slowfoobarslowfoobar Posts: 3Member

    I figured out how to downgrade the bios.

     

    Go to: http://us.acer.com/ac/en/US/content/drivers

     

    Search by Product Model:

    Aspire E5-573G

     

    Select the right OS and download a bios. In my case I downloaded 1.15.

     

    Run the ZRT_115.exe.

     

    It will fail.

     

    But before you close the installer, go to C:\Users\name\AppData\Local\Temp\

    Search for a folder (random letters).tmp

    There should be a H2OFFT-W.exe and zrt.rd file in there.

    Just copy this folder and close the failing install.

     

    In that copied folder, edit the platform.ini file.

     

    Before:

     

    [BIOSVersionFormat]
    ;[nb4-version] +
    BIOSVFEnable=1
    VersionFormat=XN.NN

     

    After:

     

    [BIOSVersionFormat]
    ;[nb4-version] +
    BIOSVFEnable=1
    VersionFormat=XN.DD

     

    The VersionFormat value now has 'XN.DD' instead of 'XN.NN'.

     

    This will ignore the fact that 1.25 -> 1.15 is a downgrade.

     

    Prepare for a reboot. I.E. close unnecessary applications. Because it'll happen automatically after running the installer.

     

    Run H2OFFT-W.exe.

     

    Upon reboot, you'll see a bios installing progress bar.

     

    After that is done, press F2 during startup to get to bios. The version should now be 1.15.

     

    At this point I set a password, turned off UEFI, and swapped my hard drive out for a fresh SSD. Ubuntu finally installed.

  • digitalrendigitalren Posts: 7Member

    VERY NICE!!!

     

    But...

     

    May I ask if your particular model of e5-573g was preloaded with Windows 8(.1) or Windows 10?

     

    Mine happens to be less than a week old with Windows 10 and BIOS 1.25 straight out of the box.  (no COA or license key?  anyone else?)  In other words, I never had the opportunity to experience an older BIOS where Linux works without problems.  I am concerned that Win 10 may be 1.25 specific and downgrading would brick my new machine.

     

    Never mind.  I just saw your post above and realized you already said your set up is like mine being preinstalled. 
    Thanks for taking one for the team in finding this solution!

  • slowfoobarslowfoobar Posts: 3Member

    Yep, Windows 10 for me. It's very likely it's the same laptop as yours. I was able to boot into Windows 10 even after downgrading the bios to 1.15.

     

    As for the linux side, everything seems to work except for wireless.

     

    I think the wireless card is: Qualcomm Atheros QCA9377 (pci id 168c:0042)

     

    Which is not yet supported. It'll eventually be supported by the ath10k driver.

  • aztwantieaztwantie Posts: 2Member

    Thank you slowfoobar, I did the downgrade and could finally run Linux on my new machine. Someone at Acer should really do better quality control, being forced to do a downgrade in order to get something running again should never be the solution.

  • najit97najit97 Posts: 6Member

    Tinkerer

    had been working hard to install Ubuntu in my new laptop, same model as yours. Been reading all kinds of solutions for the past 5 days, non-stop! Hope this clears things now. Will try it out and see man. Thanks a ton! Smiley Very Happy

  • xstationxstation Posts: 4Member

    Tried your idea today

     

    a program called insyde appeared and error message read when trying to insall v1.15 was

    'the version of ROM file is not newer than that of the BIOS --which is 1,25

     

    a ny ideas 

     

    thanks

    xstation

  • aztwantieaztwantie Posts: 2Member

    In that case you probably did not completely follow the instructions, merely running the installer without modifying the ini file as described will not work.

  • ranjitsinghranjitsingh Posts: 10Member

    I'm also the victim of Acer and how Acer is fooling around with their customer with low price tag laptops. I recently purchased this model laptop and tried installing
    centos 7 but it failed ,When contacted acer support they said said acer don't support linux and told to use Window 8 or 10 instead,

    My Question is how safe it would be to downgrade BIOS from 1.25 to v1.15 since Acer support is objecting to BIOS downgrade and
    Why Acer is sitting so quite and not coming with a solution which will help their customer to use the OS they want. We have not paid to be fooled around.

    Please also suggest how to escalate this to Acer .I personally feel acer authorised service center is of no use.     

     AND

    Thank you for this post

  • najit97najit97 Posts: 6Member

    Tinkerer

    Ranjitsingh,

     

    It is completely safe to downgrade tthe bios. The newer BIOS just gave a few minor bug fixes, which are not  of great importance.

     

     

  • ranjitsinghranjitsingh Posts: 10Member


    Hi Najit97,

    Thank you for your reply , I will downgrade my BIOS v1.15 but I'm concerned about some issue I had with BIOS v1.15 i.e

    My laptop crashes frequently with following error '[0.033338][Firmware Bug]: the BIOS has corrupted hw-PMU resources (MSR 38d is b0)
    PNP 00:09: can't evaluate _CRS:1
    mce : unable to init device /dev/mcelog (rc: -5)
    *ERROR* render ring : timed out trying to stop ring.
    *ERROR* failed to set render ring .

    Above error was when I was using oracle Linux/centos 7.1 ,7.0 and 6x .


    Currently when I'm using window provided by service center I have following error "Your PC ran into a problem and needs to restart ,We are just collecting some error
    info , and then we'll restart for you . if you'd like to know more, you can search online for this error  MACHINE_CHECK_EXCEPTION"

    Service center made me switch from oracle linux 7 to 6 to window 10 to 8 . For the silly reason they don't support linux and my laptop not support Window 10.
    Funny acer official site says it support window 10 .

    laptop detail Aspire E 15 E5-573G-76AA
    PROCESSOR I7
    RAM 16GB
    Purchased a month ago.
     
    Would you suggest anything.

    Thank you again , I have also emailed to acer on the provided email address.

  • najit97najit97 Posts: 6Member

    Tinkerer

    Your laptop should support Windows 10. I don't see any reason for it not supporting!
    Why isn't it supporting?

     

    And I have never used v1.15 of BIOS before, I got my laptop with only 1.25v. I am currently not experiencing any of such problems after downgrading, though I use Windows 10 Home, Win 10 Pro and Ubuntu 14.04 only.

     

    I will see if I can get more details about it, though!

     

     

     

     

     

    Thank you.

  • ranjitsinghranjitsingh Posts: 10Member

    Yes, You are right my laptop should support window 10 but it is Acer service center people who's telling me that it will not support window 10 and they thenselves installed window 8 and forced me to switch to window from Linux (Acer must have been bribed by Microsoft to force their user to use Window. LOL).

    My Laptop came with BIOS v1.15 and due to the mentioned issue it was upgraded to BIOS v1.25 and thereafter Linux installation issue came.

    If you want to replicate the issue then , here is what I did .

    On my laptop with Linux/Window OS
    1. Installed Vmware 11 .
    2. Created three virtual machine or to say any number of virtual machine 1,2,etc (To test clustering at Database Level).
    3. Internet connection through Dongle stick (Just to check email and browsing ,nothing else ) .
    4.If I simply start my system and keep my system IDLE than its fine .No issue (This is what acer is testing ).
    5.But When I start my virtual machine and keep using them ,system crashes, sometime it happens immediatly and sometime in hour or so with BIOS Error.
    6.I also assumed issue might be with Vmware but it happen with other version of VMware also i.e Vmvare v11,v10 and with v8.
    7.Also tested this with Oracle Virtual Box with same result .
    8.When explained this to Acer support instead of finding any solution , reviewing log and checking probable issue ,all they did was install and reinstall of Window .

    Intresting and funny thing about this was ,one of acer representative told me , why you didn't tested this while making purchase . I don't think there would be any laptop vendor who will let me test all this before making final purchase.

    Acer Team if you are reading this , Obiously you guys reading this else you people shouldn't have deleted the email ID which is available on Acer official sites publicly , Please be a port of solution and not a problem , Acer Please provide fix at the earliest and do respond to my email sent 2 days ago on the same ID you people have deleted from Najit97 comments.

    Thank you again najit97

  • najit97najit97 Posts: 6Member

    Tinkerer

    That is where you get the problem? Smiley Surprised

    Are you sure if BIOS has the issue? Because I have 3 OSs, Windows 10 Home (stock one), Windows 10 Pro and Ubuntu. And in the Windows Home edition I have Kali-Linux running already in VMware, and as of now I haven't experienced such problems! I do use a USB dongle for the VMware and its of v12.1.

     

    And seriously LOL for that guy's response! Useless people working out there.

     

    They had sent me a private message saying that the mail ID I provided has been removed and I had rreplied them in a way similar to what you have said, asking them to rather provide a solution if they are reading the comments.

    And now my reference to their action in the previos comment has also been removed. I also guess you comment along with this comment of mine will also be edited soon Smiley Tongue 

    Sorry Acer!

     

    Welcome and thank you too, Ranjitsingh. Smiley Happy

  • ranjitsinghranjitsingh Posts: 10Member

    All I see is BIOS error when my system crashes, Per system log and dmesg , it's BIOS corruption issue and need to contact system vendor .


    This error is very state-forward when using Linux , But when I'm using Window , system crashes with error 'MACHINE_CHECK_EXCEPTION' , If its not BIOS issue then what it would be ?,I have already visited service centre for 2-3 times and left my system there for 5-7 days without any result.

     

    I really want to fix this at the earliest since its affecting my work but I'm not getting any help from Acer 

     

    I Have tried Different OS (Linux/Window) and different version of VMware . All the time I'm having same system crash concern . To me it's seems to be a faulty system and should be given replacement if there is no solution.

     

     

    Seriously ,even My collogue has started making fun of my selection of Acer over ASUS and Toshiba and for no action/reply from acer support.

     

    Thank you , atleast you are trying to understand the concern .

  • najit97najit97 Posts: 6Member

    Tinkerer

    Okay, fine, I will google it and see if I can get some solution. 

     

    Oh! :/ I hope even I don't feel like that and the Acer should do it good :/

     

    I have University exams from day after tomorow, I will come here later!

     

    Hope you get some solution soon. Do post it heere if you get any, so that it would be helpful for others Smiley Happy

  • flavioflavio Posts: 1Member

    Could you explain in more detail the steps. I HAVE THE SAME PROBLEM BUT I WANT TO INSTALL LINUX 1.25 BIOS NOT LET ME AND I DO NOT SPEAK ENGLISH SO would help WATCH THE VIDEO BECAUSE THERE IS BETTER UNDERSTAND
    POSTSCRIPT'm using the GOOGLE TRANSLATOR XD

  • ranjitsinghranjitsingh Posts: 10Member

    Hi flavio ,

    Sorry , But yet we are not able to figure it out how to install Linux on Acer E5-573G with BIOS v1.25 and waiting for an update from Acer .For now if you have install Linux on your system then you have to downgrade your BIOS to v1.15 as this  thread suggest .

     

    Good luck for your exams najit97.

Sign In or Register to comment.

Who's Online249

Acer-Harvey
Acer-Harvey
Acer-Jose
Acer-Jose
Acer-Karp
Acer-Karp
Acer-Manny
Acer-Manny
Alexandre8D
Alexandre8D
Ankitv
Ankitv
Astroflam
Astroflam
ayzee
ayzee
Balu
Balu
brummyfan2
brummyfan2
Ethan_
Ethan_
himizu
himizu
IVAN_PC
IVAN_PC
JLaps
JLaps
Johnwooaster
Johnwooaster
leoparisi
leoparisi
MaClane
MaClane
mafon
mafon
TravGamer
TravGamer
Wder
Wder
+229 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Good Design Aware 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.