Fans are at high rpm due to a design flaw. acer nitro 5 AN515 54 - No heat sink over the PCH.

Options
TTTTTTT
TTTTTTT Member Posts: 24 Networker
edited March 2023 in Nitro Gaming

There is a design flaw in the acer nitro 5 AN515 54. There is no heat sink over the PCH but the fans are sped up based on the PCH temperature. Even if the CPU and GPU are very cold, at around 40-50 degree Celsius, the fans speed up to 5000 rpm for the sole reason that the system increases the rpm based on the PCH temperature. The problem is that on this model, the heat sink was never designed to be over the PCH, there is no contact between the heatsink and the PCH. The fans are at high rpm till the PCH passively cools down on its own and it is very annoying. The PCH has a very good thermal threshold but the fans start to ramp up when the PCH reaches 65 degree Celsius. This issue can be fixed with a bios update or some other update but acer is not bothered with the user experience on their gaming laptops.

[Edited the thread to add model name to the titlle]

Best Answer

  • AnhEZ28
    AnhEZ28 ACE, Member Posts: 3,930 Pathfinder
    Answer ✓
    Options

    @TTTTTTT you can try to disable the Ethernet driver. It will reduce the stress on the PCH chip.

    Please remember to include @AnhEZ28 when you want to reply back to my comment so that I can check your response.
    Thank you and have a nice day!

Answers

  • JackE
    JackE ACE Posts: 44,691 Trailblazer
    Options

    »»>if the CPU and GPU are very cold, at around 40-50 degree Celsius, the
    fans speed up to 5000 rpm for the sole reason that the system increases
    the rpm based on the PCH temperature.

    Not according to specsheet. At those temps, neither fan should be running higher than about 2500-3000 rpm. It possible, but I'm not aware of other users with this model complainng about excessive fan speed noise for temps below about 85*C. Is it still under warranty?

    Jack E/NJ

  • TTTTTTT
    TTTTTTT Member Posts: 24 Networker
    edited March 2023
    Options

    My laptop is not under warranty. I formed my conclusion from my own observation for two years and also from the same observations that quite a few others have made. Tried every solution to cool down the CPU and GPU and they are actually cold as well, they are at 40-55 degrees most of the time. When the fan ramps up due to the PCH reaching 65 degrees it takes time for it to come to a lower rpm. Toggling the cool boost switch causes the fans to come down to a normal rpm.

    https://www.reddit.com/r/AcerNitro/comments/q1f283/i_feel_like_the_fans_ramp_up_too_easely_any_hint/

    https://www.reddit.com/r/AcerNitro/comments/q1f283/comment/hfiv6h7/

    https://www.reddit.com/r/pcmasterrace/comments/iraftu/trying_to_fix_acers_nitro_5_an5155451gt_lack_of/

  • JackE
    JackE ACE Posts: 44,691 Trailblazer
    Options

    »». Toggling the cool boost switch causes the fans to come down to a normal rpm.»>

    Well yeah. That's what coolboost does. Ramps up the fan speeds if GPU exceeds 85*C and CPU about about 90*C. Why do you have coolboost enabled if these temperatures aren't being reached?

    Jack E/NJ

  • TTTTTTT
    TTTTTTT Member Posts: 24 Networker
    edited March 2023
    Options

    I mean not like that I turn it on and turn it off then it goes back to 2000 or 1900 rpm from 4500-5000 rpm. When I check the cpu and gpu, they are at 40-55 degrees, while the fan is at4500-5000 rpm. I don't know if I'm right but when I see others say the same thing, I think this is because of no cooling on the PCH, I saw some guys DIY a copper thermal pad with thermal glue to cool it down.

  • TTTTTTT
    TTTTTTT Member Posts: 24 Networker
    Options

    Without toggling like this, the fan speed is not reduced and takes a long while for it to come down.

    I'm just annoyed so much by this can't even work on a word document without it ramping up.

  • JackE
    JackE ACE Posts: 44,691 Trailblazer
    Options

    As you will note, the NitroSense app separately senses the temperatures of the integrated Intel CPU/GPU and the discrete nvidia GPU. Accordingly, these NitroSensie temperature sensors are inside or intimate with the processor chips themselves, not outside. These are the temperaturesensors that the Fans should be controlled by. However, the fan speed controllers don't immediately react to certain temperature trip points or they'd be constantly & rapidly increasing and decreasing rpms just above and just below the trip point. There is some 4-5*C hysteresis or delays built in to the controllers above and below the trip point to avoid up/down rpm fan wailing which would be far more annoying.

    Jack E/NJ

  • TTTTTTT
    TTTTTTT Member Posts: 24 Networker
    Options

    Alright, you win, I might be wrong lol.

  • AnhEZ28
    AnhEZ28 ACE, Member Posts: 3,930 Pathfinder
    Answer ✓
    Options

    @TTTTTTT you can try to disable the Ethernet driver. It will reduce the stress on the PCH chip.

    Please remember to include @AnhEZ28 when you want to reply back to my comment so that I can check your response.
    Thank you and have a nice day!
  • TTTTTTT
    TTTTTTT Member Posts: 24 Networker
    edited March 2023
    Options

    @AnhEZ28 I'll try this, thank you for responding.

  • TTTTTTT
    TTTTTTT Member Posts: 24 Networker
    edited March 2023
    Options

    @JackE

    Here's another post that I found. This laptop has a flaw. Anyone who reads this must know that the PCH is the cause. I underclocked my CPU to 3.2 GHz and undervolted it. The CPU rarely goes above 65 degrees yet the fan still goes up to 4500-5000 rpm the moment the PCH hits 65 degrees.

  • TTTTTTT
    TTTTTTT Member Posts: 24 Networker
    Options

    @AnhEZ28 This worked, not ramping up anymore. Thank you so much for the suggestion and sorry for the late response, was occupied with my university work. What other drivers can I disable? This is a good fix in itself but I am now curious.

  • JackE
    JackE ACE Posts: 44,691 Trailblazer
    Options

    Thanks for reporting back on fix. 🙂

    Jack E/NJ

  • AnhEZ28
    AnhEZ28 ACE, Member Posts: 3,930 Pathfinder
    Options

    @TTTTTTT I haven't tested much, but disabling the Ethernet driver works best. Most of the other drivers are necessary in order for the Windows to work properly. You can also turn off Bluetooth if you don't use it. Just be sure to re-enable the Ethernet driver if you need it.

    Please remember to include @AnhEZ28 when you want to reply back to my comment so that I can check your response.
    Thank you and have a nice day!
  • bekkboi
    bekkboi Member Posts: 7

    Tinkerer

    Options

    Hi, I know this is an old thread but I was wondering how I can do that. I'm experiencing the same issue, although my situation is a little different. It has only started doing this after I was forced to use a charger with too low wattage (my original one broke after it was tripped on). In other words, the lower i can keep my power consumption the better and having my fans blasting at all times does not help. I'm wondering which driver is for ethernet because when I look uinder Network Adapters in device manager I don't see something that has Ethernet in the name and i don't want to disable the wrong one

  • TTTTTTT
    TTTTTTT Member Posts: 24 Networker
    Options

    @bekkboi It is "Realtech Gaming Gbe Family Controller" for me. Might be different for you.