UEFI bootable USB win10/11 not working stuck in acer logo when trying to boot

hitler9667 Member Posts: 4 New User
edited November 2022 in Nitro Gaming

Problem: stuck in acer logo when trying to boot from usb after message of launching efi. Model- AN515-43 Nitro 5

Scenario: I was updating my laptop (currently win11) and it crashed during reboot and then got stuck in boot loading screen with acer logo.

Tried Rufus tool to setup GPT based bootable usb for win10 and 11 and also tried windows tool for win10 in 8gb pendrive. Did bios setup for loading from usb boot menu. Tried with secure boot enabled disabled both but no luck. Even the service center is quiet far. Nothing major found on google. Please help.

[Edited the thread to add issue detail]

FAQ & Answers

Assistance by Acer

The opinions expressed on Acer Community are the personal opinions of the authors, not of Acer. By using this site, you accept Acer's Privacy Policy and the Acer Community User Agreement.

  • swiftevopoweron-tertiarybanner_620x335
    Swift Series Intel® Evo™

    Power On

  • xbox-agw-tertiary-banner-620
    Game Pass

    Game Pass

  • win-11-pro-banner
    Windows 11 Pro

    Windows 11 Pro for Acer business laptops

  • chromebook-gaming
    Gaming on Chromebook

    Gaming on Chromebook