ACER SB220Q - Connects to computer, input recognized, but no display or LD indicator

LauraTHXLauraTHX Member Posts: 4 New User
I have an Acer SB220Q for work, and it worked perfectly for a while. Now it doesn't show anything on the display - no loading screen either.

When I connect the power cable, the LED indicator on the cable block is green, and the HDMI cable seems to be working as the computer recognizes there is a second screen, and operates as if it's in use (my mouse disappears onto it and it shows up as the second screen in my display settings). It even recognizes when I connect and disconnect it, although the power button on the monitor seems to do nothing.
HOWEVER, the LED indicator on the monitor does not light up at all, and the screen is completely black - no loading screen, no nothing, nothing to edit. I have tried disconnecting the power cord and holding down the power button for 60 seconds, no dice. I've tried restarting the computer with the monitor already plugged in. There is also no pinhole reset button that I can find. Is this a lost cause or can I save it?

FAQ & Answers

  • Acer-ErickAcer-Erick Moderator Posts: 165 Moderator
    Hi @LauraTHX
    Unplug the computer from the power ,and hold in the power button 20 seconds . Then when we plug it back in, the computer works again.
  • EaswarEaswar Ally Posts: 3,404
    Hi @LauraTHX,

    Are you connecting with Xbox or apple systems ?
  • LauraTHXLauraTHX Member Posts: 4 New User
    @Easwar , thank you. I tried the power button suggestion a couple times and it did not work. And I'm connecting with a Surface Pro 6, which can connect to my other second screen with no problems.
  • billseybillsey ACE Posts: 19,115 Trailblazer
    When you have the monitor disconnected from everything except power, then turn it on, do you get the Acer splash screen as it boots up?
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • LauraTHXLauraTHX Member Posts: 4 New User
    billsey said:
    When you have the monitor disconnected from everything except power, then turn it on, do you get the Acer splash screen as it boots up?
    Nope, I don't get any display showing up on the actual screen at all. I only see a "preview" screen when I see the double-monitor settings on the Surface.
  • billseybillsey ACE Posts: 19,115 Trailblazer
    That sounds like the monitor isn't working then. It should display the splash screen if the screen is working. Are you still in warranty? If so now would be the time to contact Acer support to get a ticket started.
    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • LauraTHXLauraTHX Member Posts: 4 New User
    billsey said:
    That sounds like the monitor isn't working then. It should display the splash screen if the screen is working. Are you still in warranty? If so now would be the time to contact Acer support to get a ticket started.
    Unfortunately I think we're way out of warranty. That's too bad. Thanks for your help!
Sign In or Register to comment.

Who's Online824

AussieNoob
AussieNoob
Auzzy1616
Auzzy1616
clerbird321
clerbird321
DuneJeeper
DuneJeeper
Kev0806
Kev0806
Larryodie
Larryodie
Marover
Marover
mastqallandar
mastqallandar
Ribas2210
Ribas2210
StevenGen
StevenGen
TheWolf
TheWolf
Warren784
Warren784
xapim
xapim
Xuyahfish
Xuyahfish
Yibo_de
Yibo_de
+809 Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1989

Total Points:6487

Total Accepted Answers: 249

Leostat Community Aficionado