Aspire ES1-531 Battery Issues

DavidWh1te
DavidWh1te Member Posts: 2 New User
Hi all, I bought a 2nd hand Aspire ES1-531 for my Daughter to allow her to do all her home schooling work on it during lockdown, I got it relatively cheap as I was told it needed a new battery but still worked when plugged in however I have just replaced the battery  and it still has the same issues, namely reading 255% when plugged in and powering off as soon as its unplugged!
Any help would be gratefully received.

Thanks in advance 

David 

Answers

  • Tachi13
    Tachi13 Member Posts: 135 Skilled Fixer
    Hi @DavidWh1te

    What brand is the battery? Is it a compatible battery for your Aspire ES1-531? 

    Please do a power drain, use a paperclip to insert it into the pinhole for 30-40 seconds which should be underneath the device indicated by a battery icon, see if it fixed the issue.
    {if not} 
    Go to device manager (Windows key + X) and select Device manager from the list of options. Select Battery, expand it and select the component listed under the battery, do a right click and update the driver and check if it works, if not try uninstalling the driver and restarting the computer.  

    Please share an update.

    Please click on "Yes" if this answered your question.
    Click on "Like" if you found this to be helpful. 
    Please click on "Yes" if you find this answer helpful. :):)
  • DavidWh1te
    DavidWh1te Member Posts: 2 New User
    Hi @Tachi13,

    The battery is a direct replacement with the same p/n etc, I tried the power drain with no luck and it said the latest drivers were installed so I uninstalled the drivers and restarted again with no luck.
  • gofish
    gofish Member Posts: 1 New User

    I think i may have bought David`s Aspire ESI-531, From goodwill it`s a 2016 it didn`t come with a charger, Using what works with wire spacer for now but would like to find the plug adapter 3.0 to 5.5 an use my 14"chromebook charger im not sure they make one. Anyway tried your fix info an it seemed to fix the problem of reading 255% , I only updated the driver did not uninstall, It is staying on after unplugging charger. Big thanks an if you know of the adapter im looking for let me know about it.

  • StevenGen
    StevenGen ACE Posts: 9,492 Trailblazer
    edited December 2023

    The main reason why your battery is showing 255% and probably not working 100% and properly is because the battery that you bought is NOT an original Acer oem fitted battery and its a cheap refurbished old battery that are made in China and sold as new on eBay, Amazon and allot of battery retailers for around USD $20-$30 that are dangerous and can explode so be very careful, as an oem Acer battery for your ES1-531 will never ever show a 255% charge!

    The below charger adaptor and batteries are the original oem Acer batteries for the Aspire ES1-531, buy those batteries and adaptor only,

    Alos try this community fix and see if that fixes your problem. As battery problems could be many, try resetting the battery on the ES1-531 by pressing the POWER KEY for 10 seconds, then plugging the charger back in and wait until the battery charge LED changes from steady orange to steady blue. After that, remove the charger again and try to turn on the laptop with the battery alone.

    If this doesn't work do a Hard Reset by removing the seventeen (17) M2.5×L6 screws securing the lower case to the upper case, remove main battery, disconnect the RTC/BIOS battery and shots its +&- pins to reset CMOS, take the ram out and leave the laptop like that for 1 hour and then reconnect everything back, reboot laptop and see if the laptop works on battery only.

    Main Battery

    RTC/BIOS Battery

    If it still doesn’t work, you have internal problems in the main power/charging rails and circuitries of this laptop that needs a technician to analyze and pinpoint where the exact fault is so that he can change and fix this connection issues. Good luck and hope this give you more of a guide.👍

  • Puraw
    Puraw ACE, Member Posts: 7,026 Pathfinder
    edited December 2023

    There is probably nothing wrong with your new battery, but you need to do a full charge cycle: Reset BIOS, in BIOS press F9 and save settings on exit. After that do a full charge cycle. First make sure hibernate and Fast Startup are disabled in Power Plan and completely shut down the system. Plug in the power adapter and charge till the amber charge LED turns blue, wait a few minutes and boot to Windows, unplug the adapter and work till the laptop shuts down automatically, close the lid, plug in the adapter, and charge again till the amber light turns blue.
    No issues buying a replacement battery from online shops, perfectly safe, but make sure the part number and specifications are the same as the original battery or if in doubt ask this community.