Examples: Monday, today, last week, Mar 26, 3/26/04

This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

Visit our Product Forums for more current content.

Why won't my Aspire M3100 desktop support 4 GB in Windows 7 Home Premium 64-bit ?

blueribbblueribb Posts: 18Member

I just acquired this desktop (used). It was running Vista 32 bit with 2gb DDR2 memory. I installed Windows 7 Home Premium 64-bit and everything works perfectly. I decided to increase the memory to 4gb. I installed 4 matched sticks of 1gb each (Infineon DDR2 667, DDR2 5300). It boots to windows and system information displays: 4.00 GB (3.75 GB usable). The problem is the sound is just loud crackling noises, the Network adapter fails and the video has problems. When I reduce total memory to 3 GB, everything works normal again. According to Acer, this motherboard should support 8 GB. I searched google and found another person that had the identical problem I am having. It was never resolved. I wonder if a BIOS update would help. Acer does not offer downloads of BIOS updates via the web for this model and they will not discuss this problem since the warranty has long expired.

 

I tried enabling "memory hole" in the BIOS but it did not help with the problem.

 

Acer Aspire M3100 / AM3100

Mfg Date: 2007 / 10 / 12

[edited for privacy]

 

Answers

  • Acer-TommyAcer-Tommy Posts: 6,317Member Seasoned Specialist

    It sounds like a problem with either one of the pieces of memory or the slot on the mainboard.

     

    You may wish to install/swap the memory around and see if you can determine if it is one of the memory modules or one of the slots.

  • blueribbblueribb Posts: 18Member

    Thanks for the reply. I initially tried a 2 GB stick in one bank and (2) 1 GB sticks (matched) in the second back. The computer boots and displays the total memory in both the BIOS and windows but the sound, network and video issues occur. Removing 1 GB, dropping the total to 3 GB cured the sound, network and video issues. I then installed 4 different 1 GB sticks and had the problems once again. I'm pretty sure both the memory and the slots are OK.

     

    I'm waiting on a matched pair of 2 GB sticks from Kingston. They should be here today or tomorrow. I'll post the results then.

     

    Read this similar post:

     

    http://www.tomshardware.com/forum/298910-30-trouble-installing

  • blueribbblueribb Posts: 18Member

    I received a matched pair of 2 GB sticks today (4 GB total) and installed them in the blue bank. The problem still exists. I went to MSConfig and then the advanced area and limited MAX Memory to 4095 and then re-booted. This fixed all the problems but now windows sees 4 GB but only 3 GB is usable.

     

    Either I need a BIOS update or this motherboard does not support Windows 7 64-bit with more than 3 GB.

     

    This is one weird problem

  • alicepattinsonalicepattinson Posts: 160Member

    Yes, that's really weird. Maybe you should first try the BIOS update and let us know

  • Acer-TommyAcer-Tommy Posts: 6,317Member Seasoned Specialist

    If you only have 4GB installed, there is no reason to set Maximum Memory to 4GB, just leave it at the defaults which uses all available RAM.

     

    You will never have all of the RAM you install available for use.  The OS and other items, like shared video, will take some RAM and it will not be available.  It doesn't sound like anything is wrong with the 4GB you have installed.

  • blueribbblueribb Posts: 18Member

    I set max memory to 4095, one short of 4 GB (4096). I found this tip on another forum and the person there had the exact same issue that I'm having.

     

    The current BIOS info is below:

     

    Mainboard ID F690GVM

    SMBIOS version 2.4

    System BIOS version 6.00 PG

    System BIOS ID: R01-A1

    BIOS Release Date: 06/25/2007

     

    Any idea where I can download a later version ?

     

  • Acer-TommyAcer-Tommy Posts: 6,317Member Seasoned Specialist

    Any available BIOS would be on the Driver page, under the BIOS tab.

  • blueribbblueribb Posts: 18Member

    They do not offer BIOS updates online for the Aspire M3100. Instead, they give this message under the BIOS tab:

     

    Updating an incorrect BIOS may cause harm to your system. We recomend that you only do this after being instructed by one of our Customer Care representatives. By using these updates you agree to accept the possibility of product failure.
         
  • blueribbblueribb Posts: 18Member

    Update: I found an Acer European site that offers BIOS updates for the Aspire M3100 here:

     

    Acer Europe

     

    I downloaded a newer BIOS (R02-B1) and the WinFlash Utility. I ran WinFlash in Administrator mode and pressed "update bios" and then selected the BIN file. It came back with an error message saying "select the correct file".

     

    I give up. It looks like I'm stuck with 3 GB max memory.

  • RC123RC123 Posts: 8Member

    Does any from Acer Support read this forum?  Is there anyone at Acer that knows if there is a BIOS upgrade to solve this problem?  There is definitely a problem with the 2007 version of the BIOS for Aspire M3100.   Can someone please contact Acer and ask about an update for this BIOS.  The specs say that this PC can handle 8GB of ram, but if you go over 3GB many of the drivers fail, the onboard ethernet and video fail, for example.

    I called the "Answers by Acer" phone number and they told me that "all bios upgrades for Acer computer are done by Office Depot".  Office Depot tells me that they don't do BIOS upgrades and they don't know what Answers by Acer is taling about.

  • blueribbblueribb Posts: 18Member

    I was thinking about installing Vista 64 bit with 4gb of memory to see if it works without driver issues. If it does, that means Windows 7 itself is causing the issue. This still bothers me so maybe I'll try it in the next week and report back here.

  • chuckrauchuckrau Posts: 4Member

    I am not an expert but I can't believe the bios is the problem.  If you ever tried to load a 64 bit operating system on a 32 bit machine you would find that it is the bios that prevents the install.  If a 64bit system is installed on you machine the bios would support at least 4 gig.  I would question the memory itself.  Have you run the windows 7 memory diagnostics?

  • blueribbblueribb Posts: 18Member

    Yes, I tried many matching sticks and new matched pairs. There are other people with the exact same issue. In my opinion, it's either the BIOS or Windows 7 is not compatible with this system when 4gb (or more) is installed.

     

    ps - I run a computer business and have ~20 yrs experience

  • blueribbblueribb Posts: 18Member

    I spent the last hour installing Vista 64 bit and then Windows 8 64 bit. Both failed with 4gb or more of memory. The audio, graphics and network drivers all fail. Once you drop the memory to less than 4gb, everything works perfectly. At this point it looks like the motherboard's BIOS is the fault. I found another similar complaint right here on this forum:

     

    64 bit 4gb fails

  • jjgalushjjgalush Posts: 5Member

    I am wondering if you ever found a solution.  I have a AM1100-B1410A that had vista 32bit with 2GB.  I updated to windows 7 64 bit and that worked fine.  When I went to 4GB, same thing happened to me.  I can run 3 but not 4.  Let me know if you figure this out.

  • RC123RC123 Posts: 8Member

    I did not find a solution.  I think that Acer needs to update the BIOS and make a new BIOS available for download but I don't think Acer is going to update the BIOS.  

     

    I used CPU-Z  to identify my motherboard as , Acer Model: F690GVM  BIOS:  Phoenix Technologies LTD,  Version: 6.00 PG, Date: 10/10/2007    If you go to Phoenix Technologies, their support webpage says: "BIOS Updates from eSupport.com  Please note you are being directed to a third party website that is not owned or controlled by Phoenix Technologies Ltd., and fees may apply for any BIOS updates provided."  and the link brings you to:  biosagentplus.com which then has you download a bogus scanner which scans your computer and then tells you that they can sell you a BIOS update for $30, however after pressuring thier sales people about the BIOS upgrade they finally sent me this email:

    "We don't provide customized BIOS Upgrades. The BIOS we provide is likely the latest (same) BIOS available from your OEM. We aren't promising fixes or changes - just an updated version which comes along with 10-20 other driver updates.  BIOSAgentPlus is a service for keeping your PC updated with the latest software/firmware."

     

    If anyone knows how to fix this or anything about a real BIOS upgrade, please reply.

     

    [removed potentially hazardous links]

  • blueribbblueribb Posts: 18Member

    In one of my earlier posts, I included a link to an Acer (Europe) website that offers an updated BIOS. I was unable to install that updated BIOS. Please let us know if you are successful.

  • blueribbblueribb Posts: 18Member

    I made a bootable DOS USB Flash Drive and placed the updated BIOS (755A1P12.BIN) and AFlash / AWDFlash files on it. I booted the pc to it and ran the flash utility. I got the exact same result as WinFlash > "The program file's part number does not match with your system"

     

    It seems the updated BIOS that is shown on Acer's European website is incorrect. I'll keep searching the web to see if I can find another one to try.

     

    Here's where I got the new updated M3100/M5100 BIOS:

     

    ftp://ftp.work.acer-euro.com/desktop/aspire_m5100/bios/R02-B1.zip

  • blueribbblueribb Posts: 18Member

    I did some more digging and it seems there are different motherboard versions used in the M1100, M3100 and M5100 Aspire series. I think the latest BIOS for my M3100 is R01-A3. The original BIOS is R01-A1. Now, the problem is finding the A3 version so I can download and try it.

     

    RS690-SB600-6A669FK8C-00 is the identifier for the motherboard I have. I'm guessing the R02-B1, R02-B3 BIOS updates are for a different identifier (motherboard version). This identifier is shown in the DOS version of AWDFLASH. I don't remember if WinFlash shows it or not.

     

    Maybe Acer-Tommy can help. Also, it would be nice to know why so many people are having trouble running 4 gb of RAM.

  • blueribbblueribb Posts: 18Member

    I found the updated BIOS for my M3100-U3201A / RS690-SB600-6A669FK8C-00 here:

     

    R01-A3

     

    I had to sign-up in order to download it. I unzipped the file and placed it on my DOS flash drive. I then booted to the drive and typed AWDFLASH. It asked for the new bios name and asked me to back up my old bios, which I did. The flash took about a minute and then I rebooted and reset the bios settings.

     

    The good news is the flash worked - it now displays R01-A3 with a date of 10/10/2007

    The bad news is the computer still does not handle 4gb of DDR2 RAM without driver issues

     

    Next step is to contact the motherboard manufacturer since Acer is no help

  • Phil-3Phil-3 Posts: 1,182Member Practitioner

    Hello everyone,

    While our members are generally eager to provide useful information, be advised that Acer does not validate third party external links for downloads and is not responsible for them.

    Acquiring files through such links is at the user’s own risk.

  • arttttartttt Posts: 5Member

    I have the same problem and have tried moving the memory around, different memory sizes, different brands, different slots different combinations, etc .. to no avail ... Acer won't help ...

  • arttttartttt Posts: 5Member

    Phil-3 Moderator, Nice of you to tell us this ... but it might be significantly more helpful to get ACER to help us out here ...

  • blueribbblueribb Posts: 18Member

    I found a work-around for this problem (not a solution):

     

    1. Update the BIOS to the latest version (if possible). I updated from R01-A1 to R01-A3.

    2. Click Start and enter "msconfig" in the search box

    3. Run msconfig

    4. Click "Boot" tab

    5. Click "Advanced" button

    6. Put a check mark in Maximum Memory and enter 4095

    7. Click OK twice

    8. Reboot

     

    If you are running 4gb of memory, the computer should run normally with no driver issues. Windows sees 4gb and 3.25 is usable. This doesn't explain the problem but should solve the problem with running 4gb. I sold the computer so I didn't get a chance to try more than 4gb. Maybe someone here will give feedback on that.

     

    Good Luck 

     

    ps - these instructions are assuming you are running Windows 7 64-bit

This discussion has been closed.

Who's Online127

brummyfan2
brummyfan2
Domenico
Domenico
Guaro
Guaro
JordanB
JordanB
kavi
kavi
Skelomorph
Skelomorph
sumitbagal
sumitbagal
+120 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Announcements

Five Year Anniversary

Acer Community turned 5 years old this week! I would say that's a reason to celebrate!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Member Highlight

Look at ven98 go! Raising up the ranks, helping other users in the Predator forums. Thank you for your dedication!

Total Posts and Comments: 1036

Total Points:570

Total Accepted Answers: 88

ven98 Seasoned Specialist