Examples: Monday, today, last week, Mar 26, 3/26/04

Acer Aspire ES 15 (ES1-533-C3UW): Legacy BIOS Missing

2»

FAQ & Answers

  • MegasBaladorosMegasBaladoros Posts: 5Member
    Double post.
  • MegasBaladorosMegasBaladoros Posts: 5Member

    Hi there!

     

    A little background:

    I bought an Aspire ES1-533-C4WF and faced the same problem. The workaround proposed here by Sladek90 and Pueseso was exactly what I needed. Unfortunately it did not go well. I think it can not work any more because the ESP (EFI System Partition) is damaged. Maybe it was damaged by my previous attempts, before I found this thread. One idea would be to try and fix it but this will take a lot of research. It would be easier to just format the whole disc (including the ESP) and install Ubuntu from scratch. I did not dare to do it yet because I have been warned that this could be dangerous and brick my new laptop. Maybe I am being silly but please bear in mind that this UEFI thing is new to me, I have been warned to be careful with it and frankly it has not been kind with me so far...

     

    So my (double) question is:

    1) Is it safe to format the whole disk, including the ESP, and install Ubuntu?

    2) Can the Ubuntu installation process recreate the ESP?

    Note that after the format I will still have to follow this thread's instructions, with "obiquity -b" and so on, and not a normal linux installation, but let's supose that I will do it right this time.

  • Sladek90Sladek90 Posts: 5Member
    Hello,
    1) It is absolutely safe to format complete disk erasing also the ESP. I have done it at least 10 times during my attempts to install linux and finally the computer works well. ESP is in fact nothing special but usual disk partition.
    2) The ESP can be recreated automatically from within the Ubuntu installer or you can do it manually by some partitioning tool as for instance Gparted. There are lots of guides on how to partition your hard drive for linux EFI installation across internet.

    Wish you successful installation.
  • MegasBaladorosMegasBaladoros Posts: 5Member

    I knew it! They got me scared for no reason. Thank you Sladek90! I will do it first thing in the morning.

     

    ----- EDIT -----

    It worked perfectly, no need to change anything. Kudos to everyone who worked for it.

  • Sky_Sky_ Posts: 5Member

    Tinkerer

    > @HarvardNot said:
    > Ok, I will want a beer from everyone who got helped from my message:
    >
    >  
    >
    >  
    >
    > You don't need to change to legacy.
    >
    > Use Rufus to create a GPT/UEFI compatible USB drive from your Windows 8/10 ISO.
    Won't work. Tried it already with VN7-793G. Bootloader doesn't seem to find any Windows 7 installation.
  • SwetaSweta Posts: 1Member New User
    Simple question can we change uefi to legacy in es1533, when uefi not highlighted
  • Posts: 1Member New User
    I tried to tepepjenen ia windows 7 64, but the hdd driver could not find how to install it I read sludek90 but the google translator is not fair enough.

  • Vicky007Vicky007 Posts: 7Member

    Tinkerer

    I tried many Linux distro like Ubuntu Debian Kali manjaro arch

    Some distros are get freezes while installing or  not able to install :(

    Every times I got fail

    Even I tried now 
    To install Ubuntu 
    Given steps above 

    But failed ........!


    Any one tell the correct step to install Ubuntu or any distros

    Or some one make YouTube videos 
    To install Linux distros like Ubuntu for Acer es1 533


    Very difficult to install

    Plz any one tell me the correct steps.....

    Step by step process
  • Vicky007Vicky007 Posts: 7Member

    Tinkerer

    Sweta said:
    Simple question can we change uefi to legacy in es1533, when uefi not highlighted

    You can  change

  • Vicky007Vicky007 Posts: 7Member

    Tinkerer

    Sorry for my above mistakes



    Hey 


    Tell me how to downgrade  my BIOS 
    For Acer es1 533

    Am in 1.13 so I want to downgrade it 

    Let the process 

    Step by step to downgrade it.....
  • TreacheTreache Posts: 1Member New User
    I have had the same problem and I just solved it. Downgrade your BIOS version to BIOS Improve System Performance" from the link below. Then you would be able to change the Boot mode from UEFI to Legacy.
    Acer Support Page to download the BIOS for Aspire ES1-533
  • QuabraQuabra Posts: 1Member New User
    Pueseso said:

    Hi

     

    I have successfully installed Ubuntu 16.04.1 in my laptop ES1-533-C6C1 following Sladek90 advise.

    The only drawback is that it is horribly slow (probably becouse of some bug, have tried a Live-USB with MINT and it was OK...

    This is the full tested process:

     

    -- Boot Ubuntu Live USB

    -- open terminal

    sudo -s

    ubiquity -b

    -- Press Continue testing after installation is over.

     

    --Now we will return to the CLI (  https://wiki.debian.org/GrubEFIReinstall  )

     

    sudo mount /dev/sda2 /mnt #sda2 is the root partition

    sudo mkdir /mnt/boot/efi

    sudo mount /dev/sda1 /mnt/boot/efi #sda1 is the efi partition

    for i in /dev /dev/pts /proc /sys; do sudo mount -B $i /mnt$i; done

     

    modprobe efivars # make sure this is loaded

     

    -- notice the bootx64 file

    efibootmgr --verbose

     

    -- We will reinstall grub-install for a 64bit version

    apt-get install --reinstall grub-efi-amd64

     

    grub-install —no-nvram —root-directory=/mnt

    chroot /mnt

    update-grub

    cd /boot/efi/EFI

    cp -R ubuntu BOOT

    cd BOOT cp grubx64.efi bootx64.efi

     

    -- You are finished, reboot the system.

    After much troubles and looking around on the internet when wanting to install Ubuntu on a Acer Aspire, I found this topic. And it works, almost. I do get the installation completed, where using other methods it crashes at installing grub2. But I have problems when I give the command

    grub-install --no-nvram --root-directory=/mnt

    This error occures then:

    grub-install: error: install device isn't specified

    It seems I need to add a place on de harddrive? Could you help out?
    I hope someone can help me out, untill now I have not found a solution yet.
  • avareavare Posts: 1Member New User
    hi alls... My Leptop aspire es 15 es1-533-C3N9. bios v1.07. insydeh20 rev 5.0; 
    Dont see MY usb boot HDD (win 7 64bit ) now; no boottable device mode
    i was makig 4 days, very agry and unhhappy...
    are you can help me? My world, Türkey / istanbul...
  • mamun181mamun181 Posts: 5Member New User

    Hi I tried that with no luck. Actually, the secure boot is displayed as Disabled, but BIOS still requires supervisor password before entering the BIOS editing tool... Before setting Supervisor password access to BIOS was not restricted, now the password is required to access BIOS settings edit and Secure boot disable/enable seems to have no effect on that.

     

    Anyway, the main problem - that UEFI is the only option in Boot Mode - still persists. Secure Boot settings didnt change anything.

    thx Jirka

    Same issue someone help...............
  • cosmo0093cosmo0093 Posts: 1Member New User
    Treache said:
    I have had the same problem and I just solved it. Downgrade your BIOS version to BIOS Improve System Performance" from the link below. Then you would be able to change the Boot mode from UEFI to Legacy.
    Acer Support Page to download the BIOS for Aspire ES1-533
    can you please give me some steps on how to do this? or kindly point me to some walkthrough
  • Mathieu_LeocmachMathieu_Leocmach Posts: 1Member New User
    The method by Pueseos almost worked for me on ACER Aspire ES 17 but ...
    Pueseso said:
    cd BOOT cp grubx64.efi bootx64.efi
    ... is not enough. Actually Acer and Microsoft tightend their relationship even more since this post, and Acer's UEFI (v1.17 for me) go look for .efi in Microsoft defined path and not standard path.

    What I had to do in addition is
    cd /mnt/EFI 
    mkdir OEM
    mkdir OEM/Boot
    cp -v ubuntu/grubx64.efi OEM/Boot/bootmgfw.efi
    mkdir Microsoft
    mkdir Microsoft/Boot
    cp -v ubuntu/grubx64.efi Microsoft/Boot/bootmgfw.efi
    With secured boot disabeled from UEFI (BIOS) interface, Ubuntu now boots through GRUB




  • ArjendBArjendB Posts: 2Member New User
    I have succeeded in installing Ubuntu 18.04.1 on an Acer Aspire ES 17 (ES1-732) using Sladek90/Pueseso's method, with a slight modification at the end of the script.
    Original script: cp grubx64.efi bootx64.efi
    Modified to: cp grubx64.efi BOOTX64.efi
    Necessary because the CLI is case-sensitive.
  • ArjendBArjendB Posts: 2Member New User
    Installing Ubuntu 18.04.1 could only be done on the ES 17 with secure boot disabled.

    On using the Ubuntu update manager for the first time, the system hung on an update of secureboot-db. It could only be unfrozen with a hard reset. From then on, I was prompted to enter 'sudo dpkg --configure -a' in terminal mode to fix the resultant mess, but that just froze the system again.

    Re-installed 18.04.1, rebooted, installed Synaptic in Software Centre. In Synaptic I found the troublesome secureboot-db and manually excluded it from update. All other packages were updated succesfully.
    Finally, I excluded secureboot-db from update in terminal mode by 'sudo apt-mark hold secureboot-db'.
    The Ubuntu update manager did not freeze again.
2»
Sign In or Register to comment.

Who's Online218

Acer-Harvey
Acer-Harvey
Acer-Jose
Acer-Jose
Acer-Manny
Acer-Manny
Acer-Tim
Acer-Tim
Amortis
Amortis
BERTROP
BERTROP
christy1
christy1
Dadyngwie
Dadyngwie
egydiocoelho
egydiocoelho
GVH
GVH
Hastings
Hastings
Jack22
Jack22
JulianDimov
JulianDimov
kilari_helios_300
kilari_helios_300
Kingkishor
Kingkishor
Kozidis
Kozidis
MaClane
MaClane
Myll3r
Myll3r
pranshu626
pranshu626
Rudy21
Rudy21
Svenkn89
Svenkn89
System
System
Vindy17
Vindy17
+195 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.