v3 371 keyboard malfunctioning

Hi guys,

 

I own an Acer V3-371 HV laptop since 1.5 years now. I am very satisfied with the product, but last night the keyboard stopped working properly, parts of the keys are broken: w r t u o p x backspace del 1 4 6 8 0 ~ = ] ' win and fn.

A while ago I upgraded the ram from 4 to 8 GB, and replaced the thermal paste (since temperatures were rising), so I know how to open the laptop. I first thought that maybe the connecting plastic cable from the keyboard to the motherboard might be damaged, so I opened the laptop, but I could not see any damage on the connector. I also couldn't see any other damage to the keyboard and elsewhere inside the laptop. Does anyone have an idea what may have caused the malfunction of these keys? And how I can solve this issue?

I prefer fixing it myself, rather than sending the laptop in, because I need it for work, and since I opened the laptop myself already (for upgrading ram and thermal paste), I am afraid Acer will not apply warranty, leading to a high repair bill.

I found a replacement top cover on ebay, because I think it will be impossible to separate the keyboard from the cover, since it is 'welded' on with plastic dots. But before buying that I would like to know for sure that that part is broken, not something else. Is there any way I can test this?

 

Thanks in advance for your time/effort!

FAQ & Answers

  • laurent_14laurent_14 ACE Posts: 9,859 Trailblazer

    Hello,

     

    Have you tried this:

     

    1. Shut down your laptop

    2. Disconnect the AC adapter

    3. Wait few minutes

    4. Follow this procedure

    Note: The battery reset pinhole is marked with this symbol AC-BRP on the bottom of the laptop.

    France
  • rolandtorensmarolandtorensma Member Posts: 3

    Hi Laurent,

     

    Thank you for your suggestion. I tried it but it didn't seam to change anything, the keys still don't work.

    I also should mention that an external usb keyboard works fine, that is what I am using for now.

  • laurent_14laurent_14 ACE Posts: 9,859 Trailblazer

    Hello,

     

    1. Have you loaded the default settings in the bios setup utility and save & exit?
    2. Do you have the lastest bios version?
    3. Is your keyboard (German version)?
    France
  • rolandtorensmarolandtorensma Member Posts: 3

    Hello,

     

    1. I tried entering the bios menu while booting the laptop, but pressing f2 didn't work (on external and laptop keyboard).

    2. I updated the BIOS from 1.15 to 1.29, but I observed no changes in keyboard malfunctioning.

    3. I have the international qwerty version, I live in the Netherlands.

  • amir_hzamir_hz Member Posts: 1

    This is an old thread, I also experienced the same thing, but it may be helpful to others.

     

    (This only happens in windows OS only, does not happen in linux. There seems to be a problem in the touchpad/keyboard driver)


    What I do is go into the BIOS and change the touchpad option from advanced to basic.
    go back to Windows, and keyboard works again

Sign In or Register to comment.

Who's Online2.6K

Acer-Blayn
Acer-Blayn
Acer-Ingrid
Acer-Ingrid
Acer-Jose
Acer-Jose
Acer-Samuel
Acer-Samuel
aelshow
aelshow
Alejandro_AC
Alejandro_AC
Aziz1953
Aziz1953
BigD44
BigD44
ccfellow
ccfellow
Elgermano
Elgermano
Fillipe
Fillipe
Gene8284
Gene8284
Hubbeldei
Hubbeldei
JackE
JackE
Jutha13
Jutha13
KNOT2DAY
KNOT2DAY
Krimozz
Krimozz
Martin2021
Martin2021
ragsak28
ragsak28
RenanVilela
RenanVilela
Tahkrii
Tahkrii
Xicorr
Xicorr
Pranav05555
Pranav05555
+2.6K Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers