Acer Aspire V7-581P wifi problem

emp1985emp1985 Member Posts: 4

Hey folks,

I'm having issues with my wifi as of a few weeks now. Usually I'll turn on my laptop and it'll will do its thing and start up and connect to the wifi that's in range and life will be dandy. As of late though it'll just say that there are networks available and I'll have to click on my network and it'll say connecting and hang for awhile then say something along the lines of cannot connect to network. If I try to connect again the Wifi network will disappear. If I leave it alone it will connect at random times but when I try to connect to a website using 2 different browsers it will have just say connection timed out, cannot connect to webpage, etc. When the connection does stay connected I'll have intermittent packet loss and if I troubleshoot sometimes it will say "The DNS server isn't responding." Note that this is the only laptop that gets wifi issues out of the 6 or 7 that are on the network.

Things I have tried to resolve this issue:
1) Use the troubleshooter.
2) Disable to option that lets my computer turn off the wifi adapter.
3) Reset my router
4) release/renew IP
5) release/register DNS
6) disable Anti-Virus / Firewall / Bluetooth
7) Uninstall/reinstall Wifi drivers

Any other ideas or help would be greatly appreciated!

Thanks =)

Computer Specs:

Windows 8.1 64-bit
Intel Core i5 3427U

CPU: 1.80GHz

RAM: 12GB
Wifi: Qualcomm Atheros AR5BWB222 Wireless Network Adapter Driver Version: 10.0.0.263

FAQ & Answers

  • philetusphiletus ACE Posts: 4,757 Pathfinder

    I'm sure the problem is related to a crappy 8.1 driver.

    Try using the Windows 8 driver: On some Acers this works.

    Wireless LANAtherosWireless LAN Driver10.0.0.225226.2 MB2013/04/29Download

    Uninstall the Wifi driver/s in Programs and Features and Device Manager, delete software, before you install the downloaded driver. If the 8 driver doesn't work, uninstall the 8 driver and install the 8.1 again.

    Wireless LANAtherosWireless LAN Driver10.0.0.263251.5 MB2013/10/11Downlo

     

     

  • emp1985emp1985 Member Posts: 4
    Yeah I've tried uninstalling/reinstalling the drivers already but to no avail =\
  • chienmenchienmen Member Posts: 1

    Did you end up solving the problem? I have the same problem with you.

  • emp1985emp1985 Member Posts: 4
    Nope, still having the same issue.
  • emp1985emp1985 Member Posts: 4
    Yes I have. I've done everything I possibly could do besides going to a computer repair store.
  • philetusphiletus ACE Posts: 4,757 Pathfinder

    The manual shows 4 Wifi cards. 2 Atheros and 2 Broadcom. Give the Broadcom driver a try.

    Wireless LANBroadcomWireless LAN Driver7.35.267.044.5 MB2015/07/29Download

     

    Uninstall the old one in Programs and Features first. 

Sign In or Register to comment.

Who's Online2.1K

6kapserg
6kapserg
Acer-Erick
Acer-Erick
Acer-Ingrid
Acer-Ingrid
Acer-Jose
Acer-Jose
Arhxn
Arhxn
Ashvik
Ashvik
Bobby3000
Bobby3000
Bola
Bola
buburakk
buburakk
Cyriix
Cyriix
Divad
Divad
Dolores2020
Dolores2020
Eck_Renrew
Eck_Renrew
egydiocoelho
egydiocoelho
getchethanbr
getchethanbr
Gressex1
Gressex1
Humstead
Humstead
JackE
JackE
JaimeDLH
JaimeDLH
Kpowley
Kpowley
Leo19
Leo19
Nierka
Nierka
RolfH
RolfH
SageKanav
SageKanav
Spartan
Spartan
Spilou
Spilou
Thepeter25
Thepeter25
trontech64
trontech64
uGuiDZin
uGuiDZin
Wentre3
Wentre3
+2.1K Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos