802.11ac wifi mini-card compatible with an Aspire One AO722-C52kk

DarrenHillDarrenHill Member Posts: 37

As my current Broadcom 802.11n card in my Aspire One seems to be having problems with transmission drop-outs and I have an 802.11ac-compatible router, I was wondering if anyone knows of a suitable wifi PCIe half-card that I could retrofit into my machine to make proper use of the faster router (and to get reliable connection without it corrupting the transmissions).

 

I can see several cards available on the net, but I would like to try and confirm if there is a compatible one with my machine's board and processor (as that is an AMD C-50 and many of the cards are from Intel...).

 

Is there a suitable recommended card for such an upgrade?

«1

FAQ & Answers

  • DarrenHillDarrenHill Member Posts: 37
    Hello? Anyone out there? Or is this one that no-one knows, and I'm going to have to find out the hard way by buying and trying? Which makes me nervous as most of them seem to be Intel-based, and given the controller on the Acer is an AMD I'm not so certain about compatibility...
  • brummyfan2brummyfan2 ACE Posts: 19,589 Trailblazer

    Don't spend your money, your Motherboard is not capable to handle ac mode, have you tried updating your driver?

    http://i.walmart.com/i/rb/0009980296433.pdf

  • DarrenHillDarrenHill Member Posts: 37

    The drivers are a mess, as I seem to have had to lash together all four of the drivers in the eRecovery program (Atheros LAN, Atheros WLAN, Broadcom WLAN and Realtek WLAN) to get any wifi at all. I have the latest Broadcom and Atheros LAN drivers (the current mini-card is a Broadcom), but seemingly if I don't install the other two as well I get no wifi visibility at all. If I just install the Atheros and Broadcom (ie the hardware I actually have) then the little LED for the wifi is illuminated, but under the system tray icon for the network connection there are no available wifi connections, and under the network settings page the Broadcom is disabled and won''t enable.

     

    But there seems to be period occurrences of corrupted downloads/web pages, plus the Microsoft virtual miniport adapter that I had available before has vanished, so I can't host virtual networks.

     

    Hence why I've had enough of the **bleep** thing, and as I have an 802.11ac capable router I'd like to update the machine to be able to connect that way. Hence why I want to swap out the PCIe mini-card (the broadcom one) that is 802.11b/g/n to one that can also handle 802.11ac. The networking is all on a mini daughter-card which should be quite simple to swap out physically (it's easily accessible once the base is removed), it's not on the motherboard itself.

     

    But as I said, as the processor is AMD-based, I'm a little wary about whether an Intel-based card will work or not. Most of the cards I've seen have been such, hence my original question about whether anyone has experience or knowledge of whether one would work or not, and if not what else could be substituted.

  • DarrenHillDarrenHill Member Posts: 37

    The parallel question - does anyone know if Acer actually employ hardware whitelisting in the BIOS of the Aspire One's which would limit usage of certain hardware items (e.g. specific cards will or will not work)?

     

    I'm doing some investigations on various other forums etc at the moment and there doesn't seem to be consensus as to whether whitelists are implemented or not.

  • siliziumsilizium Member Posts: 239 Enthusiast

    There is no limitation regarding Intel network adapters on AMD platforms. You can buy any Intel WLAN adapter as long as they fit into your device. Be aware that for other technologies than the build-in WLAN technology, you may have also to implement a different WLAN antenna. This is not always possible.

  • DarrenHillDarrenHill Member Posts: 37

    I'm looking at 2x2 cards (the 7620HMWWB or 7620HWM), and from what I can see they use the same antennae as the existing ones. So it should just be a case of popping off the connectors for the existing card, removing it, replacing it with the new one and plugging the connectors on again.

     

    All the reports I've seen about the cards say the antennae are fully re-usable, and the cards aren't supplied with them anyway (and I wouldn't like to have to try and re-run antennae again in the machine, as it would mean fully dismantling it.

     

    At this point for £20-£25 or so I think I'm going to give it a go. I have a mate who works for Intel so I'm just going to see if he can get me one with staff discount Smiley Wink

  • code65536code65536 Member Posts: 10

    No, Acer does not whitelist cards. The only manufacturers who whitelist are Lenovo and HP. Also, virtually everything uses the standard U.FL antenna connector. There are a few exceptions, but they are quite rare, and this is not one of them.

     

    Caveats:

     

    1) There are a gazillion different 7260 variants. Some without 11ac support. Some without 5GHz support. Some are NGFF instead of HH mPCIe. So check the specs carefully. 7260.HMWG is what most places list it as.

     

    2) If you buy a used unit, make sure it didn't come from a Lenovo machine and/or have a valid FRU code on the label. Also be careful if it came from an HP machine (though not necessarily all HP-sourced cards do this). While Acers don't have BIOS whitelists, Intel does produce a line of locked cards specifically for whitelist systems, and these cards will check the BIOS to make sure that it's a Lenovo/HP or it will refuse to work. These are pretty uncommon and most are used units pulled from Lenovo/HP systems.

  • DarrenHillDarrenHill Member Posts: 37

    Thanks for that - if my mate comes through it should be a new card direct from Intel, but if not and I end up somewhere like Amazon I will certainly bear that in mind. I already saw that there are versions of the 7260 that are 802.11abgn rather than 802.11ac, but the two I mentioned earlier that I am looking at are ac models and at least from the information available they both support dual band 5GHz too and are the half-size mini PCIe like my existing one.

     

    I also see on the net about some tricks for the whitelist cards (isolating one or two of the pins with tape to prevent them talking to the bios), but hopefully I can avoid such requirements with a suitable purchase from the correct source!

  • DarrenHillDarrenHill Member Posts: 37

    Well I can update this now, with some good news but mainly some bad.

     

    I got myself a 7260.HMWWB and now have it installed (uninstalled the Broadcom drivers, left the Atheros, then removed the Broadcom mini-card), the software downloaded from the Intel site and tried.

     

    The good news is the install went fine (I love how easy the Aspire One is to upgrade!) and the Bluetooth is all set up and works fine.

     

    Unfortunately the bad news is that the wifi doesn't work. After the drivers were installed (latest ones from Intel site 17.0.5) the wifi LED turns on, but no connections are available even though the network centre reports the card fine and the drivers show as working. If I do a manual diagnostic (one of the Intel software items) it reports that the "Wireless Hardware is not bound to transport driver" under the initial hardware diagnostics.

     

    So far I've tried:

    • Uninstalling and reinstalling the software.
    • Installing the software under safe mode (didn't work as it needs the Windows installer software).
    • IPConfig/all doesn't show the card.
    • Reset Winsock and TCP/IP (netsh int ip reset and netsh winsock reset).
    • Using the driver update thing on the Intel website - under Chrome it crashes my machine and under IE it blue-screens...!

     

    Any thoughts, aside from send the thing back, put the Broadcom back in and give up? Is simple working wifi too much to ask Man Frustrated

  • code65536code65536 Member Posts: 10

    You don't need to install the (mostly useless) Intel software package. In fact, it's my preference to avoid that entirely and just install the INF driver via Device Manager.

     

    That having been said, I highly doubt that would've made a difference in this case.

     

    First, what's the PCI hardware ID of this card? You can find it in the Details tab of the card's property sheet in Device Manager. Looks something like "PCI\VEN_8086&DEV_08B1&SUBSYS_40708086".

     

    * You've made sure that you haven't accidentally switched the wireless off / turned on airplane mode?

     

    * Have you tried booting the computer using a Linux Live USB? That's a relatively quick, easy, and non-invasive way of determining if the problem is on the hardware side of things or on the driver/software/OS side of things.

  • siliziumsilizium Member Posts: 239 Enthusiast

    There is one pretty reliable way to test whether your hardware is working. I had done this before if I would be you. Use a Linux distribution with live system.

    http://software.opensuse.org/131/en

  • DarrenHillDarrenHill Member Posts: 37

    Hardware IDs are:

     

    PCI\VEN_8086&DEV_08B1&SUBSYS_40708086&REV_73

    PCI\VEN_8086&DEV_08B1&SUBSYS_40708086

    PCI\VEN_8086&DEV_08B1&CC_028000

    PCI\VEN_8086&DEV_08B1&CC_0280

     

    I did actually (by mistake) try just the drivers first as I downloaded the wrong package (the just-drivers one) before downloading the full package of software. But you are correct, I got the same end result (no connections available) either way, although the full software gave the manual diagnosis option I mentioned above.

     

    The wifi is on judging by the little LED at the front of the machine, and it doesn't have any hardware switch (just the Fn-F3 to turn on/off).

     

    I'll try a Linux boot this evening and see where I am with that.

  • DarrenHillDarrenHill Member Posts: 37

    Well the hardware of the card is fine - I'm posting this from an Ubuntu 14.04 live CD via my 5GHz wifi.

     

    So the question now I guess is where the problem with the Windows driver and the card talking to one another is coming from. Is it something fundamental to them, or is it something that can be fixed. I don't particularly want to reinstall Windows (or switch to Linux), but I guess if that may resolve the issue then it could be worth it.

     

    Any more inputs would be appreciated on what could be done here...

  • siliziumsilizium Member Posts: 239 Enthusiast

    If the hardware is working in Linux than it will also working in Windows. My best suggestion (with view of the origins of this thread) is, to wipe your OS from your disk and install all from scratch. Do not install it over the old, delete all data and than install it. But before that turn off the device once.

  • DarrenHillDarrenHill Member Posts: 37

    Sadly I'm coming to the same conclusion - time to see quite what is hidden away in the partitions of this machine for such a system rebuild...

     

    I guess the job for tonight is going to be making sure all the backups etc are in place too so that nothing useful gets lost. Not quite how I wanted to spend my weekend, but I guess it's for the best.

     

    One question - if I format the c: drive how can I access the hidden partitions to do the rebuild (I didn't see anything in the BIOS for it)? Or do you mean to just go via the eRecovery software and select a factory default restore?

  • code65536code65536 Member Posts: 10

    Before you go through all that trouble of formatting your computer, do you have a spare/old 2.5" drive lying around? If so, wiping that drive and installing onto that would be a far easier (and less invasive) way to test to see if a fresh install of Windows would help.

     

    Unfortuantely, I don't think that it will.

     

    You see, what you're describing sounded an awful lot like something I had seen. And a part of the reason I wanted you to test it on Linux was to see just how closely your problem mirrored a couple of things that I had run into in the past. First, with a pair of Acer nettops a number of years ago. They had Atom CPUs and a NVIDIA ION northbridge. I installed Intel 5100 cards in them and the cards would not work. They were detected fine, and I installed the drivers for them just fine, but they just won't connect to any access point. And this was with a fresh install of Windows. The cards worked when I tried them in other Windows computers, so I know the cards were fine. Non-Intel cards worked on these nettops in Windows, so I know that the nettops were fine. And the strangest part of the puzzle was that the Intel cards worked fine in these nettops under Linux.

     

    The second time was just a month ago. I was installing an Intel 6205 card in a Dell Inspiron 3421. Exact same problem as before: This particular Intel card and been tested and verified in a different system and was known to work fine. This 3421 had no problems with its original wireless card. And the Intel card worked fine in the 3421 if I booted Linux--it just didn't like Windows, not even a fresh clean install. I even tried it with an Intel 5100 card (with a much older driver), and I got the exact same thing. Now, this second case is interesting because I later installed the same Intel card into a Dell Inspiron 3521 (it's the same product family as the 3421--just with a different screen size), and it worked in the 3521 just fine. The difference between these two, aside from the screen size, was that the 3421 had the optional NVIDIA graphics.

     

    But before I go blaming NVIDIA for this, I have another laptop with an NVIDIA northbridge and graphics, and that worked perfectly with Intel cards. And I also know friends with laptops with NVIDIA graphics that work fine with Intel WiFi cards in Windows. And the reason your case intrigues me so much is that it fits everything that I had seen in my two cases, except this time it's AMD instead of NVIDIA.

     

    Well, okay, there's a chance that maybe a clean install of Windows will magically solve the problem, but that seems highly unlikely because I can't really imagine how a clean install would be any different from what you've already tried (you should still try it, just to make sure you've exhausted every option, but don't pin your hopes on it, and, if possible, do it on a spare 2.5" drive so that you don't end up having to needlessly reinstall/restore everything later).

     

    Anyway, I never did find a solution for the cases that I ran into, and I never did nail down the root cause of the problem. First, my best guess is that the Linux-vs-Windows thing is really a driver issue and not an OS issue. Although both the Linux and Windows drivers for Intel WiFi cards are written by Intel, their Linux drivers (iwlwifi) are very, very different from the Windows ones. Second, I'm guessing there might be some sort of hardware conflict somewhere with a collision in IRQs or hardware memory addresses, and maybe the differently-architected iwlwifi works around it in a way that their Windows drivers do not.

     

    (BTW, in case you were wondering why I asked for the card's PCI ID, that was just to verify that you hadn't gotten a vendor-locked variant. It's not, so that's not a problem.)

  • DarrenHillDarrenHill Member Posts: 37

    Thanks for that - unfortunately I don't have a spare drive around so it's going to have to be on this one. I did take notice of your comments before (and others elsewhere on the net) about whitelists and vendor-locked cards, although it still didn't save me hassle as it turned out (or just changed it a bit) Man Wink

     

    To be honest there's not that much on this machine (it's been at least partly superceded by my Nexus 7 tablet) - I mainly just use it for game mod coding and a few other odds and ends. It's more the hassle of finding all the downloads and licenses etc for the various bits of software that are on it.

     

    The background of the card change is that I was having some issues with the previous Broadcom card (details are in this thread), so it could be that something a bit deeper in the installation is screwed up so a refresh may not be a bad course of action anyway. The machine is 3-4 years old and still on its original factory set-up, with all it's accumulated cruft. If all else fails I can put the Broadcom card back into the new installation and carry on as I was before, and chalk the Intel card up to a £20 experience. Like you said it's just annoying that it works fine and straight out of the box on Linux (or I could just bite the bullet and go Penguin I suppose, although that's more of a seed-change than I was planning).

  • code65536code65536 Member Posts: 10

    For the Dell 3421 that had the Intel WiFi allergy, I ended up picking up a used Atheros AR5B22 card from eBay (I was mostly just trying to get dual-band support, so I was okay with non-Intel as long as it was dual-band). Turned out to be cheaper, too.

  • DarrenHillDarrenHill Member Posts: 37

    Useful to know, although it's only an 802.11n card like my old Broadcom one. I'm looking for an 802.11ac one as my router can support that (the 7260 under the liveCD reported a nice high speed, just to tease me).

     

    So if a Win restore brings its drivers back as they should have been and were originally, I could just go back to that if all else fails. It was just about working before, but had somehow lost its miniport virtual adapter and was giving some corruption of things like webpage images and occasional downloads sometimes (enough to make it worth replacing for reliability).

  • DarrenHillDarrenHill Member Posts: 37

    OK an update. I've used the eRecovery software to factory-default reset the Windows 7 installation. Interestingly initially I tried to do the option keeping the user settings, but when it got to starting services in the rebuild it came up with an error that Windows couldn't be installed on the machine and rebooted after a click on "OK" (I repeated this loop three times, it would not progress past that error).

     

    Then I did a full restore (the first option - I already have a full back-up of the machine on my NAS box) and Windows proceeded to install itself. But this has made me wonder somewhat if there is something more underlying everything here ( a virus or something, even though I had a fully updated Zonealarm AV/Firewall and Malwarebyte anti-malware set-up on the PC). That said I do a full scan including archives roughly once a week, and nothing was found last time-out (although there was a hit a couple of weeks ago around the time that I was downloading the Broadcom replacement drivers).

     

    So now the good news and the bad. The first (and only) thing I did was install the Intel software, and the machine can now see the PCIe card (the good news). However the card itself cannot see any networks (the bad news), even though the machine is literally sitting on the same desk as the wireless router (as I had them cable-connected to take a few extra bits off the hard drive before I reset things - the cable is currently disconnected - the router is literally about 4 inches from the back of the screen).

     

    Again I'm now not sure what to do for the best. The manual diagnostics program passes the first three or so tests (hardware, radio and something else) but fails on the scan test with nothing found. The network is definitely there as all my other machines in the house are on it, and the antennae are connected correctly based on the Linux test earlier. 

     

    Any recommendations on how to proceed with this next roadblock? Or is it time to give up, reinstall the Broadcom card and hopefully get working wifi back again so I can proceed with the rebuild-proper as I'm away on business next week and would like to either take the machine with me in a functional state, or at least leave it here in one...

This discussion has been closed.

Who's Online2.1K

Arrandy81
Arrandy81
batmalin
batmalin
Calibre68
Calibre68
Dirkwearswhitesox
Dirkwearswhitesox
Helgur
Helgur
hiempie
hiempie
NIXSHII
NIXSHII
Sergiojimene20
Sergiojimene20
silentstorm31
silentstorm31
+2.1K Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1064

Total Points:3767

Total Accepted Answers: 151

Leostat Valued Contributor