This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

Visit our Product Forums for more current content.

V5-571G with BIOS v2.11: F2 to access bios setup not works if UEFI bios enabled

huelshuels Member Posts: 4

after having spent many hours to understand windows 8 and UEFI BIOS behavior, to be
able to start the machine from any  "FAT32/MBR boot device" using "legacy bios" (secure boot disabled),
now I have a "little" problem with my new Acer V5-571G. This is the "story":

- I made a Windows driver and BIOS update using acer "live updater" software from to BIOS v.2.11 (that is not available in the acer support website...)
- In this situation pressing (and holding) the F2 key before the power on button gave me access to BIOS setup screen
- At this point in no way I was able to start any boot device different from internal HDD.
- So, I set up the bios admin password, enabled boot menu (F12 key), and enabled "Legacy BIOS" (this disable also "Secure Boot").
- After a restart, also in this situation, no boot device was able to start...
- But at this point the problem is that F2 key to access setup BIOS page doesn't work, so after searching a solution from internet (using another PC because in non uefi mode Windows 8 doesn't start) I gained Windows access and UEFI mode by pressing and holding the power on button for 2 minutes... however from this moment F2 key doesn't work also in this UEFI mode.

- with uefi enabled, the only way I can access the BIOS setup screen is to select it from Windows 8 configuration page.
- In non uefi mode (legacy bios) I can start from a boot device like the Windows 8 recovery pendrive or dvd (I don't know why now works, I tried different bios configuration, lastly setting up also the user password)
- to return to uefi mode I have to press for two min the power button (!!)

The problem is that if the internal HDD will be damaged, I will not be able access to BIOS setup using a specific key (such as F2).
Do you know if there is a way to solve this problem? Thank you.

FAQ & Answers

  • Acer-BlaynAcer-Blayn Administrator Posts: 2,350 Community Administrator

    Are you shutting your computer completely down, or are you using Windows hybrid shutdown? Make sure your computer is shutting down completely using the instructions at, because you can not easily enter the BIOS from hybrid shutdown mode. If you are still having problems accessing your BIOS, I recommend you contact Technical Support in your local region.

  • huelshuels Member Posts: 4

    Thank you for your reply.


    Yes, I firstly disabled "fast start" of windows 8.

    The behaviour of the power button was set to "shutdown" from power management options in windows control panel. I used the power button to shutdown.


    Today I sent the notebook to Acer Italy technical support. I will keep you updated about the case.

  • huelshuels Member Posts: 4

    I received my pc from Acer today. The support have downgraded the firmware to version 2.09.

    Now the F2 key allow to access the bios setup page in both uefi and legacy modes.


    Finally I can replace the internal hdd with a ssd (7mm height). I have the service manual and I tried to disassembly the computer following the instructions but I'm not able to remove the keyboard (without signing it...).

    I don't know how to reach the four upper side latches without marring the borders. Have you got any tips that I can use?


  • quickesquickes Member Posts: 3
    for remove keyboard you need remove two sqrewfrom bottom and open clipses with thin instruments. i use knife for it. starting from right part keyboard.thanks for tested bios, I will planing update too
  • huelshuels Member Posts: 4

    I used the official service guide to open it, but the **bleep** keyboard has been hard to remove.

    Lastly I removed it using five plastic cards (with the same dimensions of a credit card) after two hours (!!) of attempt.

    Luckily I haven't made scratches over it.

    With an SSD is a pleasure using the V5-571G.

    Although it has a relatively slow i3, it works well in fullHD also using the  SVP  ( )

    The boot time is more or less 8 seconds.

    I don't understand why Acer have placed the HDD in a such similar bad position (without a little door to reach HDD from bottom side).

This discussion has been closed.

Who's Online591

+581 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

Assistance by Acer

Drivers &


Get Product Information
( only)

Acer Support