Examples: Monday, today, last week, Mar 26, 3/26/04

Qualcomm Atheros AR5BWB222 Wireless Network Adapter

scolburnscolburn Member Posts: 7

Tinkerer

Hi,

 

I am having trouble keeping my brand-new Acer Aspire 5600U online.  The WNA keeps going off, frequently.  I know it's not my router, since I never had this problem with the old computer!  Is this a known problem with the Qualcomm Atheros AR5BWB222 ANA, and if so, has anyone come up with a fix for it?  I have saved a hard copy of the diagnostic info from the last time I got knocked offline, and

Best Answer

  • scolburnscolburn Posts: 7

    Tinkerer

    Accepted Answer

    Yes, that seems to have fixed the issue for my desktop All-in-One Aspire 5600U.  The setting in Windows 8 is:

    Control Panel>Hardware and Sound>Device Manager>Network Adapters.

    Then choose Qualcomm Atheros AR5BWB222 Wireless Adapter and

    Uncheck the box labelled "Allow the computer to turn off this device to save power."

    I have tested that setting for the past few days and have not gone offline once.

    it's a shame that a lot of unnecessary fixes are being offered, that don't solve the problem,

    and that Acer support does not advise customers to do that, before they try something more drastic.

    If I had followed their instructions, I would have ended up paying to ship it to Acer for repair,

    and who knows what I would have gotten back, since their technical support doesn't seem to be aware of this!

    Turning in a brand-new computer for someone else's reconditioned computer is never going to be a good solution, to me.

    Nor is having to pay for shipping to fix a computer that should work, out of the box.  Very disappointed in Acer support.  I doubt that I would buy my next computer from them, now that I know about the quality of their technical support and customer service.

    This solution seems to work fine for a desktop, but not so well for a portable computer.  So much for efficient energy management!

    Thanks for the suggestion, at long last something that worked!

«1

FAQ & Answers

  • DrkBluePenguinDrkBluePenguin Member Posts: 18

    I have the same card in my V3-771G and I feel ya. Out of the box I had the disconect issues. Updating the bios and wireless driver fixed this issue. But this also brings on a new set of problems if you use bluetooth and thats where I'm at. I''ve sent the laptop back a few times and nothing fixes it. 

    If you want to read about my issues you can find it here. http://community.acer.com/t5/Notebooks-Netbooks/Need-some-tech-savvy-people-to-help-me-with-my-problem-Bluetooth/m-p/113601

  • scolburnscolburn Member Posts: 7

    Tinkerer

    Yep, the suggested fixes are no fixes.  I also contacted Qualcomm's Atheros Division, and they replied that it is Acer's responsibility to provide the necessary drivers--they can't help, they just sell the components to the OEM's, who modify them to work with their products.  Another dead end.  That's a shame that the WNA is in your laptop, at least with my AIO, not being portable, I can direct-connect to my router.

     

    I have had success tethering my tablet to my cell phone's internet connection, using a bluetooth connection.  That's how I get online when traveling by car, when I want to read and am riding shotgun.  Maybe that approach would work for getting a reliable connection on the latop, although I know that some CP providers block tethering, and the connection is rather slow on my 4G LTE Droid.  So far the best solution I've seen is buying an external WNA (USB Dongle).  I don't know what the speed or quality of that connection would be, never having used one.  I'd look for a USB 2.0-3.0 model, hopefully with dual 2.4 & 5.0 bands.

     

    I feel your pain!  Your experiences with trying to work it out have saved me from jumping through hoops that didn't need to be jumped through, only to return to the same place you started.  As an Senior Analyst, I learned over the years, working with various I.T. staff, how to spot a  "solution", and keep asking for "another/better choice."  Acer can lick this, they just need more motivation:-)

  • padgettpadgett ACE Posts: 4,021 Pathfinder

    Did you try opening Control Panel>Device Management>Network adapers then right click on the Qualcom adapter, select properties>power manaugement and uncheck everything ?

  • scolburnscolburn Member Posts: 7

    Tinkerer

    Accepted Answer

    Yes, that seems to have fixed the issue for my desktop All-in-One Aspire 5600U.  The setting in Windows 8 is:

    Control Panel>Hardware and Sound>Device Manager>Network Adapters.

    Then choose Qualcomm Atheros AR5BWB222 Wireless Adapter and

    Uncheck the box labelled "Allow the computer to turn off this device to save power."

    I have tested that setting for the past few days and have not gone offline once.

    it's a shame that a lot of unnecessary fixes are being offered, that don't solve the problem,

    and that Acer support does not advise customers to do that, before they try something more drastic.

    If I had followed their instructions, I would have ended up paying to ship it to Acer for repair,

    and who knows what I would have gotten back, since their technical support doesn't seem to be aware of this!

    Turning in a brand-new computer for someone else's reconditioned computer is never going to be a good solution, to me.

    Nor is having to pay for shipping to fix a computer that should work, out of the box.  Very disappointed in Acer support.  I doubt that I would buy my next computer from them, now that I know about the quality of their technical support and customer service.

    This solution seems to work fine for a desktop, but not so well for a portable computer.  So much for efficient energy management!

    Thanks for the suggestion, at long last something that worked!

  • ewernewern Member Posts: 1

    Padgett,

     

    Thank you, thank you, thank you.
    I just got a new (refurbished) Acer laptop. Had issues with it playing and downloading videos. Buffering didn't seem to work, and downloading the file kept failing. I found this link and unchecking the power saving box in the network adapter property box (and rebooting) did the trick.
    I didn't contact Acer support. It seems they need to add this solution to their knowledgebase. Better yet, they should amend their Windows installation script. They can save a lot of returns and have happier customers.

  • n2gcn2gc Member Posts: 104

    If any should need a real Acer driver for the WIFI card, here ya go.

     

    http://global-download.acer.com/GDFiles/Driver/Wireless%20LAN/Wireless%20LAN_Atheros_10.0.0.217.v3_W8x64_A.zip?acerid=634922543832226505&Step1=NOTEBOOK

     

    Another option is to get rid of the Athreos and go with either an

    Intel 5300 card or 4695 WIFI card. Drivers are avail and I have

    both if any should decide to go this route. I run the 5300 in my

    7520 and the 4695 in my 5315. I t just depends if you have the

    long card or mini card. Now this suggestion is for W7 OS. I

    don't know if W8 will affect the drivers for the intel cards

    as I don't run W8, but may try these drivers on another lappy

    I'm working on and will load W8 just to see what works and

    what doesn't regarding aftermarket drivers and cards.

  • ZermanzZermanz Member Posts: 1

    I have tried so many times, and nothing has happened. I am so tired of this. I payed 1300 £ for my acer g, and I can't even connect to wireless netwroks. I can only use ethernet and my routher/ broadband have problem with ethernet connection. I hate this! Never an acer again! I am in the end of my tether, and done everything I can

  • MrRatioMrRatio Member Posts: 14

    I have this same problem on my Acer Aspire One 725.

    Never Acer again Smiley Sad

     

    //Update

     

    Probably I fixed this issue. This problem I have on driver 10.0.0.251 from 27 may 2013.

    I found new drivers: 10.0.0.255 from 02 July 2013. In this version I do not have this issue all day.

     

    Download: http://www.atheros.cz/atheros-wireless-download.php?chipset=74&system=5

  • speirssspeirss Member Posts: 2

    Aspire V5-431P with Atheros AR5BWB222

    I did a complete refresh and re-install with upgrade to Windows 8.1. Followed this by disabling the BT and uninstalling WLAN driver. Then upgraded to the latest .263 driver for the WLAN. Disabled the auto power off setting. 

     

    The good news is that it seems to have eliminated the internet dropping issue, the bad news is that it is only when I am sitting within 10 feet of the router. If I go upstairs the network connetion remains strong but alas the internet is dropped. I am now officiallly stumped. Anyone got any suggestions? 

    by the way this problem did not occur while running 8.0 and had progressively gotten worse over time after upgrading to 8.1 to the point where wireless connetion to the internet was useless.

    PS. nothing wrong with the router, it works perfectly with all my other devices.

     

  • scolburnscolburn Member Posts: 7

    Tinkerer

    Yep, this is definitely a firmware issue with Acer's implementation of the Qualcomm Atheros WNA.  It has shown up in every model that Acer uses it in, from laptops to All-in-Ones, regardless of the OS that computer is running.  Qualcomm has already told me that it's not their hardware, but the Acer firmare implementation.  The only ways to get around the problem are (1) to direct-connect with a network cable to your router, or (2) buy an add-on WNA and disable (or replace, if buying an internal WNA card) the Atheros WNA.  Doesn't matter what your router is, you will have problems maintaining the connection.  I have an ASUS Dark Knight, which is just about the best, strongest, most capable, feature-rich router out there right now, and it can't maintain a wireless connection to the ASUS for more that 5 minutes without a reset, regardless of how I change the WNA settings, including the auto power-off option.

  • MrRatioMrRatio Member Posts: 14

    I have this problem on Aspire One 725 few times in one day and I fixed this issue.

     

    1. Uninstall all drivers for WiFi (in Device Management too).

    2. Reebot PC.

    3. Download and install drivers in version 10.0.0.255 (do not use other versions).

    4. Control Panel>Device Management>Network adapers then right click on the Qualcom adapter, select properties>power manaugement and uncheck everything.

     

    In four days I have 0 (zero) WiFi disconnections so it works properly Smiley Happy

    Amen.

  • speirssspeirss Member Posts: 2

    I thought the same thing, until I went up the stairs...... good luck

     

  • MrRatioMrRatio Member Posts: 14

    Router is in one room and laptop is in second room. Between the two rooms is a half-meter, concrete wall. All works fine.

  • AndMacAndMac Member Posts: 1

    Thank you very much to those who have offered solutions; I've had the same issues and have duly unticked the box and crossed my fingers.

     

    My work is almost purely internet based and at times it's absolutely critical that I don't drop connection. I've had my laptop and fibre-optic broadband since July and have experienced this periodically, but it's now reached ridiculous levels of disconnnection since I upgraded to Windows 8.1.  I switch browsers regularly - I usually use Opera or Firefox.

     

    I decided to buy an Acer laptop as my Acer desktop, running XP and now 6 years old has been generally reliable. Hmm.

     

    I had similar problems with my old Sony VAIO netbook after installing fibre-optic broadband, but discovered that if I avoided using Chrome, all was usually well.

     

    As I work from home and have more than one laptop, if all else fails I shall hook my laptop up directly to the router.

  • d0min0d0min0 Member Posts: 5

    Hello, I feel you that you bought an acer pc with these network drivers. I'm so regretful that I bought this piece of **** with internet that can't even function normally. Basically, nothing helps it's a huge problem of acer thta they didn't take care of. The only solution is to buy an USB wireless adapter or just change your network adapters because neither wired network works neither wireless. Everything about networking in acer pcs with these drivers is ****** up. You will just waste your time with these solutions because you will find other stuff not working for you. These drivers are good for just browsing, but I have issues with Steam and other software which uses internet connection. As soon as I started using USB wireless adapter, EVERYTHING works like it should on a ****** new laptop for 1500$.

  • MrRatioMrRatio Member Posts: 14

    Just use new drivers: 10.0.0.270 (atheros.cz)

  • n2gcn2gc Member Posts: 104

    You all might find this link of some interest. It appears to point to the link

    above for the drivers from .atheros.cz. I don't use ANYTHING atheros, instead Intel

    WIFI cards, and I understand peoples frustration's with dropped signals, so that's

    Why Intel for me, but in any event below may help.

     

    http://www.tomshardware.com/forum/3975-73-qualcomm-atheros-ar5bwb222-windows-driver-download

     

     

  • mbeerensmbeerens Member Posts: 2

    Hi everyone,

     

    I tried everything like you have done as well. I even let Acer sent my two new PCI WIFI cards for my two Aspire Laptops V3 772G, unfortunatly all for nothing. I noticed that nothing in the browser worked, and the wifi conintued to reconnect. But Skype for example worked well, we took this all into consideration with a friend of mine and he came with a solution.

     

    The proper solotion for you all. 

     

    Set your computer to use the "google proxy server"

     

    https://support.google.com/chrome/answer/96815?hl=en 

     

    From there on your internet connection will be restored forever. 

     

    Good luck!

     

    Kind regards,

     

    Maikel

  • MarzEzMarzEz Member Posts: 2

    I'm stuck wit an AR5BWB222 as well. Got in my V5-571.
    Had issues with WiFi dropping from day 1. Fixed it with a driver update, but the issue's back after upgrading to Windows 8.1.
    Wish acer would find a solution to this problem.
    Will try power management options and see if it helps.
    (Hell, the internet dropped in the time it took me to write this post.)

  • MrRatioMrRatio Member Posts: 14
This discussion has been closed.

Who's Online in this Category0

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos