Let's Get Social!

Ask our members for help or assist others.
You are all welcome at Acer Community!

Showing results for 
Search instead for 
Did you mean: 

This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

Visit our Product Forums for more current content.

I am sick and tired of Acer and Windows 8.1!


I am sick and tired of Acer and Windows 8.1!

Acer Aspire V5-571, Win 8


What started as simple upgrade to 8.1 has become a nightmare of wasted and frustrating time. Acer Support is useless, but maybe community can help. Or maybe Costco will read th elist of uselessness and take it back and stop selling Acer altogether. I used to be a big fan but this experience has turned me off the brand completely.


I've updated FOUR other brands with no problem. I've spen t th best part of two days with this Acer and nothing I've tried works.


After I decided to check out the BIPS to see if UEFI was part of th eproblem, I changed the BIOS to Lagacy and now it won't boot to the BIOS Menu (F2). NOTHING on the Acer site tells you how to fix this. Whoever heard of a BIOS that can't load without the operating system. The error is "Operating System not found" and F2 doesn't work.


Ideas anyone? Please no regurgitating of "press F2 on POST". It doesn't work -- see above.



Accepted Solutions

Re: I am sick and tired of Acer and Windows 8.1!

its okay..

btw, try again the 2.17 sir... 


unzip the exe there...

after that...


locate the update.bat then run it...


Fix Problem With EUFI set to "BIOS Legacy" And No Access (Win 8.0)

Extracting BIOS 2.17 and updating BIOS worked. Thank you for the suggestion. :-)


Here's the steps I took to get the system bootable (and BIOS accessible via F2)


System powered off.

Insert USB System Recovery Drive (I used Windows 8.1 but it probably will work with a Windows 8.0 version) or Windows 8.0/8.1 Install DVD) and power on. Don't bother pressing F2 (it won't acces the BIOS).

Insert USB drive with *unpacked* BIOS 2.17 installer files

Select Language

Go to Repair, Advanced Option, Command Prompt

Change to the USB drive containing the BIOS 2.17 *unpacked* files

type update.bat (you might get a DNS error message -- no idea why)

The updater will check if the current BIOS is the same or earlier (so if you have updated to a later BIOS, you'll have to use that BIOS install instead) then go through the update process. Be sure to read ALL the instructions as you proceed.

After a reboot the BIOS will be updated and you will be prompted to shut down and restart.

After shut down remove all the USB drives/DVD

Restart and pres F2 at Acer screen (or immediately after restart)

You can go into the UEFI BIOS and check the settings (it defaults back to UEFI BIOS)

Go to Exit -> Save and Exit

The system restarts and loads Windows 8.0 (I suppose it would do the same for 8.1 but I didn't test with 8.1)

All done.


Re: I am sick and tired of Acer and Windows 8.1!

1st of all,,, NEVER update bios if you have no problems with it..


and never try anything you dont know about.

2nd., before searching, i think you can search for similar problems to yours which is mine here:



3rd... follow my steps there..

all you need is

1. bootable flash drive.. (any windows, better if 8 or 8.1)

2. the latest bios update... or if you updated it, then the previous working version
3. winrar on your primary driver.. or anything that can extract files..


follow those steps from the url


there is a 2nd option, you can opt to fix yours by going to windows repair, (i forgot the button, try going for f3 to f12)

as i know, f12 shows you the boot menu, if you enabled it in the past..


also, try ctrl+alt+esc... that is for the bios setup of older acer laptops


and f2 of course, if not responding, but sends a beep..


go to windows repair, then advance options then go change uefi or firmware settings, if not present, then go to the another option which is in the url.. 


hoped i helped and you learned your lesson..

Tags (1)

Re: I am sick and tired of Acer and Windows 8.1!

F12 won't work -- because it's not actually loading the BIOS. That's why F2 won't work. I've worked on hundreds of systems over 30 years and I've NEVER had one that can't go to the BIOS. Until this Acer. Any BIOS setup that requires the OS to load it is useless precisely because of situiations like this.


As for unpacking and installing a BIOS update, the C drive isn't accessible -- see above.


Re: I am sick and tired of Acer and Windows 8.1!

PS. Lose the superior attitude as well. It's not helping. You might know what you're talking about but your 'advice' gets lost in the noise of your crowing. It might work on the minion crowd, but it's lost on me.


Re: I am sick and tired of Acer and Windows 8.1!

you can access it using the command prompt..

basics are..

cd for change directory..
dir for knowing what files and folders are present there


you should what is in the url


Re: I am sick and tired of Acer and Windows 8.1!

does clicking f2 makes a beeP?


Re: I am sick and tired of Acer and Windows 8.1!

first of all... for all i know,, that problem still LOADS the BIOS... BUT... it doesnt go to the setup...

Loading the bios and going to bios setup is different...


Re: I am sick and tired of Acer and Windows 8.1!

The fundamental purposes of the BIOS are to initialize and test the system hardware components, and to load a bootloader or an operating system from a mass memory device. http://en.wikipedia.org/wiki/BIOS


Re: I am sick and tired of Acer and Windows 8.1!

absolutly upgrade to windows 8.1 take a long time on blank screen.
if you want to re-install or repair it you may try to boot from installation or make it enter to safe mode (recovery emvironment).
Change to legacy make your windows won't boot because you install your windows on UEFI mode, there's a system configuration difference of them.

Re: I am sick and tired of Acer and Windows 8.1!

I know what a BIOS does. I was probably configuring BIOSes before you were born! :-)


I know what it shoud do. That's not the problem. It's not doing it is the problem. Once again.... <sigh>


IF you change the BIOS Setting from UEFI to Legacy when you restart the system you CANNOT get into the BIOS -- by pressing F2, or any other key or combination. Not even by or standing in the corner on your head and whistling the theme from "Man of La Mancha".


Why? Because the dafault BIOS Boot Order is "Secure Boot Manager" and for that you have to have an accessible Windows 8 drive. And that Windows 8 drive will only boot when the BIOS is set to UEFI.


Is that clear enough? No? Then I can't help you any more, and I do request that you stop injecting your "I'm a superior tech" into the thread. You're not helping. Thank you.