How to change SATA mode from " Optane without RAID " to AHCI ? Acer Aspire 7 A715-75G.

anuragnittanuragnitt Member Posts: 2 New User
I want to install Kali Linux on my Acer Aspire 7 A715-75G.
The Linux installation setup doesn't detect the SSD.
I think it detects drives with AHCI SATA mode but I cannot find any option in the BIOS menu
which allows me to change the SATA mode from " Optane without RAID " to AHCI.
Please help !

Best Answer

  • batmalinbatmalin Member Posts: 4,158 Guru
    Answer ✓
    Hi, boot to Windows and follow the instruction below:
    1. Clck the Start Button and type cmd
    2. Right-click the result and select Run as administrator
    3. Type this command and press ENTER: bcdedit /set {current} safeboot minimal 
    4. Restart the computer and enter BIOS Setup by tapping on F2
    5. Change the SATA Operation mode  from RST to AHCI (press crtl+s on the main tab if the option is not visible) 
    6. Save changes and exit Setup and Windows will automatically boot to Safe Mode.
    7. Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
    8. Type this command and press ENTER: bcdedit /deletevalue {current} safeboot (ALT: bcdedit /deletevalue safeboot)
    9. Reboot once more and Windows will automatically start with AHCI drivers enabled.
    10. After that you will be able to install Linux
    Please click "Yes" if I have answered your question.
    Userbench: https://www.userbenchmark.com/UserRun/31177158

FAQ & Answers

  • batmalinbatmalin Member Posts: 4,158 Guru
    Answer ✓
    Hi, boot to Windows and follow the instruction below:
    1. Clck the Start Button and type cmd
    2. Right-click the result and select Run as administrator
    3. Type this command and press ENTER: bcdedit /set {current} safeboot minimal 
    4. Restart the computer and enter BIOS Setup by tapping on F2
    5. Change the SATA Operation mode  from RST to AHCI (press crtl+s on the main tab if the option is not visible) 
    6. Save changes and exit Setup and Windows will automatically boot to Safe Mode.
    7. Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
    8. Type this command and press ENTER: bcdedit /deletevalue {current} safeboot (ALT: bcdedit /deletevalue safeboot)
    9. Reboot once more and Windows will automatically start with AHCI drivers enabled.
    10. After that you will be able to install Linux
    Please click "Yes" if I have answered your question.
    Userbench: https://www.userbenchmark.com/UserRun/31177158

  • anuragnittanuragnitt Member Posts: 2 New User
    batmalin said:
    Hi, boot to Windows and follow the instruction below:
    1. Clck the Start Button and type cmd
    2. Right-click the result and select Run as administrator
    3. Type this command and press ENTER: bcdedit /set {current} safeboot minimal 
    4. Restart the computer and enter BIOS Setup by tapping on F2
    5. Change the SATA Operation mode  from RST to AHCI (press crtl+s on the main tab if the option is not visible) 
    6. Save changes and exit Setup and Windows will automatically boot to Safe Mode.
    7. Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
    8. Type this command and press ENTER: bcdedit /deletevalue {current} safeboot (ALT: bcdedit /deletevalue safeboot)
    9. Reboot once more and Windows will automatically start with AHCI drivers enabled.
    10. After that you will be able to install Linux
    batmalin said:
    Hi, boot to Windows and follow the instruction below:
    1. Clck the Start Button and type cmd
    2. Right-click the result and select Run as administrator
    3. Type this command and press ENTER: bcdedit /set {current} safeboot minimal 
    4. Restart the computer and enter BIOS Setup by tapping on F2
    5. Change the SATA Operation mode  from RST to AHCI (press crtl+s on the main tab if the option is not visible) 
    6. Save changes and exit Setup and Windows will automatically boot to Safe Mode.
    7. Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
    8. Type this command and press ENTER: bcdedit /deletevalue {current} safeboot (ALT: bcdedit /deletevalue safeboot)
    9. Reboot once more and Windows will automatically start with AHCI drivers enabled.
    10. After that you will be able to install Linux
    Thanks a lot !
    That solved my issue.
  • batmalinbatmalin Member Posts: 4,158 Guru
    You are welcome!
    Please click "Yes" if I have answered your question.
    Userbench: https://www.userbenchmark.com/UserRun/31177158

  • 1970jip1970jip Member Posts: 6

    Tinkerer

    I've tried this steps but I don't get any progress.
    Ctrl+s doesn't work, no changes are made.
    SATA parameter in main tab of the BIOS remain as Optane without RAID value, and it doesn't change.

    I'd really appreciate youor help on this.
    Regards
  • batmalinbatmalin Member Posts: 4,158 Guru
    edited November 2020
    Ctrl+s doesn't change the setting just makes it to unhide. Select it and change it to AHCI
    Please click "Yes" if I have answered your question.
    Userbench: https://www.userbenchmark.com/UserRun/31177158

  • 1970jip1970jip Member Posts: 6

    Tinkerer

    Thanks for your reply
    I cannot select it, in fact, I cannot select any parameter in the first tab of the BIOS. It's like an Information screen.
    Or shall I change this parameter in a different place? Maybe from Windows?

    Regards

  • 1970jip1970jip Member Posts: 6

    Tinkerer

    Solved!!!

    Sorry, my bad. I was trying Ctrl+S in "Information" tab instead of "Main" tab
    Once SATA mode has been updated, I'll try to install Linux again.

    Thanks for all.

  • batmalinbatmalin Member Posts: 4,158 Guru
    You are welcome!
    Please click "Yes" if I have answered your question.
    Userbench: https://www.userbenchmark.com/UserRun/31177158

  • Jas000Jas000 Member Posts: 3 New User
    Doing so and writing command for the first time and than running it resulting in password incorrect, now what should I do ?
  • batmalinbatmalin Member Posts: 4,158 Guru
    Doing  what, what command and what password? Where you saw a password in this topic?
    Please click "Yes" if I have answered your question.
    Userbench: https://www.userbenchmark.com/UserRun/31177158

  • neopantherneopanther Member Posts: 13 Troubleshooter
    batmalin said:
    Hi, boot to Windows and follow the instruction below:
    1. Clck the Start Button and type cmd
    2. Right-click the result and select Run as administrator
    3. Type this command and press ENTER: bcdedit /set {current} safeboot minimal 
    4. Restart the computer and enter BIOS Setup by tapping on F2
    5. Change the SATA Operation mode  from RST to AHCI (press crtl+s on the main tab if the option is not visible) 
    6. Save changes and exit Setup and Windows will automatically boot to Safe Mode.
    7. Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
    8. Type this command and press ENTER: bcdedit /deletevalue {current} safeboot (ALT: bcdedit /deletevalue safeboot)
    9. Reboot once more and Windows will automatically start with AHCI drivers enabled.
    10. After that you will be able to install Linux
    i did this and installed linux but then when i try to open the bios , it crashes (like it only shows a underscore there)
  • batmalinbatmalin Member Posts: 4,158 Guru
    Delete as root grubx64.efi and BIOS will appear by next reboot
    Please click "Yes" if I have answered your question.
    Userbench: https://www.userbenchmark.com/UserRun/31177158

  • neopantherneopanther Member Posts: 13 Troubleshooter
    from where should I delete it 
    please explain 
  • batmalinbatmalin Member Posts: 4,158 Guru
    Search at boot/efi/  should be there and delete it as root.
    Please click "Yes" if I have answered your question.
    Userbench: https://www.userbenchmark.com/UserRun/31177158

  • neopantherneopanther Member Posts: 13 Troubleshooter
    edited January 2021
    batmalin said:
    Search at boot/efi/  should be there and delete it as root.
    am i supposed to do it from linux(pop os)
    and I didn't get any grub when booting. I had to select it from bios by pressing f12
  • batmalinbatmalin Member Posts: 4,158 Guru
    Yes, boot from from linux and delete the file.
    Please click "Yes" if I have answered your question.
    Userbench: https://www.userbenchmark.com/UserRun/31177158

  • rva1945rva1945 Member Posts: 6

    Tinkerer

    batmalin said:
    Hi, boot to Windows and follow the instruction below:
    1. Clck the Start Button and type cmd
    2. Right-click the result and select Run as administrator
    3. Type this command and press ENTER: bcdedit /set {current} safeboot minimal 
    4. Restart the computer and enter BIOS Setup by tapping on F2
    5. Change the SATA Operation mode  from RST to AHCI (press crtl+s on the main tab if the option is not visible) 
    6. Save changes and exit Setup and Windows will automatically boot to Safe Mode.
    7. Right-click the Windows Start Menu once more. Choose Command Prompt (Admin).
    8. Type this command and press ENTER: bcdedit /deletevalue {current} safeboot (ALT: bcdedit /deletevalue safeboot)
    9. Reboot once more and Windows will automatically start with AHCI drivers enabled.
    10. After that you will be able to install Linux
    Mine is an Acer Aspire 3 with Optane.

     I need to disable RST but can't manage to do it. I typed the command bcdedit /set {current} safeboot minimal (it said Sucess) then in the BIOS there is no way to change the SATA mode, it is in RAID mode. Ctrl+s does nothing, no new option appears.
    In Advanced rtab I see 
    Intel VIX: enabled/disabled 
    Intel VID: enabled/disabled
    (both enabled)
    SATA configuration: if I enter here the options are
    SATA port 0: enabled/disablkd
    SATA port 1: enabled/disablkd
    (both enabled)

    but nothing related to changeing SATA mode.

    I need to install Linux Ubuntu but it says it can´t because of he RST mode.

    Anywat whan I reboot now it is in Safe Mode with the icons and "Safe Mode" text at the corners everything blinking all the time and I can´t do anything.


  • batmalinbatmalin Member Posts: 4,158 Guru
    edited February 2021
    Update your BIOS... and make sure you press ctrl+s on the main tab.
    Please click "Yes" if I have answered your question.
    Userbench: https://www.userbenchmark.com/UserRun/31177158

  • haris53haris53 Member Posts: 1 New User
    Hi there Friends , i really need help .. why is my acer laptop always power off automatically .. unless if i press the keyboard without release it . any idea guys? 
Sign In or Register to comment.

Who's Online973

Acer-Monica
Acer-Monica
billsey
billsey
dosboy
dosboy
KaushikGautam
KaushikGautam
msagagamina
msagagamina
vlado22
vlado22
+967 Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers