Disable function keys Aspire TC-885 i7.

juliekjuliek Member Posts: 3 New User
I have just bought an Acer Aspire TC-885 i7. I will be using it with NVDA screen reader and Osara. They use the function keys, but can't use them as Windows is using them at the moment. I read somewhere that you can disable them in the BIOS settings, in system configuration, but I can't find that on my computer. Can anyone advise me how to do it, please?

FAQ & Answers

  • MartinJohn00001MartinJohn00001 Ally Posts: 636
    @juliek

     Hi, Follow the steps below to disable Fn keys in the BIOS.
     
      1. Turn off the unit. When the unit is off completely, press the power to turn on the unit. Immediately keep on tapping the Delete key to enter the BIOS.
      2. Use the right-arrow or left-arrow keys to navigate to the System Configuration option.
      3. Use the up-arrow or down-arrow keys to navigate to the Action Keys Mode option, and then press the "Enter" key to display the Enable / Disable menu.
      4. Select the desired mode.
      5. Press "F10" to save your settings and restart the computer.

        I hope that this is helpful to you! If I have answered your question click YES alone please, thank you  :3   

    Kindly click "YES" to "Did this answer the question" if my answer helped you!      
    Thank you and have a Blessed Day  :3
  • juliekjuliek Member Posts: 3 New User
    Thank you for your reply. I tried that, but couldn't find a system configuration tab. Would it be anywhere else?
  • VernonGeekVernonGeek Member Posts: 2 New User
    Same issue, Same model.  I updated to latest BIOS and there is NO System Configuration in the BIOS.  I am a tech and searched all menus in the BIOS but there is no Fn key control.

    i am considering using an aftermarket keyboard, such a Logitech that have a special Fn Lock key, and am wondering if that might override the special functions.  I doubt it, as there are only two states for the Fn Keys (on/off).

    Please put the ability to disable the hotkey features of the Fn keys back into the BIOS.  
  • VernonGeekVernonGeek Member Posts: 2 New User
    Also searched the keyboard and could not locate a Fn-Lock option on this keyboard.  Is there an Easter egg keystroke combination that enables/disabled the Fn keys?
  • tttttttttt Member Posts: 998 Seasoned Specialist
    Why don't change for a generic keyboard like me? Acer's keyboard isn't good anyway.

  • juliekjuliek Member Posts: 3 New User
    In the end, we did change the keyboard, and that sorted it out. Thanks for your replies.
  • ALF_TannerALF_Tanner Member Posts: 5 New User
    I just installed the latest BIOS on my Acer Aspire TC-885, and there is still no option to disable the annoying special keys so that the normal function keys will work.  The only way I could find to get normal functions keys was to throw the piece of garbage Acer keyboard in the garbage and replace it with a normal generic keyboard.
  • tttttttttt Member Posts: 998 Seasoned Specialist
    Dear ALF_Tanner,

    How about start a new thread?

    I believe I have found a solution on similar topic yesterday.
  • ALF_TannerALF_Tanner Member Posts: 5 New User
    ttttt, I do not think there is any solution.  I tried everything that people recommended, and nothing worked.

    Here is a list of things that people suggested that do NOT work:
    - There is no option in the BIOS. 
    - There is no language setting in Windows. 
    - The Fn-padlock key does not change the Fn lock.  It only logs out the user.
    - The "enable special keys" in Spanish is actually for the sticky keys and has nothing to do with the Fn key.
    - Num-lock does not affect Fn-lock.
    - The settings button does not bring up Fn-lock settings.
    - Fn-Esc does not work.
  • tttttttttt Member Posts: 998 Seasoned Specialist
    @ALF_Tanner

      To make  things simple, I suggest people to change for a generic keyboard. I use a generic one and the function keys seemed to be the same as Acer's keyboard with the "Fn" key pressed.

     https://www.top-password.com/blog/disable-windows-key-shortcuts-hotkeys

    Read this link see it will help. 

    It may be risky as it involves the Register Edit, so be careful!
  • pickeringpickering Member Posts: 1 New User
    WORST KEYBOARD OF ANY MANUFACTURER. NO ROOM TO ACCESS THE LEFT SHIFT KEY. THREW FIRST ONE OUT AND RETURNED SECOND COMPUTER FOR SAME REASON. OTHERWISE COMPUTER AND MONITOR ARE GOOD. 
  • klty0988klty0988 Member Posts: 1 New User
    edited January 21
    Hi all, here is the best solution so far

    1. Find a place or document on your computer where you can find and copy paste the letter 'K'. For example, what I did was open a web browser, and I went to the web bookmarks to open a site that had the letter k in their URL. Doesn't matter how you do it, just get the letter K (since the numlock would have prevented your letter K from working)
    2. After copying the letter K, go to the Windows Search and search for 'KEY'. Note that the letters E and Y will not be affected by the NumLock, so what you do is just paste the letter K that you have copied, then type E and Y (to form the word KEY). You should then see the link to 'On-Screen Keyboard' appear. Click on it.
    3. With the On-Screen Keyboard open on your screen, click the 'Options' key on the on-screen keyboard (near the bottom right)
    4. In the menu that appears after, click to check the 'Turn on numeric keyboard' box. Click OK
    5. You will now see the Numlock key displayed (at the bottom right) on your on-screen keyboard. Click on it to deactivate it. And now NumLock is off, and you are good to go! No need to worry about the Fn key ;)

    ____

    On a side note, by any chance anyone is interested in data science related articles, please feel free to check out: http://kennethleungty.medium.com/ Cheers!
  • acreuser786171acreuser786171 Member Posts: 1 New User
    I have Aspire 3 and faced the same proble. I used the BIOS method but the settings were different. I have put up a step by step with images here - https://www.sumitcbrty.com/how-to-change-default-function-key-and-media-key-settings-in-acer-aspire-laptops-with-images/

    If you dont want to visit the site - here are the steps 
    Step O: Plug in your charging cable
    Step 1. Shut down your laptop
    Step 2. Enter the boot screen (mine works by F2)
    Step 3. Head over to the "Main" tab and function key settings
    Step 4. Change "Function key setting"
    Step 5. Save the settings (F10)
Sign In or Register to comment.

Who's Online1.4K

abdoo
abdoo
Acer-Erick
Acer-Erick
Acer-George
Acer-George
Acer-Ingrid
Acer-Ingrid
alekseyzhukov
alekseyzhukov
Arlein
Arlein
biggi
biggi
billsey
billsey
Chris_P
Chris_P
darth_mulligan
darth_mulligan
EduardoLTZ
EduardoLTZ
EmilioGalindo
EmilioGalindo
fernandov28
fernandov28
Fisher_P
Fisher_P
island
island
MARY19
MARY19
pandalotero
pandalotero
PrskMate
PrskMate
Sanketh0012
Sanketh0012
ShubhamTamhane
ShubhamTamhane
Speculoos
Speculoos
survivalcar
survivalcar
VeganCzech
VeganCzech
Yibo_de
Yibo_de
Zeytun
Zeytun
Dylan_05
Dylan_05
mdpattaguan
mdpattaguan
Larryodie
Larryodie
+1.4K Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1961

Total Points:6332

Total Accepted Answers: 246

Leostat Community Aficionado