Examples: Monday, today, last week, Mar 26, 3/26/04

Aspire 5 A515 - 52G Disable keyboard backlight timeout?

F3reespiritF3reespirit Member Posts: 6

Tinkerer

Hi,
I can't find the setting to disable the timeout for the keyboard backlight.
How do I do that?

Have the Aspire 5 A515 - 52G - ... with Windows 10 and can't find the setting or shortcut to let the backlight stay on.

Best Answers

  • brummyfan2brummyfan2 Posts: 14,536 Trailblazer
    Accepted Answer
    Hi,
    It's a power saving feature but I understand your frustration with it, you may contact Acer Support centre about it and they may be able to provide a solution.
    http://www.acer.com/worldwide/support/
    Please click "Yes" for "Did this answer the question", if I resolve the problem.
    https://www.userbenchmark.com/UserRun/22060540
  • Acer-MannyAcer-Manny Posts: 2,948 Acer Crew
    Accepted Answer

    Hi all,

    Thank you for all the feedback provided on this matter, please keep in mind that the backlight automatically turning off 30 seconds after the last keystroke, is a power saving feature (mostly found in our newer models) as part of our effort to meet Energy Star7.0, Acer is unable to offer a support path to override or modify this feature if your model is not eligible for the following BIOS update:



    A "Keyboard Lighting Timeout" function has been implemented for the following models only: 

    Model

    BIOS v.

    Date

    Download Link

    Aspire T7000

    1.25

    2019/03/20

    Download

    Aspire A715-72G

    1.25

    2019/03/20

    Download

    Predator PH315-51

    1.25

    2019/03/20

    Download

    Aspire A717-72G

    1.25

    2019/03/20

    Download

    Nitro AN515-52

    1.25

    2019/03/20

    Download

    Nitro AN515-53

    1.25

    2019/03/20

    Download

    Predator PH317-52

    1.25

    2019/03/20

    Download

    Model

    BIOS v.

    Date

    Download Link

    Nitro AN515-42

    1.13

    2019/03/08

    Download


    Note: Please keep in mind that this implementation (Main tab) will allow users to Disable the "Keyboard Lighting Timeout" option to have the Keyboard Backlight on at all times when on AC power only if the unit is on battery power, it will work as intended (automatically turning off 30 seconds after the last keystroke). You can check periodically for any drivers, manuals and BIOS updates here: Drivers&Manual official page

    Please follow the "Disable keyboard backlight timeout" instructions (FAQ):

    https://us.answers.acer.com/app/answers/detail/a_id/61998#_ga=2.159783933.1374864991.1552488642-1045363774.1531752932

    BIOS changes example:


    Note: This thread will be now closed and this reply will be marked as the solution.


    Best Regards,

    Acer-Manny

«1

FAQ & Answers

  • brummyfan2brummyfan2 ACE Posts: 14,536 Trailblazer
    edited November 2018
    Hi,
    No, that feature is not available in this model.

    Please click "Yes" for "Did this answer the question", if I resolve the problem.
    https://www.userbenchmark.com/UserRun/22060540
  • F3reespiritF3reespirit Member Posts: 6

    Tinkerer

    Thanks for your replie.
    I don't want to request a feature, I want just to turn one off basically, namely the clock that is ticking down and then disables the keyboard backlight. How can I disable this, because I have to write long hours and get distracted by this "flickering" keyboard a lot. Also when I start typing I often first hit the wrong key because I can't see the right one.
  • Hi,
    Unfortunately, the setting to keep the keyboard backlight switched on is not available.
    Please click "Yes" for "Did this answer the question", if I resolve the problem.
    https://www.userbenchmark.com/UserRun/22060540
  • F3reespiritF3reespirit Member Posts: 6

    Tinkerer

    edited November 2018
    Thank you,
    so how to fix it then?
    I can't type with this 700€ machine undisturbed. That is a basic task 200€ Chromebooks are able to do. Is a hack available, and if not how can I file a official complaint with all the other unsatisfied customer best? Any tips?
    Because there are a lot of people that don't like to search for a lamp every time they write long texts because the keyboard back light needs to be turned off to stop "flickering" disturbingly. That shouldn't be necessary, people are rightfully disappointed on this one.



  • brummyfan2brummyfan2 ACE Posts: 14,536 Trailblazer
    Accepted Answer
    Hi,
    It's a power saving feature but I understand your frustration with it, you may contact Acer Support centre about it and they may be able to provide a solution.
    http://www.acer.com/worldwide/support/
    Please click "Yes" for "Did this answer the question", if I resolve the problem.
    https://www.userbenchmark.com/UserRun/22060540
  • F3reespiritF3reespirit Member Posts: 6

    Tinkerer

    edited November 2018
    Ok,
    the guy from tech on the support line had no solution. I now wrote a mail with my arguments and ask to give it to the decision maker. Worst case I have to give the machine back because they do nothing. Best case they give a programmer some hours to fix this for them. Let's see ...
  • I hope they resolve it for your satisfaction.
    Please click "Yes" for "Did this answer the question", if I resolve the problem.
    https://www.userbenchmark.com/UserRun/22060540
  • YourReckoningYourReckoning Member Posts: 4 New User
    Good news guys. They finally fixed it. Atleast for my Nitro 5 they fixed it. Just go to https://www.acer.com/ac/en/IN/content/support type in your notebook model number and download the latest BIOS (V1.13 for me). After that, there should be an option called "Keyboard Backlight Timeout" in your BIOS settings which should be enabled by default. Disable it and save settings. And you should be good to go. Thank me later. :)
  • harshsingh98harshsingh98 Member Posts: 1 New User
    Hi,
    I can't find the setting to disable the timeout for the keyboard backlight.
    How do I do that?

    Have the Aspire 5 A515 - 52G - ... with Windows 10 and can't find the setting or shortcut to let the backlight stay on.
    The Backlit Keyboard is not switching on. please help. I tried Fn+F9, but didn't helped.
  • F3reespiritF3reespirit Member Posts: 6

    Tinkerer

    edited April 2019
    Hi,
    I can't find the setting to disable the timeout for the keyboard backlight.
    How do I do that?

    Have the Aspire 5 A515 - 52G - ... with Windows 10 and can't find the setting or shortcut to let the backlight stay on.
    The Backlit Keyboard is not switching on. please help. I tried Fn+F9, but didn't helped.
    I still have no solution for this problem. I was in support and had a guy on the phone, nothing. My keys still switch off after some seconds, and I can't fix that. So I spend around 800€ for a machine, I don't like to use now, because the blinking keys are highly distracting while writing important stuff for my company. I recommend to never buy an Acer again, because they don't seem to be able to get such small problems fixed or don't care to do so (Apple style).  Sorry

  • F3reespiritF3reespirit Member Posts: 6

    Tinkerer

    Good news guys. They finally fixed it. Atleast for my Nitro 5 they fixed it. Just go to https://www.acer.com/ac/en/IN/content/support type in your notebook model number and download the latest BIOS (V1.13 for me). After that, there should be an option called "Keyboard Backlight Timeout" in your BIOS settings which should be enabled by default. Disable it and save settings. And you should be good to go. Thank me later. :)
    Still not fixed for the Aspire 5 A515 - 52G it seems.
  • iaj92iaj92 Member Posts: 2 New User
    edited October 2019
     Oct 2019 and still no solution to this problem?  I recently purchased the A515-52G-52KN for $800.  This is an upgraded version with 8th gen i5 and MX250 graphics... but still no bios fix for backlight?

    Please Acer do the right thing for this laptop as many were on sale recently via Best Buy, and you will have a lot of customers unsatisfied.

    Personally, I was chosing between the Aspire 5 and the Zenbook.  Aspire 5 was better value option but might switch to Asus because of these issues... 14 days left for return, wonder how many Open Box units BestBuy will have; not a good look Acer.
  • SieberzSieberz Member Posts: 1 New User
    I discovered a solution to allow the keyboard backlight to stay on fulltime. Hit the [ N ] on your keyboard, next to NumLk, GeForce NitroSense controls. Open your Advanced Settings at the top, the Gear symbol. Find the Keyboard Settings at the bottom, deselect the "Backlight off after 30 seconds". It truly is this simple if you want the keyboards backlight on all the time. If you want it off all the time however, I haven't found a solution to this just yet. I hope this helps anyone out there who has been looking for a solution.

    Cheers!
  • jimfitterjimfitter Member Posts: 10

    Tinkerer

    edited November 2019
    Still no BIOS update for the Aspire A515-54. I am posting this flaw everywhere I can.
    Maybe with enough bad press, someone will address this. I sure am sorry I bought an Acer.
  • OldFatDogOldFatDog Member Posts: 1 New User
    Good news guys. They finally fixed it. At least for my Nitro 5 they fixed it. Just go to https://www.acer.com/ac/en/IN/content/support type in your notebook model number and download the latest BIOS (V1.13 for me). After that, there should be an option called "Keyboard Backlight Timeout" in your BIOS settings which should be enabled by default. Disable it and save settings. And you should be good to go. Thank me later. :)
    Glad it worked for you! It's very irritating. Unfortunately, it didn't work for me (BIOS 1.12) on my Acer A515-54. No such option appeared.

    The weird thing is, the F8 key looks like it might be a keyboard backlight toggle. (See attached.)

    But it doesn't actually toggle anything -- the keyboard backlight still times out after 30 seconds. Any idea what this particular F8 key is supposed to do?


  • DB22DB22 Member Posts: 7

    Tinkerer

    edited December 2019
    jimfitter said:
    Still no BIOS update for the Aspire A515-54. I am posting this flaw everywhere I can.
    Maybe with enough bad press, someone will address this. I sure am sorry I bought an Acer.
    Same here. I downloaded and installed the most recent BIOS, but the option to toggle the backlight on is still not available. I'm happy enough with the machine, but this tops the list of gripes I have. Acer machines have always performed well for me in the past. Will contact Acer tomorrow and add my complaint to yours.
  • OldFatDog said:
    Good news guys. They finally fixed it. At least for my Nitro 5 they fixed it. Just go to https://www.acer.com/ac/en/IN/content/support type in your notebook model number and download the latest BIOS (V1.13 for me). After that, there should be an option called "Keyboard Backlight Timeout" in your BIOS settings which should be enabled by default. Disable it and save settings. And you should be good to go. Thank me later. :)
    Glad it worked for you! It's very irritating. Unfortunately, it didn't work for me (BIOS 1.12) on my Acer A515-54. No such option appeared.

    The weird thing is, the F8 key looks like it might be a keyboard backlight toggle. (See attached.)

    But it doesn't actually toggle anything -- the keyboard backlight still times out after 30 seconds. Any idea what this particular F8 key is supposed to do?


    Hi,
    It's a power saving feature to preserve the battery life for laptops, you can use F8 button to switch off back light when you use the laptop in bright surroundings, you have to press Fn+F8 to switch off/on.
    Please click "Yes" for "Did this answer the question", if I resolve the problem.
    https://www.userbenchmark.com/UserRun/22060540
  • Harsh3338Harsh3338 Member Posts: 3 New User
    Not sure if this is a late post, but let me put it out there.
    I am using Nitro 5 AN515-43, and found a solution for the Keyboard back light.

    -> Open NitroSense application (default app for Fan control), if you don't have it please download from the Acer website & install the latest version, if it is supported for your machine.
    -> Go to Settings (Click on the gear icon you find on top right corner).
    -> You will find Keyboard Setting there, just below that "Backlight off after 30 Seconds" -> just Disable this option and you are good to go.
    -> To increase the backlight brightness press Fn + F10
    -> To decrease the backlight brightness press Fn + F9
    -> You're Welcome :-)

  • jimfitterjimfitter Member Posts: 10

    Tinkerer

    A BIOS update came and went, without a keyboard update. I keep giving bad reviews where I can, on this model, in various forums. Hopefully, the bad press gives someone the incentive to fix this. It really is frustrating to have to deal with this.
  • ThomasLindvigThomasLindvig Member Posts: 4 New User
    edited January 13
    I have the same totally annoying problem on my brand new very expensive Acer Aspire 7. No setting option in BIOS v1.19. Sometimes keyboard lights seems to turn off after just couple of seconds. I need to train myself to always press the CTRL firstly to activate the lights without writing, before writing...
    I had a Thinkpad where Windows 10 interfered with the keyboard lights, turned them on and off according to room brightness, but I can't find that setting on my Acer.

This discussion has been closed.

Who's Online in this Category2

LalGen7
LalGen7
ManishKataria
ManishKataria

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos