Examples: Monday, today, last week, Mar 26, 3/26/04

Issues with installing Linux distros on Aspire 7 A715-72G-56ZT


FAQ & Answers

  • CalebXCalebX Member Posts: 19 Troubleshooter
    Also tapping E doesn't bring up the grub loader either...
  • GawainGawain Member Posts: 286 Practitioner
    okay, try the right shift key instead as soon as the machine is powered on
  • CalebXCalebX Member Posts: 19 Troubleshooter
    @Gawain Right shift / Left shift  - doesn't work
  • JackEJackE ACE Posts: 20,091 Trailblazer
    I suspect your BIOS is set to look in the wrong subdirectory in the ESP for the efi. Maybe a remnant of the Mint terminal installation? We may have been through this already but can you actually see/select what subdirectory it's in from the BIOS security tab? Jack E/NJ
    Jack E/NJ
  • CalebXCalebX Member Posts: 19 Troubleshooter
    I can set it manually.
    I set the grub64.efi file to be trusted in the HDD/Ubuntu/grub64.efi and it hangs again.
    I delete the entry after that.
    I set the shim64.efi file to be trusted in the HDD/Ubuntu/shim64.efi and it hangs again.
  • JackEJackE ACE Posts: 20,091 Trailblazer
    Do you mean it hangs again on the blue screen with mouse cursor?   Jack E/NJ

    Jack E/NJ
  • CalebXCalebX Member Posts: 19 Troubleshooter
    I mean that the system pops up the purple screen for Ubuntu and the mouse appears and that is all.
  • JackEJackE ACE Posts: 20,091 Trailblazer
    Before or after logging in? Jack E/NJ
    Jack E/NJ
  • JackEJackE ACE Posts: 20,091 Trailblazer
    ...I am trying to install any Linux distro>>>

    Also, have the same stick and port been used for all these attempts? Jack E/NJ
    Jack E/NJ
  • CalebXCalebX Member Posts: 19 Troubleshooter
    3 sticks used so far on all of the ports. Before logging in.
  • JackEJackE ACE Posts: 20,091 Trailblazer
    Do any of the installations allow an advanced setup option of choosing which graphics adapter gets used? Jack E/NJ
    Jack E/NJ
  • GawainGawain Member Posts: 286 Practitioner
    JackE said:
    Do any of the installations allow an advanced setup option of choosing which graphics adapter gets used? Jack E/NJ
    JackE, i think CalebX will have tried that when i suggested making sure the "install 3rd party..." box is ticked during install as that should install the propriety vid drivers for Nvidia rather than just the default open source driver (as long as internet has been configured).  
  • JackEJackE ACE Posts: 20,091 Trailblazer
    Good point. Then I'd suggest unticking it to at least try to get into the system, even if only a terminal, with a plain vanilla intel-type driver. I suspect that might've been the way the Mint light was originally set up on this particular box.  Then work on getting the right nvidia driver for this proprietary ACER graphics combo which I now think might be the issue.  Jack E/NJ
    Jack E/NJ
  • CalebXCalebX Member Posts: 19 Troubleshooter

    Apologies for the 1 month absence. I had more high priority issues to attend and forgot about the forum post...
    So @JackE ; @Gawain a colleague managed to install a minimum installation of Debian 9. I don't know exactly how and don't remember any more.
    He is a sysadmin with 13+ years experience in Linux/Unix. I didn't manage to upgrade to the full Debian 9 Installation and tried putting a Manjaro 17.10 installation. I formatted my 2 new USB devices at DD format and tried them both. 1 of the devices managed to install the Manjaro under a designated USB port. I have 3 USB ports and 2 of them didn't work for the installation. After that I tried to install Linux Mint again, formatting the 2 USB sticks at the standard format for a iso image using Ruffus. Again only 1 of the USB sticks worked under a designated USB port, just like at Manjaro.
    I am still experiencing issues with installing Fedora 28. I tried mutliple spin offs of the Distro with both USB sticks formatted under DD and standard iso format and it didn't work. It detects the used iso image as corrupted and the "/boot" directory doesn't install and it breaks the OS.
    For anyone who is experiencing the same issue, my suggestion is to get a couple of USB sticks, format them at ISO image selected, not DD and try every port on the laptop with all of the USB sticks. If by chance it doesn't work, try DD. Linux Mint 19 and Manjaro 17.10 works, but you need to tweak a little with which USB port is to be used and on which format you should use. If someone knows a way to install Fedora 28 I would appreciate it greatly.
  • CalebXCalebX Member Posts: 19 Troubleshooter
    Just want to clarify, I bought 2 new USB sticks for this.
  • jurjendevriesjurjendevries Member Posts: 1 New User
    Hi all,

    I have the same issue but found a workaround. When I add an external monitor connected to the HDMI output of the laptop and boot the computer I don't have the freeze (only mouse pointer movement possible) problem. Then when I boot again without the external monitor connected it just works almost fine excepts that Ubuntu gives an error window with the request to send the details. The output is saved in /var/crash/_sbin_plymouthd.0.crash and I copy/paste it to https://pastebin.com/4PneS0Xs

    The differences I have from your post:
    - Acer A715-71G-76Z5 (16Gb mem, Nvidia GeForce GTX 1050)
    - I do get the login screen (during install I selected that I want to login). I am able to enter my password and then in the next phase it freezes
    - I tried with Ubuntu 16.04, 18.04, 18.10 and Elemantary OS (ubuntu based), all have the same issue. Debian is working fine, but that does only install free open drivers so not all hardware such as wifi is working out of the box.
    - I have dual boot with Windows 10 (Windows is the default setup) and Grub is working fine that way.

    I hope this extra info helps to get closer to the cause of the issue so that it can be fixed, and will be a workaround for those who have the same issue.

  • JackEJackE ACE Posts: 20,091 Trailblazer
    Thank you for your report @jurjendevries  Jack E/NJ
    Jack E/NJ
  • antuanantuan Member Posts: 1 New User
    Gawain said:
    if you live boot and get a blank screen...try this:  boot from the stick and when you get to the "try ubuntu without installing" bit, hit "e" and replace "quiet splash" with "nomodeset" then hit F10 and see what happens (I had a blank screen on a live boot a while back and this got to live boot part)   ((using uefi mode and personally i disable secure boot)) and when installing, make sure to check "install 3rd party..." box

    I had this issue with an Acer Aspire 7 series laptop and with other Hybrid Intel Graphics + Nvidia video card (an Asus one)
    It was really very frustrating because it would sometimes work but then fail on the next reboot, though mostly fail with blank screen on startup from live distros on a USB stick
    Adding nomodeset to the boot line helped and also adding: nouveau.blacklist=1 or rdblacklist=nouveau 

    I'm not sure but I reckon the problem was with the kernel loading/initializing the nouveau open source kernel driver for nvidia and intel driver loading at the same time an messing up the boot process

    If the install goes well and it's possible to start the laptop with linux, then installing the nvidia drivers right after would be a good idea, it worked well for me (with both ubuntu Cosmic 18.10 and Bionic 18.04)

    It may be necessary to modify the /etc/default/grub file to make the change to the boot process permanent, I mean the nomodeset and/or the nouveau disable action (check online about the process)

    Aside from this the Linux support is great for this Aspire 7 laptop, only the fingerprint reader is not working

    Oh and the external monitor doesn't work when I use the Intel card, I switch with the NVidia X Server settings application (comes with the proprietary NVidia drivers), the switch between the two works well though I need to Log out/Log in, I get almost 2 hour extra battery with the Intel one
    Anybody having this issue with external monitor using the Intel graphic card?
  • JackEJackE ACE Posts: 20,091 Trailblazer
    Thank you for your report too antuan  Likely helpful for other ubuntu flavors. Jack E.NJ
    Jack E/NJ
  • Michael999Michael999 Member Posts: 1 New User
    Thanks Antuan, very helpful. I followed that lead around the nouveau driver and found some interesting pointers on google.
    To install Fedora 29 on my A715-72G-771X I followed the 2 posts below. 

    Now no more freeze.
    Cheers - M

Sign In or Register to comment.

Who's Online in this Category1


Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer

Drivers &


Get Product Information
( only)

Acer Support