Examples: Monday, today, last week, Mar 26, 3/26/04

Bios Password for Acer Spin 5

Hey everybody,

so some days ago after a windows update I tried to use my F-Keys. Only to find out that I'm somehow have a FN-Lock enabled suddenly. Trying to figure this out I did pretty much everything, then it dawned on me to look in the Bios. Only to find out, that it's suddenly password protected, which is quiet scary as I'm pretty sure it wasn't me.

Just tried to flash a new Bios, and the tool reports that I have the latest from the 06/19/18 which was surprising to me. Then it dawned, must have been the windows update.

Would be nice to get any help and be able to get my F-Keys back.

FAQ & Answers

  • JackEJackE Posts: 18,928ACE Trailblazer
    edited August 2018
    Enter an incorrect password XXXXXX. If you get an 8-digit lock key, you may be able to get an unlock key by XXXXXXXX  Jack E/NJ

    [Post edited to remove inappropriate or personal content -Acer-Manny]
  • razzeerazzee Posts: 9Member


    JackE said:
    Enter an incorrect password 3 times in a row. If you get an 8-digit lock key, you may be able to get an unlock key by tuning to bios-pw dot org  Jack E/NJ
    So I tried that some weeks ago, I do get a lock key but entering it on the site unfortunatly only yields a partial password

    At the moment I'm hoping for another bios update that maybe fixes it...
  • JackEJackE Posts: 18,928ACE Trailblazer
    What is your full spin5 model number? Also send me a PM with your 8-digit lock key. Jack E/NJ
  • razzeerazzee Posts: 9Member


    It's actually a 10 digit lock key.

    Acer Spin 5 SP515-51GN

  • JackEJackE Posts: 18,928ACE Trailblazer
    Yeah, a 10-digit key currently doesn't work. We can probably clean re-install the latest BIOS or revert to an earlier version but with some bricking risk. I suggest you first try to uninstall the KB driver from Device Mgr if you haven't done so already. Then exit and reboot and allow Win10 to re-detect the keyboard and auto re-install the drivers. If no joy, I suggest that you might be safer trying to hold your breath and wait for another Win10 or ACER UEFI firmware update to fix this annoyance. Jack E/NJ
  • razzeerazzee Posts: 9Member


    Did try to reinstall the keyboard drivers. Didn't help.
  • JackEJackE Posts: 18,928ACE Trailblazer
    You have 3 choices. (1) Tolerate the annoyance till the next BIOS firmware release. Can't tell when this will happen but it's the safest option. (2) Revert to an earlier version carrying a significant risk of bricking the machine. (3) Short BIOS password clear jumpers on the mainboard as shown below. This is also risky since it requires opening the machine to access the jumpers. Jack E/NJ

  • razzeerazzee Posts: 9Member


    It doesn't seem like those pictures match my board. Any idea where I can find a reference for my mainboard?
  • JackEJackE Posts: 18,928ACE Trailblazer
    Those are the only two mainboards spec'd for the SP515-51GN. If you have only one graphics adapter, it would be the UMA board. The mainboard part numbers are shown in the image below. Jack E/NJ

  • razzeerazzee Posts: 9Member


    Your right, I just have the wrong side of the board. Not sure how to get to the other side.
  • razzeerazzee Posts: 9Member


    So I did try to disconnect the cmos battery for an hour and switch the board to the other side then bridged G601 with a needle and a screw driver. But no change in bios behavior so far. Would not recommend that for people that have never handled hardware.
  • JackEJackE Posts: 18,928ACE Trailblazer
    Hold on! Which mainboard do you have? Jack E/NJ
  • razzeerazzee Posts: 9Member


    The one with two coolers, with the big cut out or do you mean which specific model number?

  • JackEJackE Posts: 18,928ACE Trailblazer
    Sounds like you have the DIScrete board with a 2nd graphics chip. I was hoping a brief gap bridge would work. So I suggest trying it again but this time arrange to bridge the gap for several hours preferrably overnight possibly using tape to affix a small copper wire or foil across the gap. If this still doesn't work, there is another method which I consider much riskier and complicated since it involves trying to bridge the gap while at the same time applying power until after the BIOS POST sequence. Jack E/NJ   
  • DenizDeniz Posts: 5Member



    I have a similar problem with my SPIN 5 - I cannot access the UEFI after having updated WIndows because of an admin-password, that does not work anymore.

    It seems, that there is no technical way to reset the ADMIN-password in UEFI.

    Following attempts failed with regard to get rid of that password:
    1) Downgrade of the ACER UEFI / BIOS to a prior version 
    2) Disconnect of the CMOS batery and of the rechargeable main batery for > 1 hour

    I would like to avoid the ACER procedure (sending the laptop to ACER and paying a password-reset-fee).

    The jumper R601 seems not to exist on the mainboard. Is there any other chance to get rid of that annoying issue?

    Many thanks!

    Kind regards,


  • JackEJackE Posts: 18,928ACE Trailblazer
    edited January 2019
    Try pressing the numlk key. It might have been accidentally activated thus preventing you from entering the correct password. Jack E/NJ
  • ingaramopingaramop Posts: 1Member New User
    edited July 2019
    Similar problem here. I had factory default passworless access to bios. After upgrading bios firmware to version 1.14 (2019/01/22), I realized that fn key was reverted from "unpressed" to "pressed" (I had already changed this configuration ir previous bios version). When I tried to get into the bios to set this again, it asks me for a password, which I am sure I have not set.
    Is it possible that there is something wrong with the latest bios version? If there is... Am I supposed to pay to get this working again?

    Edit: My laptop is a Nitro Spin 5 from 2018
  • JackEJackE Posts: 18,928ACE Trailblazer
    Sorry, unlike driver updates, firmware updates should only be used a last resort for trying to fix major problems due to the risk of bricking the machine or creating adverse side effects like you now have. You should arrange for service if earlier suggestions fail. Jack E/NJ  
Sign In or Register to comment.

Who's Online in this Category0

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Good Design Aware 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.