image

Updating Aspire 5930G bios

onurkireconurkirec Member Posts: 2 New User
Greetings,

I have Acer Aspire 5930G-843G32Mn laptop. I recently installed new ram making it 4GB total. However, I realized that my systems can only use 2.99 GB of that although they see 4GB installed. Bios version 1.23 seems to solve the problem. (I have bios v1.20)

I dualboot Linux Mint 18.3 alongside Windows 7. Both 64 bit.

I downloaded the 1.23 driver from Acer support page. However, when I boot from win7 and run the EGR-123.EXE file inside x64 folder, I get this error.
EGR-123
---------------------------
Driver(WDM) Init fail!(0x137)

Strangely, Acer no longer provides a DOS version of the bios. 

Any help would be much appreciated.



FAQ & Answers

  • JackEJackE ACE Posts: 38,808 Trailblazer
    NO!!! v1.23 does NOT address this problem!!! Because you do NOT have a memory problem. 2.99GB out of 4GB available for use memory is correct. The operating systems are using the rest of the memory to run. Do not try to update your BIOS or you could brick your machine!!! Jack E/NJ
    Jack E/NJ
  • onurkireconurkirec Member Posts: 2 New User
    Yes, it does. There are over a thousand posts online that says v1.23 enabled their system see 4GB. 

    I am still waiting for an answer from someone who knows what they are talking about and actually answers my question.
  • JackEJackE ACE Posts: 38,808 Trailblazer
    Sorry, your old BIOS information tab should show the full 4GB installed is recognized. Jack E/NJ
    Jack E/NJ
Sign In or Register to comment.

Who's Online710

ElvioRenato
ElvioRenato
jbell
jbell
rafaelsoaresbr
rafaelsoaresbr
RoKo1882
RoKo1882
Sobe
Sobe
StevenGen
StevenGen
+704 Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers