Examples: Monday, today, last week, Mar 26, 3/26/04

Black screen after select Linux installation

I've got my new Travelmate yesterday, an X349-m-597M version, and i tried to install many distributions of linux (manjaro, ubuntu, kde neon, mint) from usb bootable stick (used tools: rufus, ImageWrite, unebootin, dd). After i step into the bootloader and pick an installation option, i got a black screen. No prompt, no response for any key and if i remove the usb stick, nothing happens. 

After few hours of pointless attempts, i decided to try windows. Created a stick with rufus, and worked immediately.

My questions are: is there any hardware limitation for linux in this series? If no, what is the method to get any linux distro on this laptop. If there is a method for installation, but not working on my laptop, is the warranty valid?

Best Answer

  • hmaihmai Posts: 4 New User
    Accepted Answer

    It works with Insyde BIOS version 1.07. No more black screen. I updated from 1.05 to 1.07.

    The installation of Ubuntu goes to the end successfully, but when I reboot, it still starts with Windows, so I guess I have chosen the wrong place to install my Ubuntu 16.04?

FAQ & Answers

  • JordanBJordanB Posts: 3,453ACE Pathfinder

    Make sure you have the latest BIOS/UEFI.


    The links below are about people using Insyde H2o UEFI in default EFI mode with secure boot enabled.

    I'm not familiar with your computer model, but if you have the latest BIOS/UEFI and have insyde H20 UEFI, it should work if you read the procedure in links below.  Read my posts and eelcoherders posts.





    I'm not an Acer employee.
  • hamstermajszterhamstermajszter Posts: 5Member

    Thanks for your fast response.


    I downloaded and upgraded the latest BIOS from Acer site. First tried legacy boot, after UEFI boot and finally, tried to add Trusted UEFI file as eelcoherders mentioned in his comment.


    The problem still the same: i'm only can reach the GRUB, but when i try to install the os (or start the live version), just a black screen.


    This could be a bios related issue (this quite a new model), should i report it somewhere?

  • JordanBJordanB Posts: 3,453ACE Pathfinder

    It's easy to get things in a mess if you didn't originally follow the correct procedure.


    In the other thread, the forum member had to resort to using an external DVD.


    I tried to reproduce his mess and was also successful in messing things up.  I don't have an external DVD, so I just started completely over.   I mean completely over.  Smiley Happy


    Make sure you create a USB factory default recovery drive in case something goes wrong.







    I'm not an Acer employee.
  • hamstermajszterhamstermajszter Posts: 5Member

    Now i re-do everything step-by-step as you wrote (whit the newest BIOS):

    1. create bootable stick with rufus, take care for these 3 parameter as you mentioned

    2. set up BIOS pswd

    3. set boot mode to UEFI and enable the Secure boot

    4. add UEFI file as trusted executing: usb0/EFI/boot/bootx64.efi

    5. in Boot priority order I move recantly added bootx64.efi to first place

    6. save&restart

    7. system boot into Manjaro's bootloader

    8. select Manjaro Linux x86_64 UEFI USB 

    9. black screen


    I jumped down to the store and bought an external DVD reader, burn the iso, but still got the same result.

  • JordanBJordanB Posts: 3,453ACE Pathfinder

    Ok, but that's not what I meant by starting completely over.  I don't work for Acer and I don't have your computer model.  It's possible Acer needs to update your BIOS.  It's impossible for me to say since I don't have your computer sitting in front of me.


    1. I backed up my important personal files.

    2. I created a USB factory default recovery drive.

    3.  Wiped my HDD with "diskpart clean"

    4. Went in to UEFI and deleted secure boot settings and then save/exit 

    5.  Went back in to UEFI and loaded default secure boot settings and then save/exit

    6.  Went back in to UEFI and loaded UEFI defaults (F9) and then save/exit.

    7. Inserted USB factory recovery drive

    8. Reset PC to factory condition

    9. shrank C drive by about 30 GB

    10. Inserted Ubuntu installtion USB

    11. Went in to UEFI and added grub to trusted secure boot (My supervisor password was already set from before)

    12. Went in to UEFI and enabled the F12 boot menu

    13.  Booted Ubuntu USB

    14.  Installed Ubuntu 


    My computer boots to windows 10 by default.  If I want Ubuntu, I hit the F12 key at Acer boot screen.



    I'm not an Acer employee.
  • hmaihmai Posts: 4Member New User
    Accepted Answer

    It works with Insyde BIOS version 1.07. No more black screen. I updated from 1.05 to 1.07.

    The installation of Ubuntu goes to the end successfully, but when I reboot, it still starts with Windows, so I guess I have chosen the wrong place to install my Ubuntu 16.04?

  • JordanBJordanB Posts: 3,453ACE Pathfinder

    hmai, It's really difficult to help you since you didn't bother to post your model #.  Some topics on this forum are for older computers and some topics are for newer computers.  There are different procedures depending on your computer model.


    Did you enable the F12 boot menu in the BIOS?


    Try reading the thread below as it relates to newer computers. I don't have a newer computer so I don't think I'm going to be able to help you, but the link below might help as it is for newer computers.  Acer and Insyde H20 changed some things in their implementation.  My posts in this topic probably won't help you if you have a newish computer.




    Your best bet would be to start a new topic and take the time to actually post your computer model.  Good luck.

    I'm not an Acer employee.
  • hamstermajszterhamstermajszter Posts: 5Member

    Hey man, thanks for your reply.


    That's true, after BIOS update, black screen bug disappeared. Anyway, i had a same problem as you, i could installed every distro, like ubuntu/manjaro/debian, but i cannot boot into it. Tried every combination with secure boot and UEFI boot, every flag and MBR/GPT partition table. I failed, i put 20+ hours to install and start linux with this machine and i think, it's impossible at this moment.


    If you found any way to create a working configuration, please, write it.



  • 700ghz700ghz Posts: 4Member

    You can use this manual: https://www.reddit.com/r/linuxmint/comments/5lu69k/installing_linux_mint_181_on_an_acer_swift_3/
    My acer works with Mint 18.1 x64. It often freezes when boots. It crashes when you run chrome. You can't use sleep or hibernate power off modes. I think we are cheated and seems like acer uses dirty business model.

  • hmaihmai Posts: 4Member New User


    It works!

    With Acer X349-M laptop, Insyde BIOS version 1.10, F12 Dual boot Windows boot Manager 7 Pro/ grub Ubuntu 16.04.02 installed from a live USB key with the boot loader on sda6 (where I have chosen the partition sda6 ext4 to install Ubuntu, sda7 being the ext4/home and sda8 the swap, sda1 the EFI Windows boot manager. The previous install where I chose "Something else" and decided to install on sda/HDD ATA... did not work and I had purple screen hanging, so we chose sda6 next to see if it was better), UEFI, secure boot disabled, with EFI trusted path that we added manually in the choices after boot repair, and editing the kernel booting with F12, choosing advanced option, editing with the following that I found on the Ubuntu forum:


    I have the same laptop, and i had the same problem the first launch. Near the acpi=off kernel option you need to add these options :

    i8042.reset i8042.nomux i8042.nopnp i8042.noloop

    Once your computer booted up, your trackpad will be supposed to work, and you will need to add these option to the grub file. Open a terminal and type :

    sudo gedit /etc/default/grub

    Find the line "GRUB_CMDLINE_LINUX_DEFAULT" and add i8042.reset i8042.nomux i8042.nopnp i8042.noloop between the quotes. Save and exit gedit. Go back to your terminal and type :

    sudo update-grub

    (Ignore update-grub2)

    Now, the trackpad boot options will be executed automatically.

    If you contact Acer, they will answer you : "You are not supposed to run Ubuntu on this Laptop". And because you did it, you don't have your warranty anymore :/

    And because of the acpi=off option, you need to know that your laptop will not be 100% stable. On mine, as an example, i dont have any information about the battery status ... Your wifi may not work as well, but you only have to reboot the computer, as many times as you need, to fix this issue (once, it needed 5 reboots ...). Of course, i didnt find any fix for those issues

    I hope i was helpful, Cordialy

    PS : sorry for the English, i'm French Smiley Happy


    I have the same problem as the guy, I can't see the battery power management. But the rest works.

  • hamstermajszterhamstermajszter Posts: 5Member

    Hey, thanks for the really detailed solution.


    First of all: "You are not supposed to run Ubuntu on this Laptop". And because you did it, you don't have your warranty anymore :/

    I think, they are wrong, if there isn't any special statement in warranty documents, your warranty must be alive. I bouth this laptop with linux. It wasn't working, but linux was preinstalled to my machine. 


    Anyway, I've already sold my laptop, this attitude from Acer is ridiculous, i wont buy any other machine from them. I hope your solution will help somebody, thanks for your work.


  • hmaihmai Posts: 4Member New User
    Hello, my computer Acer Travelmate X349 has Windows 7 pro, BIOS version 1.12 and installed Ubuntu 18.04.01 on it with a USB key. I allowed F12 menu and was on boot option Legacy. I had the problem that when I start the computer, it starts on Windows and I can't choose grub anywhere in F12 choices. Finally, I changed for UEFI and disabled secure boot, and when I restarted the computer and hit F12, the grub choice appeared below the Windows Boot Manager. So I can now use Ubuntu, but when I start the computer, I have to hit F12 and hit the arrow, otherwise, it starts on Windows by default.
    Does anyone know how to put grub by default?

  • JackEJackE Posts: 18,936ACE Trailblazer
    Move grubx64 above winbootmgr in the BIOS Boot tab Jack E/NJ
Sign In or Register to comment.

Who's Online in this Category0

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Good Design Aware 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.