Examples: Monday, today, last week, Mar 26, 3/26/04

Aspire TC-120 Won'T boot anymore since windows 10

BurritosBurritos Posts: 2Member

Greetings folks, I got a problem with my Aspire Tc-120 since i installed windows 10. I'm fairly skilled but theres one thing i can't figure out yet.  I saw there was a bios upgrade to fix that problem. I upgraded my bios with the win flash utility. Now i'm on the EFI thing, and i can't find a way to use it, it says i to make a bootable flash drive, but how can i do it? i don'T wanna loose my data on my hard drive, do you guys have any solution for me?

 

it tell me to insert a bootable drive ( pc won't recognine my hard drive)

I tried to install windows on another hard drive to boot that's how i succeded at updating my WIN, but then the problem came back, still can't boot.

 

Thanks for your answers, i hope i've been specific enough about my problem.

FAQ & Answers

  • IronFlyIronFly Posts: 18,343ACE Trailblazer

    so, prior the BIOS update it booted?

    have you tried to set launcCSM on BIOS?

    1.Completely shut down your computer.

    2.Power on the system. As soon as the first logo screen appears, immediately press Delete to enter the

    BIOS.

    3.Use the right arrow key to select Authentication.

    4.With Secure Boot highlighted, press Enter and then the down arrow to select Disabled.

    5.Use the right arrow key to select Boot Options.

    6.With Launch CSM highlighted, press Enter and use the down arrow to select Always.

    7.Press Enter.

    8.Press the F10 key to save changes and restart the system

    I'm not an Acer employee.
  • BurritosBurritos Posts: 2Member

    in installled windows on another hard drive, and it only booted once, i mean, this time i installed windows, and the stopped working. of cours I did all those things. I successfully flashed with the WIN thing. Still dosent boot, i guess i must completly flash the bios, but i can't find a way to flash the EFI section, I need to make a bootable flash device to do so, and i don't know how to do it. And no it haven't booted after the Bios update. unfortunatly

Sign In or Register to comment.

Who's Online85

billsey
billsey
Deejay_tech
Deejay_tech
Kesaca
Kesaca
Ninjakitty844
Ninjakitty844
sri369
sri369
xapim
xapim
+79 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Member Highlight

We would like to feature andylb as a destacated member in the Acer Community. With his dedication and support efforts, andylb has become a Valued Contributor . On behalf of the Acer Community team and all our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1044

Total Points:2652

Total Accepted Answers: 129

andylb Valued Contributor
Intel Extreme KAtowise 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.