How do you set Num Lock key to activate on startup?

cap0k3n Member Posts: 2 New User
edited March 22 in 2020 Archives

I just bought this laptop (Acer V3-572P) before Xmas and have a couple of issues - a call to Acer and Costco "tech support" was no help:

1) In Windows 8.1 and Acer laptop Aspire V3-572P how do you set the Num Lock key to activate on startup?

2) The day I turned on the computer I checked for updates to the drivers and several were found and updated.  The next time I turned the computer on I got the following message from Dolby Home Theatre:  "wrong version of dolby digital plus audio driver is installed - looking for version - please get a version of Dolby Home Theatre and digital plus audio driver that are compatible."  I tried to find answers on the Dolby site & called Acer tech support with no luck - can someone direct me to someplace that can help?



  • Sharanji
    Sharanji ACE Posts: 4,327 Pathfinder
    Here are two ways you can do it.
    Disable Fast Startup, to enable Num Lock
    Press Win + X and click on Control Panel
    Click on Power Plan
    Now click on Choose what the power buttons do on the left side panel
    Now select Change settings that are currently unavailable
    Scroll down and uncheck Turn on fast startup (recommended)
    That’s it. Now after shutting down and reboot your NumLock should retain the last configuration.
    The second method is to alter the registry settings and so, I would strongly recommended taking a backup of the registry and/or create a system restore point first. Having done that, follow these steps:
    Press Win + R and type in Regedit
    Navigate to registry key HKEY_USERS\Default\Control Panel\Keyboard
    Right click on the “InitialKeyboardIndicators”, select Modify and change Value data to 2.
    Exit Registry.
    If you see the default value data as 2147483648; that is fine too and is the default on most installations.
    Click the Kudos kudos-thumbs-up.pngto say “Thanks” for helping! select "Accept Solution" if your issue is resovled.


  • Sharanji
    Sharanji ACE Posts: 4,327 Pathfinder

    Here's the recommended audio driver package for this model : Download Audio driver package


    The above package has the sudio driver and Dolby Home Theatre software. The file size is approx 386 GB

    You may direclty run the setup application file to install the driver and package.

    Another way is to open the downloaded folder Audio_Realtek_6.0.1.7300_W81x64, then open DS1 folder and run the  software application.


    Click the Kudos kudos-thumbs-up.pngto say “Thanks” for helping! select "Accept Solution" if your issue is resovled.

  • cap0k3n
    cap0k3n Member Posts: 2 New User

    Sorry, I'm away from home and will try these solutions when I return.  In reading the response to the Dolby Digital Plus Home Theatre issue I still have the following questions:


    1) Is the file size really 386 GB or MB?  386 GB would take up a lot of my hard drive.


    2) If I download the package (or run the software application) and it works, will it be ok to a) update the driver using a third party driver update program or will b) Acer and/or c) Dolby Home Theatre advise me when a valid updated driver & software combo is available?  If the second or third option is applicable which driver updates should I not allow? - the one that I can find that may have caused the problem is Realtek High Definition Audio driver version dated 10/28/2014.


    My third party driver update software (Driver Booster 2.1) gives me the 2 options of rolling back or uninstalling which to me sounds like the same thing so uninstalling must be to uninstall the driver completely - right?  Is it better to do one of these or download the audio driver package option in your response?


    Thanks for any help you can give me.

  • studio771
    studio771 Member Posts: 2 New User

    Problem : Acer Aspire E-17 E5-771G-79PN with Windows 8.1 turns NUM Lock off when waking from SLEEP.


    I seem to have succeded in getting Num Lock to activate at startup and restart by registry edits to InitialKeyboardIndicators as shown below:


    HKEY_USERS\.DEFAULT\Control Panel\Keyboard   set to data value=2


    HKEY_CURRENT_USER\Control Panel\Keyboard     set to data value=2


    However the problem is that when I wake the laptop from sleep (or from hibernate) the NUM LOCK is always OFF - but I want it to be ON.


    (Preferably ON, but if that is not possible then it would probably be OK if it has to be set to follow pre-sleep state whether that be ON or OFF.)


    I note that there are four other registry keys which reference INITIALKEYBOARDINDICATORS:


    HKEY_USERS\S-1-5-18\Control Panel\Keyboard   data value=2147483648

    HKEY_USERS\S-1-5-19\Control Panel\Keyboard   data value=2147483648

    HKEY_USERS\S-1-5-20\Control Panel\Keyboard   data value=2147483648

    HKEY_USERS\S-1-5-21-1474213637-4233574618-4290759491-1001\Control Panel\Keyboard data value=0


    Does anyone know what are the functions of these four registry keys? Do I have to change any of them to get the laptop to wake from sleep or from hibernate with NUM LOCK ON?


    Or is there any other registry setting I need to change? (I do not want to try and fix this by disabling Fast Startup, which I kind of like.)

  • CSWinnall
    CSWinnall Member Posts: 1 New User

    I am very frustrated with this now how can something so simple (that is how it appears) be so annoying.


    I have followed initial instructions and num lock is always on after restart however after hibernate (closing the lid) it is always off.


    Please help 


    I am getting very annoyed now

    thanks in advance

  • EmailFuzzi
    EmailFuzzi Member Posts: 13


    Hey Guys,

    i think i've found a solution to this problem, which works very well for me! [Acer Aspire VN7-571g with Windows 8.1 64bit]
    "However the problem is that when I wake the laptop from sleep (or from hibernate) the NUM LOCK is always OFF - but I want it to be ON."
    It's the same with locking windows by [winkey + L], so you can test faster if it works.

    Disable the Acer "Launch Manager" task in task scheduler.
    It's activated every time you log on.

    I did not need to disable the whole service
    [ Launch Manager    LMLauncher    Acer Incorporate    c:\program files\acer\acer launch manager\lmlauncher.exe ]
    because the registry trick often mentioned works well for me on startup/reboot, so i couldn't recognize any disadvantages especially regarding FN-keys.

    In conclusion that means to me that it is definitely a problem caused by acer software.

    Please Acer, fix that! Many people have been annoyed and wasted hours of searching the internet for that stupid little bug!


  • manfrommars
    manfrommars Member Posts: 4 New User

    Hi. I cannot believe that there has not been a solution to this issue as of yet, as far as I can find on the net. I am in the exact same boat as studio771 above, and it's really quite frustrating to have the numlock off every time I switch to a new window, or when logging in (because I wanted to use a PIN). I'm using an Acer Aspire F5, on Win 10 Home, but I disabled the Acer Portal program from start up in task manager a few days ago, and the issue is still persistent. What's frustrating is that if I get to the 'enter your password' screen really quickly, I can enter a few digits on the numpad before it defaults to turining itself off. What's even more unfortunate is that my model of laptop does not have an LED indicator for whether the num lock is on or off, so I never know exactly when it's on or off, as the onscreen indicator for the toggling of num lock only appears when you manually intervene and change the num lock setting with the hardware button.

    Is there anyway to stop these acer programs running on startup? I've tried in task manager, but that doesnt stop them. I've tried disabling auto updates and also checking from the disable startup in the Acer Care centre app (but they dont show up as they do in the task manager). I'll attach a screenshot of my startup in task manager.taskmanager.png

  • EmailFuzzi
    EmailFuzzi Member Posts: 13


    I have no experience with Windows10, but usually AutoRuns for Windows works very well to control your autostarting programs/services/scheduled tasks etc.

    Description says it also works for Win10.

    Good luck!

  • manfrommars
    manfrommars Member Posts: 4 New User

    I still havent been able to resolve the issue of num lock turning itself off! I even tried to disable the keyboard from substituting to a different layout in the registry settings but that didnt work either. Funny thing is, is that there is no profile for English (Australia) under my registry settings; ie 00000c09, however it shows up in my preload keyboard layout for all users under HKEY_USERS...

  • TeresaHsu
    TeresaHsu Member Posts: 68 Troubleshooter

    Hi manfrommars,


    Acer Portal won’t affect Num Lock key. If you want to stop Acer Portal running when start up, I suggest you sign out your Acer ID from Acer Portal.

    Remind you, if you sign out Acer ID, the data you shared via abPhoto and abMedia before will be removed, you need to share the files again (your files in the original place will not be affected). For more Acer BYOC Apps information, you can visit Online Help.



    Acer BYOC Apps Support

  • manfrommars
    manfrommars Member Posts: 4 New User

    Ok, so would you be able to tell me if there has been any way identified to fix this issue, where the state of num lock is defaulted to off constantly, for every new application, and after each screensaver/lock screen return?


    Has anybody figured out if it is tied to the keyboard hardware of acer computers, or if it's related to the Windows 10 software? Is it something that is going to be patched? Or do we just have to learn to live with it? I cannot be the only one with an Acer Aspire that is still having this issue. Have people found a resolution or have they just given up?

  • klj1122
    klj1122 Member Posts: 2 New User

    I've pretty much given up, but I hope this is addressed. I find it incredibly aggravating. I've tried the work-arounds suggested in this thread and they don't work. The number pad is one of the reasons I chose another Aspire, after my old 9301.

  • manfrommars
    manfrommars Member Posts: 4 New User

    I hope so too, but no body really seems to understand what's going on. One of the reasons I was attracted to this laptop was because it had a num pad, and to have it not function half the time in the way that I does on other computers is really annoying it confuses me as to why this hasn't been identified as a bug. I personally still haven't found a fix. Most people just dismiss the issue by suggesting we change the registry values, but that doesn't fix much at all. All it changed for me was having num lock enabled on start up from cold boot; Every time my screensaver comes on or my computer goes on standby, the num lock turns back off. 

  • EmailFuzzi
    EmailFuzzi Member Posts: 13


    Did you try to disable as much preinstalled Acer software as possible? Don't give up on it. Just grab a tool like Autoruns and disable ALL the Acer stuff except in "services" (just ctrl+f "acer"). Then restart and see what works or not. Then carefully reenable stuff if needed. It still required the registry trick for the first bootup (for me), but then numlock now keeps its status.
  • mbutler2575
    mbutler2575 Member Posts: 1 New User

    Hi EmailFuzzi,

    Your suggestion worked a treat for me. I had previously done all the registry edits, searched initialkeyboardindicators and changed all the values to 2. But this only partially worked. I have now deactivated lmlauncher.exe using autoruns & that seems to have done the trick.


    Is anyone aware of what lmlauncher.exe is & what are the ramifications of disabling it?

    I have checked the extra function keys & they seem to work OK.

    Is it possible to have lmlauncher.exe just enable number lock via a command line switch?



  • rusty9073
    rusty9073 Member Posts: 3 New User

    ‎03-08-2016 03:00 PM

    Scheduled task is the solution.

    Download numlock program or any program that let you programatically lock the numpad

    Create a scheduled task specifying in action tab numlock.exe with argument value "on"

    In trigger tab, trigger this action on "unlocking session".


    This totally worked for me - I downloaded this program and then set it to execute the numlock.exe program (action) with a tigger of "On workstation unlock of any user" in Task Scheduler.


    I have spent months trying to solve this issue, changed everything in regedit that I could find and nothing worked, but this quick fix did the job. Thank you so much for posting this solution. Smiley Happy

  • EmailFuzzi
    EmailFuzzi Member Posts: 13


    @rusty9073 Actually I think you're just fighting symptoms with another program, not the root. I agree with you that scheduled tasks are the solution - but delete one (see above), don't add another ;-) However, thanks for sharing your solution!
  • klj1122
    klj1122 Member Posts: 2 New User

    Yes, thank you, this is a good work-around that seems to be working for me so far - but it's still not a solution. Why in the world does Acer assume I would I want to use my number pad as arrow keys when there is a set of arrow keys literally right beside the number pad?! Just leave the number lock on by default!

  • rusty9073
    rusty9073 Member Posts: 3 New User

    "@rusty9073 Actually I think you're just fighting symptoms with another program, not the root. I agree with you that scheduled tasks are the solution - but delete one (see above), don't add another ;-) However, thanks for sharing your solution!"



    Agreed EmailFuzzi Smiley Happy


    Based on your posts, I believe your computer techincal skills are far superior to mine. I didn't want to spend the time and risk of disabling all the Acer programs and doing something wrong that I would not be able to undo (something that would definitely not be an issue for you at your skill level).


    The task scheduler solution was a quick fix to my dilemma without having to invest any more time in researching and troubleshooting this issue. I guess you would call it the lazy man fix, but I was so sick of wasting time on this I was just glad to have a quick way to get it working as desired. Smiley Happy

  • twilight
    twilight Member Posts: 1 New User

    I have windows 10 64 bit and an Acer E5-575G-51BN laptop.


    Tried all the internet with regedit and 2 or 8000000000000xxxxxxxx2 and other numbers but nothing worked. So i thought hey, it shoul be acer`s fault, so i got to this page and it helped me a lot.


    The problem was that i wouldn't find lmlauncher.


    So my workaround is to run "msconfig" to enter System Configuration, go to services and find Quick Access Service by Acer. Disable it.



    After restarting the system, the only drawback with this workaround is that you won't have the on-screen icons when turning on/off caps lock, scroll lock and num lock. At least that's what i found!


    But hey, numlock is ON after hibernate! Smiley Wink


    Oh... by the way: the key HKEY_USERS\.DEFAULT\Control Panel\Keyboard is set to 80000002. I won't make any further testing if my workaround would work with other values. 


    Best regards!