Examples: Monday, today, last week, Mar 26, 3/26/04

Aspire E15-575G-53VG touchpad (ELANtech) settings / device missing?

I purchased a brand new Aspire E15-575G-53VG less than a week ago, and I went to the Acer website to download drivers for it to make sure everything was as it should be. I noticed that, after installing the touchpad driver (learned that I have the ELANtech touchpad, not the Synaptics one) and rebooted, there were no additional settings for the touchpad anywhere in the Mouse Properties panel. Later that day, I shut down the laptop and it installed some Windows 10 updates, and when I rebooted, I noticed the ELAN tab had suddenly appeared, however my touchpad does not show in the list of devices:


Does anyone know how to address this? I would very much like to tweak a few of the settings for the touchpad, but as you can see, even after installing the driver and letting Windows Update partially fix the tab not even appearing, the device is still not listed for whatever reason.


I should add this is still a very fresh machine, only used it for maybe a couple hours max, no external devices plugged in (including mice).

FAQ & Answers

  • brummyfan2brummyfan2 Posts: 13,683ACE Trailblazer

    You could try different drivers for similar models, for example you could try E5-572G driver Win 8.1 from the Acer download site:http://www.acer.com/ac/en/GB/content/drivers

    I am using win8 driver version in my windows 10 (E1-571).

    EDIT: If any driver doesn't suit your system, uninstall it before installing the new driver.

    The driver you currently have mostly used in Extensa models.


    Please click "Yes" for "Did this answer the question", if I resolve the problem.
  • thefowles1thefowles1 Posts: 7Member


    Thank you for your reply; I will give that a try. I find it odd that, even though it's the driver specified for this model computer, it does not seem to fully work properly.

    Edit: I should add that I went to the device manager, selected the touchpad, and clicked "update driver" and let it search automatically for a driver. It found one and installed it, and I'm seeing that the driver installed is version, which is different (older) than the one pictured in the OP (, which is STILL different than the driver listed for this specific laptop ( I am thinking Windows Update found a newer driver for the touchpad than the one the website has listed, which is odd because, after this most recent procedure which seems to be an older driver, Windows Update claims that it's up to date. I'm so lost, and still no luck.

  • thefowles1thefowles1 Posts: 7Member



    Forgive the month-long delay. I have tried several different driver versions, but none of them even provided the ELAN tab in mouse settings. I am now back on, and the ELAN tab is gone yet again.


    I don't understand why this is happening; it is infuriating. I just want to adjust the touchpad driver settings; is that too much to ask?? Smiley Frustrated

  • CoalfordCoalford Posts: 6Member New User
    I too have been having this same issue with my brand new ACER computer.

    Incredibly upsetting.
Sign In or Register to comment.

Who's Online in this Category3


Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Good Design Aware 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.