Lost Wifi after Win10 upgrade from Win 7

Dave_JohDave_Joh Member Posts: 3

I upgraded a few days ago on my ACER Aspire 605G from Windows 7 to Windows 10 and I lost wifi capability.  After upgrading numerous drivers, The Qualcomm Atheros Wireless LA Driver gave a message that said, "The device may not be present or could have been ejected/unplugged from the system.  Insert or reinsert now."  Is that the root of the problem.

 

How do I fix the wifi access?  Thanks for your help.

FAQ & Answers

  • philetusphiletus ACE Posts: 4,759 Pathfinder

    Aspire 605G isn't a good model number. Is it a XC-605G?

  • Dave_JohDave_Joh Member Posts: 3

    Yes, it is a XC 605G

  • philetusphiletus ACE Posts: 4,759 Pathfinder

    Go to Device Manager, Network adapters, double click on your Wifi and click drier. Note the version and date.

    Uninstall the wifi driver in Programs and Features and reboot. Check to see if Win 10 installed the driver again.

    If no driver is installed,Install this driver and reboot.

    Wireless LANAtherosWireless LAN Driver10.0.0.31859.1 MB2015/08/27Download

    Check if Win 10 let it install. 

  • Dave_JohDave_Joh Member Posts: 3

    Thanks.  I will try that.  Much appreciated.

Sign In or Register to comment.

Who's Online1K

Acer-Samuel
Acer-Samuel
ansley
ansley
Emattex
Emattex
fred54
fred54
GamingRoos
GamingRoos
Hubrich
Hubrich
Louis62
Louis62
Michelvvl
Michelvvl
PauloD
PauloD
raptor47
raptor47
RenanVilela
RenanVilela
sorenkair
sorenkair
VasishthG
VasishthG
+1K Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers