Examples: Monday, today, last week, Mar 26, 3/26/04

Problems with internet connection, Aspire V15-V3-575G

Hi, I bought a new laptop and have problems with internet connection without installing any other programs.

The problems are following:

  • I'm using ethernet cable to connect and just after switching on the laptop, there is no Internet connection at all. I have to restart router to make it.
  • When downloading or uploading it brokes down in interval about 30s - 1 minute. It's not always the same. Sometimes it works 3 minutes, but it's not enough.

There is Win10... With my old laptop with Win7 I didn't have such problems. I didn't change ISP.


I don't know what to do to repair it. I haven't tried to uninstall any Acer aplications yet. Did you experience something similar?


Thank you very much for answer.

Best Answer

  • IronFlyIronFly Posts: 18,415 Trailblazer
    Accepted Answer

    plese try this:

    on device manager, right click on your Realtek network adapter, choose uninstall and tick to uninstall software to if asked, reboot and then re-try to install the downloaded driver.

    I'm not an Acer employee.

FAQ & Answers

  • IronFlyIronFly Posts: 18,415ACE Trailblazer

    if mcAfee antivirus is installed, uninstall it:



    use this tool to uninstall it


    check also if you need to update drivers and BIOS:


    I'm not an Acer employee.
  • Tomáš123Tomáš123 Posts: 8Member

    Thank you for answer. I did uninstall all parts of McAfee program, but not by using that application, and installed Eset instead. Unfortunatelly this didn't help me. I have problem to download an actualization for Eset right now. Hope manual unistallation didn't broke anything.

    And what about those drivers? I bought a new laptop, why should I have something not updated? I don't see any driver for ethernet in list of drivers on that website... Which one should I download?


    Thanks! Tomáš123

  • IronFlyIronFly Posts: 18,415ACE Trailblazer

    a new laptop doesn't mean that a driver or BIOS update can be already available.


    yes, there's no ethernet driver at the moment.


    Have you tried using another ethernet cable?


    when you have those "disconnections", have you checked if your router loose DSL sync?

    I'm not an Acer employee.
  • Tomáš123Tomáš123 Posts: 8Member

    Actually I tried two cables. Both were straight-through.


    Sorry, I'm not so skilled in networks. Could you write me how to check it?

  • IronFlyIronFly Posts: 18,415ACE Trailblazer

    you need to look at your router LEDs but since i don't know your model, it's better if you ask at your ISP.


    if you don't mind, try to install this ethernet driver:



    it's for V3-575 not G, it's the same platform as yours.

    I'm not an Acer employee.
  • Tomáš123Tomáš123 Posts: 8Member

    I tried to use my laptop in school network. It did work so there's something wrong with my home network. I'm going to talk about it with my ISP. Thank you.


    „you need to look at your router LEDs but since i don't know your model, it's better if you ask at your ISP.“

    The model is WL-5460AP. It has two ports and both blink approximately the same frequency (the PC on second port works properly, but has Win XP, so worked my laptop with Win 7, this has Win 10). Than there is indicator Link/Act. that blink quite a lot. I don't know what does it mean.

    Maybe the last question. I've got a theory that internet connection brokes sometimes and so my laptop tries to create a new one (something like new session). But some internet content doesn't respect such things so video, downloading, uploading etc. fails when such error occurs and cannot regenerate. School network is aproximatelly 25x faster so maybe this applications is able to wait few miliseconds and it seems that it works but actually it doesn't and the problem is that my laptop has wrong configuration and ISP cannot make it with repairing something on the router... Is it possible? Thank you :-)

  • IronFlyIronFly Posts: 18,415ACE Trailblazer

    you told that you tried 2 cables, have you tried in different router ports too?


    did you connect using ethernet cable at school too?

    is the laptop WiFi adpater turned OFF?


    are you able to post the ethernet adapter model of your laptop?


    windows logo key + x

    device manager

    click on network adapters

    check about a Realtek ethernet adapter

    I'm not an Acer employee.
  • Tomáš123Tomáš123 Posts: 8Member

    Sure, I have tried both ports, different cables, in school I have tried it with my own cable (which is category 5e btw.).


    Yes, I have always had WiFi switched off.


    I did what you wanted, but I couldn't find there something like model (maybe Realtek PCIe GBE Family Controller), {4d36e972-e325-11ce-bfc1-08002be10318}\0001 is a key of controller. I did find this (picture on myscreen.cz). It's in Slovak, but the main part of that is the line with version (verzia).


    Should I search it here? I'm sorry it is in Slovak.


    I think some settings might be wrong. Could you send me something with correct options? There is allowed to switch it off to save energy. Isn't that the reason.


    I haven't changed anything yet.


    Thank You for your help!

  • IronFlyIronFly Posts: 18,415ACE Trailblazer

    Try this first:



    select the correct drivers version for your windows installation, click on global and then install this driver.

    I'm not an Acer employee.
  • Tomáš123Tomáš123 Posts: 8Member

    Don't I need to uninstall old program first? I'm downloading the installation zip. What is Diagnostic program for? In Problems in Control panel was only one item: 000000.


    I did launch it and chose to repair it. It works the same way as before. No change at all.

  • IronFlyIronFly Posts: 18,415ACE Trailblazer
    Accepted Answer

    plese try this:

    on device manager, right click on your Realtek network adapter, choose uninstall and tick to uninstall software to if asked, reboot and then re-try to install the downloaded driver.

    I'm not an Acer employee.
  • Tomáš123Tomáš123 Posts: 8Member

    It did help. Downloading ok, uploading ok, I haven't tried videos yet but it should be ok as well. Thank you very much indeed. Write me on e-mail if you will have some problems with HTML or CSS :-)

  • IronFlyIronFly Posts: 18,415ACE Trailblazer

    You welcome. Smiley Happy

    I'm not an Acer employee.
  • Matej-FMatej-F Posts: 1Member

    Hi, I see, it is quite recent topic. I have the same device and completely same problem. Well, not completely same, because, I have done everything described in here but my ethernet adapter still does not work properly. Downloading simply stops after few MBs and sometimes these dificulties are visible even in loading of web pages - they simply cannot load and they need to be reloaded. I could reconsile with it, but I cannot even download Win 10 updates because of this problem. I tried every driver you offered here and in totaly hopeless situation even followed procedure step by step as your conversation took place to copy conditions on Tomáš123s laptop. I looked for some other drivers on the Internet but I did not find anything. My laptop is almost new there is just CCleaner instlled on it, it probably has this problem since it have been made.


    I really need your help. Thanks for your answers.

  • Tomáš123Tomáš123 Posts: 8Member

    Hi, the problem came back unfortunatelly. Yesterday I had to restart the router to get the internet connection for the first time after succesful repair last time. Today I did some tests to find out whether is everything allright. And it is not so I tried to reinstall again the ethernet driver as I did before:

    1. I downloaded a driver from here: http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false
    2. I unistalled current driver and also ticked to uninstall all parts.
    3. Then I installed a driver I downloaded before and chose "change" in install process.
    4. I set IP address, subnet mask, default gateway, DNS servers and restarted comupter.

    This didn't help.


    Three monts ago the big actualization of Windows had to be done. Since that, I had to always pull out the ethernet cable from my laptop and pull it in back to get the connection (even after restart or waking laptop), but stable one. I did not notice any actualization now. Suddenly it just stopped working correctly. I had to do something away, my laptop was sleepy, so it took some rest and then I couldn't get the connection making just the typical process of pulling.

    Can you help me please?

Sign In or Register to comment.

Who's Online in this Category2


Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Good Design Aware 2019
Predator Join the forum discussions on our
Predator line of products.
Find out about the Acer ACE program.