Examples: Monday, today, last week, Mar 26, 3/26/04

BIOS, F5-571, UEFI, Linux / Ubuntu



I understand that there is a bug in the v1.25 Insydeh20 BIOS which effects serveral laptop models including the Aspire F5-571 which stops the installation of Linux distributions.


There are older versions of the BIOS available for other models (E5-573G) which rectify the problem, but none available for the F5-571.


My question is: Would the bios software for the E5-573G the same as the BIOS for the F5-571.






FAQ & Answers

  • fontinixxlfontinixxl Posts: 2Member

    It happens the same to me, with exactly the same model too. I'm desperate...

  • spitspit Posts: 2Member

    any update on this guys?

    or referal to a linux distro that would be supported?


    bought this kit a week ago.. a reply would be appreciated

  • davidbepodavidbepo Posts: 2Member


    just followed downgrade instructions for e5-573g :


    (comment 5)

    it works bios are all the same!

    but beware wifi isnt working on linux (yet)

  • w3davew3dave Posts: 4Member

    A brave move, davidbepo - well done!  I got as far as running the exe before i lost the courage Smiley Happy

  • CuestaCuesta Posts: 1Member

    I have also found the same issue, but I am not brave enough to make the same move as davidbepo did.


    Anyone knows how long does it take for Acer to solve this kind of issue? Do they react quickly? Otherwise, I may return the laptop. Smiley Frustrated



  • Danixu86Danixu86 Posts: 11Member

    Same here... but maybe we wil return the laptop because i've asked on support and the answer was that they don't give support for change the OS... I know it, i don't want help to change the OS because i can do it by myself, i want a fully working laptop with OS change support. Even the Mac laptops supports Linux...


    I've asked again to see if maybe this answer is better than the other, but I do not think...


    Someone has tested to change the Bios?.


    Greetings and i'm sorry for my english.

  • Danixu86Danixu86 Posts: 11Member

    Finally after about a week waiting for an Acer SAT response without luck (very poor technical service), i've decided to test to downgrade the bios using the above link. After the first run i've seen that the BIOS model is the same then I've edited the file and i've run the update. Now i've writting from the computer so it still alive Smiley LOL and i've booted a live version of Ubuntu 14.04.03LTS without problem, so the problem is the latest version of the bios. Tomorrow i will backup the whole drive using Clonezilla and i'll try to install Ubuntu. I'll report if i make the wifi works on ubuntu because maybe it only need to install the Atheros proprietary drivers.


    I'm sorry for no post any screenshot, but just run the updater and the computer restarts to program the bios.



  • Danixu86Danixu86 Posts: 11Member

    Hello, it's me again...


    I write again to say that finally i've made it work near to perfect. Here are the tips:

    - You've to downgrade the bios using the above link. Don't care if the laptop model is different.

    - Change the touchpad mode to basic on BIOS.

    - Install your prefered Linux version and enjoy.


    Next we will do is add the grub files to "trusted boot". For that we will go to "Security" tab > "Select a UEFI file as trusted for executing" and select the "grubx64.efi" file. Later we will see the Grub boot on Bios order and we will be able to set as the first place:



    With that steps finally the Clonezilla has booted and i've done a full hard drive backup without problems and i've installed the Ubuntu 14.04.3 version.

    To make the wifi works you have to open a terminal as root and run this commands:

    # wget http://www.kernel.org/pub/linux/kernel/projects/backports/2015/11/20/backports-20151120.tar.xz
    # tar -xvf backports-20151120.tar.xz
    # cd backports-20151120
    # make defconfig-ath10k
    # make
    # make install

    # apt-get install git
    # git clone https://github.com/kvalo/ath10k-firmware.git
    # cd ath10k-firmware/
    # cp -R QCA9377 /lib/firmware/ath10k/
    # ln -s /lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin_WLAN.TF.1.0-00267-1 /lib/firmware/ath10k/QCA9377/hw1.0/firmware-2.bin

    Just reboot and you will get the wifi working.

    Maybe it will work with other linux versions too because we are compiling the source.


    Some distributions may need "Build Essentials tools" to build the wifi source:

    apt-get install build-essential


    The only problem (at least on Ubuntu) is that reboot did not work, you have to shutdown the computer and then power on again.


    EDIT: I've reinstalled Ubuntu again to test the exact above steps and now reboot is working fine too.



  • stephemstephem Posts: 5Member

    I got no help from Acer support who said it was a hardware fault and that I should send in the machine for repair! Thanks to Danixu86's post I plucked up the courage and followed the instructions to downgrade the BIOS. It was simple and worked beautifully so I could boot with a live DVD. I hope others will be able to be reassured by this.


    I had a few problems, such as the wired connection wouldn't work, which a reboot of the router sorted out. I followed How to dual-boot Linux Mint 17.2, Windows 10, Windows 8.1 on a PC with UEFI firmware to dual boot which worked fine. But the computer would only boot into Windows. F12 brought up a Linux option, but in subsequent boots that option vanished and no sign of grub.

    Running a command prompt as administrator and issuing this command sorted the problem and on reboot, grub appeared:

    bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi


    I am typing this in a full install of Linux Mint 17.2 with Cinnamon.


    No wifi as expected and I was thinking of getting a wifi dongle. I tried Danixu86's latest post, as Linux Mint 17.2 is based on Ubuntu 14.04, but when I typed

    make defconfig-ath10k

    I got


    Generating local configuration database from kernel ... done.
    cc -Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer -c -o conf.o conf.c
    conf.c:6:20: fatal error: locale.h: No such file or directory
    #include <locale.h>
    compilation terminated.
    make[2]: *** [conf.o] Error 1
    make[1]: *** [defconfig-ath10k] Error 2
    make: *** [defconfig-ath10k] Error 2

    so that subsequent make and make install failed. Any suggestions?

  • Danixu86Danixu86 Posts: 11Member



    About first problem, i had the same behaviour but i've changed the order on BIOS and i've set the GRUB on fist place. Maybe you have to add the efi file to trusted boot files on bios too and maybe you have to disable Fast boot on Windows too.

    About second problem, maybe you need to install the build tools:

    apt-get install build-essential

    It was not neccesary on Ubuntu but maybe on other is it.



  • stephemstephem Posts: 5Member

    Second problem first: Thank you very much, that worked beautifully and I'm typing this using wifi Smiley Happy


    With the boot problem, I had disabled fast boot and I changed the order in the BIOS but that only applies to the disk drives, not the various OS's in them so it then loads the UEFI configuration which doesn't mention GRUB. Some BIOSes allow you to edit the UEFI boot order but not Acer's.


    Anyway it's all working well now. Thank you for giving me the nerve to try the BIOS downgrade and then for sorting out the wifi. Have a virtual beer on me!

  • Danixu86Danixu86 Posts: 11Member



    I've changed the boot order on my Acer computer too Smiley Wink. Maybe you have to disable secure boot or just add the files to trusted UEFI files.


    My exact steps were:

    - On Security Tab i've added both linux boot files (grubx64.efi and shimx64.efi) on "Select a UEFI file as trusted for executing" (Maybe with grubx64.efi only will work too).

    - Now i see both files on boot priority:



    Later i've disabled Secure Boot, but is not neccesary.



  • stephemstephem Posts: 5Member

    Ah, I hadn't added the efi files on the Security tab so the boot order only showed the Windows Boot Manager and HDD etc. But that will be useful to know and implement if Windows starts messing things up again.

  • Danixu86Danixu86 Posts: 11Member

    Nice Smiley Wink


    I've edited the other post to add all the new info. Maybe will help other users.



  • xstationxstation Posts: 4Member

    tried to downgrade as per post in septermer to 1.15v



    a program called insyde appeared and error message read when trying to insall v1.15 was

    'the version of ROM file is not newer than that of the BIOS --which is 1,25


    a ny ideas 





  • stephemstephem Posts: 5Member

    That is what is supposed to happen. If you read the instructions at http://community.acer.com/t5/E-and-M-Series/Acer-Aspire-e5-573g-You-can-not-install-any-one-Linux/m-p/386281#M3080 carefully you will see that you have to copy a folder, make a small change to a file and then run an installer to make it work. It works beautifully!

  • xstationxstation Posts: 4Member

    thankyou did not read the howto correctly but have successfully installed BIOS 1.15

     now ubuntu is running fine.


    many thanks


  • Danixu86Danixu86 Posts: 11Member

    Good news everyone who don't want to downgrade the BIOS version. The latest version (1.35) seems to fix the problem. I'm writting this message after upgrade to that version and from my Manjaro Linux.

  • lucgarc97lucgarc97 Posts: 4Member

    Thanks a lot!!!! Now it's working completely fine! (I'm on Ubuntu 15.10)


  • maxcorpmaxcorp Posts: 2Member

    Does anybody know is this problem with the Linux exist on Acer Aspire F5-573G-75Q3?

Sign In or Register to comment.

Who's Online in this Category0

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.