How to flash Revo R3700 BIOS?

dpires
dpires Member Posts: 3
edited March 2023 in 2014 Archives

Hi there,

 

my Aspire Revo R3700 won't boot anymore. It crashed and when I tried to reboot it stopped in a black screen, and I couldn't even get to the BIOS.

 

I downloaded the bios file from acer, copied it to a usb dongle, but I don`t know how to make the Revo read it. Couldn't find instructions specifically for the Revo...

 

any help?

 

thanks in advance!

Answers

  • Hello,

     

    Have you tried a Clear Cmos with the jumper?

    France
  • dpires
    dpires Member Posts: 3

    I've changed the jumper position for a few seconds, put it back in the original place and rebooted. nothing Smiley Indifferent 

  • Before doing this, do you hear beeps on startup?

     

    Remove the HDD and the memory stick(s). (Out of voltage)

    Plug in the wall socket and start the "desktop".

     

    Be careful to the static electricity!

    France
  • dpires
    dpires Member Posts: 3

    no beeps before.

     

    After removed hdd and memory it beeps continuously due to lack of memory.

     

    copied bios rom renamed to "amiboot.rom" as I found in some documentation for Revo. Tried to reboot but its not reading from the USB. (tried this before and after putting back memory...)

     

    so far, no good. 

  • Hello,

     

    If you have 2 memory sticks, try to boot with only one and without HDD.

    France