Aspire E5-511 Touchpad Driver not working

quaycom Member Posts: 3
edited March 2023 in 2017 Archives



2 days ago I bought a acer notebook.

The touchpad is working but not the gestures.

If i go to the "mouse settings", there are no specific settings for my touchpad.

Just the normal mouse settings like pointer speed...

I already downloaded the 2 driver which are on the acer support site:

TouchPad_Synaptics_18.1.2.1_W81x64_A and TouchPad_ELANTECH_13.6.1.1_W81x64_A.

I have installed boot of them sucesfully (there was the green pick).


So what to do now?

Does anyone have ideas?


Also for ur info there are no warning signes for unknown devices in the device manager.




Sorry for my bad english, I'm not a native speaker.


  • Ryanrr
    Ryanrr Member Posts: 831 Practitioner



    I am sorry that you having problems with the touchpad its gestures. I can assure you that the touchpad is working, however your touchpad is not a ELAN or Synaptics. It looks like we are shipping Precision touchpads with a lot of our newer Windows 8.1 products.


    What this means is that the gestures you are use to are no longer the same and you have to go to a different location to manage your touchpads settings. For a better idea and explanation of Microsofts Precision touchpad and gestures, please visit

  • quaycom
    quaycom Member Posts: 3

    Thanks for ur reply.


    I already found this settings before but in my view, they are not complete.


    I dont really like the zoom gesture, so I would like to deactivate just this gesture and still use the other one.


    On my old Win 7 Notebook was a menu for each gesture where I could individually activate and deactivate each gesture.


    Is there really no way to get the old settings back?


  • Ryanrr
    Ryanrr Member Posts: 831 Practitioner

    No.  The only available settings that are available to change are the ones listed here:


    This is only my opinion, but I think the gesture changes that the Microsoft Precision touchpad use were made because some of the old gestures conflicted with the new features of Windows 8 /8.1. For example moving your finger up and down on the right edge use to let your scroll but that is to close to how you swipe from right to left to bring up the charms. Again this is just my look on why new gesture changes.

  • quaycom
    quaycom Member Posts: 3

    Ok thanks for ur help.

    I will try to get familiar with the new settings and gestures.

    Thank you really much.

  • Honoralexandria
    Honoralexandria Member Posts: 11

    This actually answers the question/issue I had with my Aspire touchpad. I had the same issues as the OP and no one from Acer could really help. Eventually I was told to use the settings you mentioned here, but was never given the explanation that this was the only way to change settings, and that it was in place of elan or synpatic drivers. Despite repeated interactions with Acer "support" that was never explained. So thank you for explaining that.

    I agree with the OP that the "precision" settings are incomplete and lack the ability to fine tune the touchpad. As a result I personally find the touch pad practically un-usuable.

    One of my biggest issues is the "right click". On the touchpad, if I click the bottom right corner, it acts as a right click. This might be nice but: 1. there is NOTHING to notify of this feature. I literally found it by accident. 2. the feature is inconsisent. Sometimes it works, sometimes not.   I would prefer the feature of holding "ctrl" while I click to access right click features. But when I go to the mouse settings, the only option I have is to disable touchpad right click entirely.

    is there a way around this?

    Even better, is there a way to uninstall the "precision" touch pad drivers/feature which is garbage, and install synaptic or elan drivers instead? I often will choose to use my phone or wait until I'm at my desktop if I don't have a USB mouse with me rather thanuse this laptop anymore, because the touchpad is that bad.

  • Dagonite
    Dagonite Member Posts: 3

    Found the solution that finaly worked for me(triedn everything with UEFI/Legasy and other soulution on site).

    Lauch BIOS -> Main -> Touchpad

    Make sure this setting is set to Advanced and NOT basic. After changing it to advanced win8 finaly recognised touchpad as, well, touchpad. Guestures work and it no longed seen and regular mouse.

  • dave142
    dave142 Member Posts: 1

    disconect from mains, remove battery hold down power button then refit battery restart

    this worked with my Aspire E5-551 .

  • MJean
    MJean Member Posts: 1

    Thank you dave142, this worked great. My curser/pointer when using the touchpad was tracking and going where ever it wanted. My daughters were trying to install a driver for the touchpad, but it would just disappear.  I'm not a computer geek. I get by. But this seems like an issue with static electricity. Works fine now Thank You again!

  • helpmehelpme
    helpmehelpme Member Posts: 2

    Tried that on my Acer E5-511 and my Acer R11 All-In-One but both were already set to Advanced. Looks like it's been a while on this post, any updates?

  • kTA952
    kTA952 Member Posts: 1

    I have some problem with touchpad. The mouse hangs littel bitt when i use.


    Can you install the touchpad driver from Acer ?


    i have try booth of them, but the driver didnt help.


  • KarlMarx
    KarlMarx Member Posts: 2
    Precision trackpad = horribly reduced trackpad: good for industry, bad for users. Gone are programmable corner taps; optional tap-to-click; edge motion; constrain cursor to horizontal / vertical; variable sensitivity; cursor momentum...

    That's progress folks!

  • Balathasan
    Balathasan Member Posts: 1

     I have two problems with my Acer Aspire. 1.touch pad right click doesn't work. 2. two USB ports on the right side doesn't work. I recently upgraded to windows 10. touchpad worked even afterwords. now all of a sudden it ceased working. However the USB ports stopped working even before windows 10. Pleaase help.

  • KarlMarx
    KarlMarx Member Posts: 2

    I have regular trouble with my touchpad: it just can't cope with having tap-to-click AND click-lock on at the same time, it just goes mental every 5 days or so, incredibly regular... Selection gets sticky, then tap-to-click dies completely (forced to use clicker), then things get really nasty... Can only drag with 2 fingers, have to triple-click to select... Eventually selection is almost random then jammed... Finally the cursor just disappears & I only have the arrow / return / escape (etc) keys to get me out of serious trouble... Which means navigating to "This PC / Acer(CSmiley Happy/ OEM / Preload / Autorun / DRV / Elantech Touchpad... & (somehow!) clicking the "Setup.exe" inside. I have to do that every 5 days, have done for 2 years!  Total I have regular trouble with my touchpad: it just can't cope with having tap-to-click AND click-lock on at the same time, it just goes mental every 5 days or so, incredibly regular... Selection gets sticky, then tap-to-click dies completely (forced to use clicker), then things get really nasty... Can only drag with 2 fingers, have to triple-click to select... Eventually selection is almost random then jammed... Finally the cursor just disappears & I only have the arrow / return / escape (etc) keys to get me out of serious trouble... Which means navigating to "This PC / Acer(CSmiley Happy/ OEM / Preload / Autorun / DRV / Elantech Touchpad... & (somehow!) clicking the "Setup.exe" inside. Must make hidden folders visible on Windows to follow that path. I have to do that every 5 days, have done for 2 years! So I put a shortcut on my desktop of course. Total madness. It completes in a few seconds but then has to restart the PC which takes much longer than usual... Still, better than using System Restore, that used to take 40 minutes & had me close to abandoning the computer!

    Well, you can try that .exe, good luck with it, there's no big virus / compatibility issue because it's already on your machine, but it's not a guaranteed fix. I can't comment on your right-click issue, sounds mechanical rather than software, although the right-click zone is incredibly tightly jammed into the corner (you probably noticed!) Don't forget that a 2-finger tap on the touchpad is the same as a right-click though... If that sounds like a workaround for you, press the Windows key+C to invoke the 'Charms' Search... Type in "Touchpad" & go to the bottom entry in the Settings, with all the blah about response delays... Pick "No delay (always on)".

    Good luck my good man, & remember, never change or upgrade anything till you're absolutely forced, it'll just go wrong!

    PS. I know I said tap-to-click was gone with the 'precision' (¿) touchpads in my previous post. Well ok, I withdraw that statement, but with it hidden so deeply in all that hateful 'Charms' (¿!) rubbish I think you can forgive me!