Headphone mic not working or not recognized in Linux mint with Helios Phn16-71-768W

Options
Pranav33
Pranav33 Member Posts: 15 Troubleshooter
edited March 20 in Predator Laptops

Laptop in use: PREDATOR HELIOS NEO 16 https://www.acer.com/us-en/predator/laptops/helios/helios-neo-16/pdp/NH.QLUAA.008

Installed Linux mint 21.3 recently. Faced lots of issue, but was able to fix it. (Thanks to Linux Mint community and Acer community) But got stuck on this one issue, gone through most of the related forums, but none of them worked.

In input tab of sound setting, even though headphone is not inserted the option to select headphone is always there along with internal mic option. And after inserting the headphone, it remains same and doesn't work even if the headphone option is selected.

Post link to linux mint forum:

https://forums.linuxmint.com/viewtopic.php?p=2445353#p2445353

«1

Answers

  • JackE
    JackE ACE Posts: 44,691 Trailblazer
    Options

    Plug in headphones, Open terminal. Enter 'killall pulseaudio'. If no error messages, try it again.

    Jack E/NJ

  • Pranav33
    Pranav33 Member Posts: 15 Troubleshooter
    Options

    Thanks for the response Jack 😄

    When I run the command "killall pulseaudio" once, nothing happens. But when I run the command multiple times I get this error msg "pulseaudio: no process found" after that all external and internal sound stops working.

  • JackE
    JackE ACE Posts: 44,691 Trailblazer
    Options

    Sorry, I meant run the command only one time. If no error message, then try the headphones again, not run the command again.

    Jack E/NJ

  • Pranav33
    Pranav33 Member Posts: 15 Troubleshooter
    Options
  • JackE
    JackE ACE Posts: 44,691 Trailblazer
    Options

    Do you have Mint installed alongside Windows? Is ii the Cinnamon desktop?

    Jack E/NJ

  • Pranav33
    Pranav33 Member Posts: 15 Troubleshooter
    Options

    Yes, I have dual boot Linux Mint alongside Windows 11 and yes it is the Linux Mint 21.3 Cinnamon Edition.

  • JackE
    JackE ACE Posts: 44,691 Trailblazer
    Options

    (1) To help rule in/out a hardware issue, does the mic still work OK in Win11?

    (2) And did you turn off fast startup in ControlPanel's power button app BEFORE you originally installed Cinnamon?

    Jack E/NJ

  • Pranav33
    Pranav33 Member Posts: 15 Troubleshooter
    Options
    1. Yes, mic works completely fine in Windows 11.
    2. Yes, I did turn off fast startup before installing Cinnamon.

  • JackE
    JackE ACE Posts: 44,691 Trailblazer
    Options

    Go to the Cinnamon start menu. Click Mint software manager in left pane. Search 'pulseaudio'. Which pulseaudio apps are green checkmarked as installed?

    Jack E/NJ

  • Pranav33
    Pranav33 Member Posts: 15 Troubleshooter
    Options

    All the pulseaudio apps that I can see as green checkmarked after searching "pulseaudio" in software manager are listed below:

    1. Pulseaudio-utils
    2. Pulseaudio-module-bluetooth
    3. Pulseaudio
    4. Pavucontrol
    5. Gir1.2-cvc-1.0

  • JackE
    JackE ACE Posts: 44,691 Trailblazer
    Options

    Try uninstalling #2 Pulseaudio-module-bluetooth. Then run killall pulseaudio from the terminal. Test external mic again

    Jack E/NJ

  • Pranav33
    Pranav33 Member Posts: 15 Troubleshooter
    Options
  • JackE
    JackE ACE Posts: 44,691 Trailblazer
    Options

    Search 'sound' in start menu. Is more than one sound control app displayed?

    Jack E/NJ

  • Pranav33
    Pranav33 Member Posts: 15 Troubleshooter
    Options

    Yes, there are some apps that I installed, while trying to fix this issue. But none of them worked. Should I uninstall them?

  • JackE
    JackE ACE Posts: 44,691 Trailblazer
    Options

    PulseAudioControl looks like the generic FlatHub version of the recommended Mint PulseAudioServer (aka "Sound"). Since both are installed & active, mutual interference is possible, not just redundancy. I'd remove one of them to eliminate this possible complication. FlatHub version is more resource demanding with a slightly fancier GUI but adds nothing to the Mint default version.

    The HDAJack* & RMEdigi* are GUI versions of the PulseAudio ALSA sound terminal command-line utilities. Again, they might interfere with the default command line settings. So probably should be removed too.

    Like others with current and earlier ubuntu releases, I've found that PulseAudioServer often fails to properly or even fully detect sound hardware for some reason. In my situation, the killall command to re-fresh and re-load the ALSA drivers usually if not always fixes the problem.

    Jack E/NJ

  • Pranav33
    Pranav33 Member Posts: 15 Troubleshooter
    Options

    Removed everything except "PulseAudioServer" and restarted my laptop, and ran the command "killall pulseaudio" but the issue is still there.

  • JackE
    JackE ACE Posts: 44,691 Trailblazer
    Options

    Please post a screenshot of the "sound" input tab.

    Jack E/NJ

  • Pranav33
    Pranav33 Member Posts: 15 Troubleshooter
    edited March 28
    Options

    Screenshot of input tab of "sound", even though headphone is not plugged in. Even after headphone is plugged in it remains same.

    I don't know why this "Headphones Stereo Microphone sof-hda-dsp" is showing, it was there when I first installed Linux mint. At first, I thought after inserting my headphone and selecting that option will activate my headphone mic, but that doesn't seem to be the case.

  • JackE
    JackE ACE Posts: 44,691 Trailblazer
    edited March 29
    Options

    > >I don't know why this "Headphones Stereo Microphone sof-hda-dsp" is showing, it was there when I first installed Linux mint.> >

    Try this. Boot Windows with the headset plugged in & its mic active. While still plugged in & active, re-start Windows to boot Mint. What happens to its mic level now?

    PS: Mint PulseAudioServier update is now available. Install it before we do any more troubleshooting.

    Jack E/NJ

  • Pranav33
    Pranav33 Member Posts: 15 Troubleshooter
    edited April 1
    Options

    Try this. Boot Windows with the headset plugged in & its mic active. While still plugged in & active, re-start Windows to boot Mint. What happens to its mic level now?

    Updated Mint PulseAudioServer, and restarted Windows to boot Mint while the headset was plugged in with its mic active but it didn't worked. The mic level is still the same. 🙁

    One thing I noticed in windows, in "Input devices" under "All sound devices" option, there is "Stereo Mix" option as well. If I select that option, it also doesn't work. I am not sure but I think it is somehow connected to the input option "Headphones Stereo Microphone sof-hda-dsp" of Mint.