How to disable over clocking? - Predetor Helios 300 PH315-53

NathanAlwisNathanAlwis Member Posts: 61 Troubleshooter
edited October 14 in Predator Laptops
Hello acer, I have heard that overclocking a CPU is not a good idea and reduces life span of the CPU can I know how I can disable it on my Predetor Helios 300 PH315-53 i tried doing max process state to 99% in the power management but it fixed the problem but after I did some editing on Adobe after effects it suddenly started over clocking I repeated the same thing I did before but didn't work I cant find any options to disable it on the BIOS either can some one help me pls? 

​//Edited the content to add model name.   ​

Best Answer

  • NathanAlwisNathanAlwis Member Posts: 61 Troubleshooter
    Accepted Answer
    Ok seems to be an issue on my side I have set max performance in battery settings and after I turned that to power saving it worked ....  

FAQ & Answers

  • NathanAlwisNathanAlwis Member Posts: 61 Troubleshooter
    Accepted Answer
    Ok seems to be an issue on my side I have set max performance in battery settings and after I turned that to power saving it worked ....  
  • xapimxapim ACE Posts: 6,960 Pathfinder
    edited October 15
    NathanAlwis what do u mean overclocking cpu you cant overclock any mobile cpu unless you have a HK cpu all H cannot be overclocked also why are you disabling the turbo boost thats the same as for ex transforming you cpu into a core i3 whats the point of buying a gaming laptop if youre cutting all its performance ? might as well just buy a normal one instead :)#

    U just need to optimize windows properly undervolt with TS and if needed repaste it with kryonaut or similar if youre able to without voiding your warranty or send it back to acer to get it repasted with stock paste thats the proper way to solve all thermal issues if youre having them also if you use adobe premiere you need the cpu/gpu at full performance for rendering so as i said use TS and msi AB to undervolt the cpu/dgpu to your needs without loosing too much performance do not disable the cpu turbo boostthats not a solution and whoever invented it its just the dumbest solution wont solve anything 


    https://www.userbenchmark.com/UserRun/11532543

    UserBenchmarks: Game 43%, Desk 61%, Work 40%
    CPU: Intel Core i5-7300HQ - 63.5%
    GPU: Nvidia GTX 1050-Ti (Mobile) - 41.9%
    SSD: WDC WDS200T2B0B-00YS70 2TB - 71.4%
    HDD: WD WD10SPZX-00HKTT0 1TB - 93.7%
    RAM: Kingston HyperX DDR4 2666 C15 2x16GB - 76.8%
    MBD: Acer Predator G3-572

    I'm not an Acer employee. (just here to help in the best way i can)
    If my answer fixed you issue please accept it for any other users who search for it would find it quickly thanks :)
    If you want to learn more about undervolting/optimizing windows join the Predator fb group and youtube channel:

    Owner/Admin (HOTEL HERO/Red-Sand/Opoka Opoka)
    https://www.facebook.com/groups/PredatorHelios300
    https://www.youtube.com/channel/UCNJwGUHxSJ8FKqAhnOqQuAw
    Acer support:
    https://www.acer.com/ac/en/US/content/service-contact
    http://www.acer.com/worldwide/support/  


Sign In or Register to comment.

Who's Online774

AnneS
AnneS
BaconOnes
BaconOnes
billsey
billsey
brnunes
brnunes
Chamuskara
Chamuskara
DonSerrucho
DonSerrucho
hristijanXXXX
hristijanXXXX
jdragao
jdragao
larryemma00
larryemma00
Leostat
Leostat
lizzie28
lizzie28
Luquiverio
Luquiverio
Masteruniversal
Masteruniversal
NaluF
NaluF
RX2071
RX2071
Satsume
Satsume
sebasellol
sebasellol
spychs0
spychs0
tadekm
tadekm
ThatIcyPolarBear
ThatIcyPolarBear
xapim
xapim
Xphuzz
Xphuzz
zZIGORZz
zZIGORZz
+751 Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos