Helios 300 ph315-53 will not boot

DrTorrDrTorr Member Posts: 3 New User
edited June 22 in Predator Laptops
I'm using the helios 300 ph315-53-72XD and after installing an HDD my machine will refuse to boot up, with the turbo and lightbulb icon turning on then off. Ive attempted to remove the cmos battery and putting it back, ive tried switching ram, ive tried taking out and putting back in the battery overnight, ive tried taking out the m.2 ssds. Nothing seems to work

Thread was edited to add model name to the title


FAQ & Answers

Sign In or Register to comment.

Who's Online651

Athwart
Athwart
clerbird321
clerbird321
HannaRN22
HannaRN22
heymyh
heymyh
IAmHeroForFun
IAmHeroForFun
Kev0806
Kev0806
moolbkram
moolbkram
Morisuprime
Morisuprime
Oluarry
Oluarry
Phittiphat
Phittiphat
SherwinArguelles
SherwinArguelles
StevenGen
StevenGen
Timmy_87
Timmy_87
TomCloyd
TomCloyd
xapim
xapim
Yibo_de
Yibo_de
+635 Guests

Join in, share your experience!

It looks like you're new here. Sign in or register to get started.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1990

Total Points:6487

Total Accepted Answers: 249

Leostat Community Aficionado