This page has been archived.

The content on this page may be out-of-date or have been superseded by newer information, and links on this page to other sites may not work. This page has been archived for future reference.

Visit our Product Forums for more current content.

I have a new Acer Iconia W510 tablet. I frequently lose audio sound and have to reboot. How to fix?

jsnjsn Member Posts: 4

I keep losing audio on my new Acer Iconia W510 tablet.  It comes back after reboot, but then I lose it frequently.  Customer support had me uninstall the driver, and then reinstall.  I did that once and rebooted.  The next time the audio failed, I uninstalled the driver and got a hard crash (dpc_watchdog_violation).  I'm seriously considering returning the tablet.  Has anyone else seen this or solved it?

«1

FAQ & Answers

  • ChrisChris Member Posts: 84

    Hi jsn,

     

    Can you please try a windows update and see if it finds a new driver. There have been many new

     

    windows update which may resolve the problem.

     

    If that doesnt fix the problem please try a recovery.

     

    This can be done by using the Acer Recovery Management.

  • jsnjsn Member Posts: 4

    I have been installing all updates as they are available.  The driver has always remained the same.

    Intel SST Audio Device (WDM)

    Driver Date: 9/26/2012

    Driver Version: 6.2.9200.22017

  • ChrisChris Member Posts: 84

    Does the audi device dissapear meaning not showing in device manager when it doesnt work?

     

    You can try enabling/disabling the Audio Device.

     

    Otherwise try a recovery as some components of the driver for Audio may be corrupt.

     

     

  • jsnjsn Member Posts: 4

    My initial fix was to disable the audio device, and then re-enable it.  That worked only temporarily.

    Then I called customer support, and they had me uninstall and reinstall the driver.

    That worked temporarily, and the 2nd time I tried it I got the RTC error.

     

    What is meant by Acer Recovery?  Doesn't that require a USB DVD drive?  I don't own one, and I'm not going out to buy one.

    Also, as a new customer it is unreasonable to expect me to competely recover a system I just took out of the box.  I would rather get my money back.

     

    There must be another way to solve this.

  • ChrisChris Member Posts: 84

    Do you have the 32Gb or 64GB W510?

     

    I have included link for Audio Driver,

     

    Please download and reinstall:

     

    https://www.dropbox.com/s/ur8ge72x5696noh/Audio.zip

     

    Go into Device manager>Sound,Video and game controllers>Intel SST Audio Device

    Select Driver Tab

    Uninstall and select the Delete the driver software for this device.

     

    Restart tablet, when booting up and find new hardware direct to the location where you donwload the file and unzip.

     

  • jsnjsn Member Posts: 4

    This is the 32GB model.

     

    I tried your suggestion of deleting the audio driver and rebooting.  It wasn't as easy as just rebooting.  Instead, I had to go to the device manager, find the "unknown" device, and then install the driver manually.  Unfortunately, after resinstalling the audio driver manually, the wi-fi device stopped working too.  I then worked through the Win8 repair tools to get the wi-fi device working again after a few re-boots.

     

    So, after using the tablet successfully with both audio and wi-fi for 3 hours, the audio stopped working again.

    This is a deal breaker.  The tablet is now on its way back to the Microsoft store where I purchased it.

    I will get a full refund.  I enjoyed this tablet when it worked and I really wanted to keep it.

  • tinypockettinypocket Member Posts: 9

    Chris, can you please escalate this to the engineering/product team?

     

    I have the exact same issue with the sound, and I've read about others having the same problem also (it was mentioned in at least one review I read).

     

    I have the 64GB model.

     

    I really do want to keep this but it is a deal breaker for me also -- I can't keep rebooting the device whenever I want sound!

  • mikeklacymikeklacy Member Posts: 1

    I'm experiencing the same issues, typically provoked by switching users or switching between desktop and tile views. This needs to be addressed asap.

  • ChrisChris Member Posts: 84

    Hi tinypocket,

     

    Are you able to elaborate on the problem and will help where I can.

     

    - With the audio does the device dissapear from device manager?

     

    - Are you able to play a an audio file when the sound dissapears? or does it give an error message?

     

    - Is there a red cross on the system tray on the speaker?

     

    Thanks

  • tinypockettinypocket Member Posts: 9

    It seems to happen pretty randomly. I would say possibly more frequently after not having used the tablet for a while.

     

    Answers to yor question and a few more points:

    -The device does not dissapear from device manager.

    -I can't play any sound out of any program. Depending on the program, it'll either get stuck and not play or give an error message.

    -There is no red cross in the system tray on the speaker.

    -When clicking the speaker in the system tray and adjusting the volume that way, it doesn't make the usual "ding" noise and does not show the green volume bar as it normaly does while the "ding" sound plays.

    -When going into the playback devices, right-clicking then going to Test, you hear nothing. Sometimes it also gives an error message -- I can't remember the exact message but something like 'test sound failed to play'. Disabling and re-enabling _sometimes_ helps, but not always.

    -Rebooting always helps and the sound comes back

     

    Hopefully this helps. If you have any more questions, let me know. It is getting frustrating though so hopefully there can be a resolution soon!

     

    Thanks,

    Nick

  • PerKjaerPerKjaer Member Posts: 3 New User

    I have the exact same problem.

     

    Acer, should I return my W510 or do you have a fix for the problem?

     

    - Per

  • rajivlooniarajivloonia Member Posts: 3

    I am having the exact same issue, the sound would disappear frequently and wont return without a restart, does acer have a solution for this, when can we expect an update that fixes this issue.

  • nizzonnizzon Member Posts: 3

    Im having the exact same problem.

    It just randomly stops working, everything looks fine on the system, nothing wrong in sys manager etc. Once when using spotify spotify said there was no device driver for my soundcard, after a reboot it worked fine, now spotify plays the music but the speaker is dead.

     

    This must be a driver issue.

    Needs high priority.

    A device like this with no sound is useless.

  • fuqibfuqib Member Posts: 5

    i have the same problem too.

    i have noticed that if i use to photos app to view a video, a couple of videos later, the sound dies or sounds broken.

    a reboot is the only way to fix it it seems.

    btw, i have all the latest windows updates on the 64 gb tablet

  • dalootsdaloots Member Posts: 2

    I have the exact same problem. I only have the device for a couple of hours and it already happened twice, right out of the box. It makes it pretty much unusable as a media device.

     

    What I've noticed is that the volume control behaves strange when it happens: the volume control is really slow to react and  even reacts in the wrong direction to the volume rocker. If you press the + button, sometimes it will decrease.

    There is nothing in the Windows event log, restarting any audio related service doesn't help either.

     

    For me it occured when watching Youtube videos. In between two videos the sound vanishes without any visual indication of a problem. So it's probably related to ending or starting a media stream.

     

    I hope this gets the necessary attention from Acer.

     

    Cheers from Belgium,

    Davy

  • dalootsdaloots Member Posts: 2

    I installed the new W510 Driver Package from the Acer website and that has made things worse: not only is the sound issue not fixed, but now every reboot the device tries a firmware update lasting 30 seconds. The device manager shows a problem with "Clovertrail Firmware 5.0".

     

    Windows event log shows this event:

    Device UEFI\RES_{ffd4675e-ff47-46d9-ac24-8b331f937737}\0 had a problem starting.

    Driver Name: oem25.inf
    Class GUID: {f2e7dd72-6468-4e36-b6f1-6488f42c1b52}
    Service:
    Lower Filters:
    Upper Filters:
    Problem: 0xE
    Status: 0x0

     

    This is the driver information: 

     

    Device UEFI\RES_{ffd4675e-ff47-46d9-ac24-8b331f937737}\0 was configured.

    Driver Name: c_firmware.inf
    Class GUID: {F2E7DD72-6468-4E36-B6F1-6488F42C1B52}
    Driver Date: 06/21/2006
    Driver Version: 6.2.9200.16384
    Driver Provider: Microsoft
    Driver Section: FirmwareResource.NT
    Driver Rank: 0xFF3000
    Matching Device ID: UEFI\CC_00010001
    Outranked Drivers: c_firmware.inf:GenFirmwareResource:00FF3001
    Device Updated: false

     

    To make matters worse, I'm also experiencing the trackpad problems mentioned in another thread.

     

    I've always been happy with Acer products, and really wanted to like this tablet, but this is starting to feel as a product that has been rushed to the market. 

     

    Dear Acer support, what should I do?

     

    Thanks,

    Davy

  • ChrisChris Member Posts: 84

    Hello Acer Community,

     

    I would like to update in regards to the Touchpad for W510. The issue has been resolved we have found a hardware update to the touchpad module will need to be applied. Please contact your local service support to arrange this.

     

    Contact numbers are available by going to your local Acer Support web page.

     

    Thanks

  • sgtkerorosgtkeroro Member Posts: 1

    i installed the new driver. but the sound problem does not resolve.  please help me to fix this.

  • rajivlooniarajivloonia Member Posts: 3

    How About the sound problem, is there any fix for it recognized, it is very problematic and the sound seems to disappear all the time .. FIX Please

  • ThomasThomas Member Posts: 10

    I have upgraded to the newest driver of 13/Dec, I still lost sound once these days (when you lost sound, playing a movie with 3rd party player is very sluggish ~3-5fps).

This discussion has been closed.

Who's Online652

billsey
billsey
bupwen
bupwen
Hvac
Hvac
JimHoward
JimHoward
luiscaarrasc892
luiscaarrasc892
Meet_2
Meet_2
Nik123
Nik123
nosleep666
nosleep666
resotov
resotov
s321koko
s321koko
Shamuro
Shamuro
Skopek
Skopek
steja
steja
sudhiyamohan
sudhiyamohan
Teksal
Teksal
wishka
wishka
Teksal
Teksal
Teodor
Teodor
Sandeep62
Sandeep62
+633 Guests

Join in, share your experience!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Here?

So, what are the rules of this place? Check out our Acer Community User Agreement. Register to get all the benefits of being a member! Get social and introduce yourself in our Welcome Forum, or learn about our ACE Program and What's Happening at Acer.

Assistance by Acer


Drivers &
Manuals

Acer
Answers

Get Product Information
( only)

Acer Support
Videos

Member Highlight

We are honored to have Leostat in the Acer Community. With their dedication, support and effort, Leostat has become one of the main collaborators. On behalf of our Acer Community Team and all of our users, we want to recognize and thank you for your dedication!

Total Posts and Comments: 1296

Total Points:4232

Total Accepted Answers: 163

Leostat Overclocked Contributor