how do i fix the last update ASV15-1B

PinkieAnomaly Member Posts: 5


edited April 3 in SpatialLabs

the last update of SpatialLabs Experience Center 1.3.201 disabled 3d in videos and i can't play unsupported games like Boti - Byteland Overclocked in 3d now, i still get the 2d or side by side popup but when i click 2d nothing happens same with clicking side by side, I was previously running SpatialLabs Experience Center 1.3.169 i did a system restore to go back to SpatialLabs Experience Center 1.3.169 and that still didn't fix the problem i don't want to have to restore from a saved disk image just because i updated SpatialLabs software what do i need to do, will this be fixed in the next update, what should i do so i can watch movies in 3d again

System specs

Acer SpatialLabs View Monitor - ASV15-1B

CPU AMD Ryzen 7 7700X 4.5 GHz 8-Core Processor

Cooler Master Master Liquid 360L Core ARGB Liquid CPU Cooler

ASRock X670E PG Lightning ATX AM5 Motherboard

Kingston FURY Beast 16 GB (2 x 8 GB) DDR5-6000 CL40 Memory

WD_BLACK 1TB SN850X NVMe Internal Gaming Solid State Drive with Heatsink

Sapphire NITRO+ Radeon RX 7900 XTX 24 GB Video Card

Cooler Master MWE Gold 850 V2 Full Modular, 850W, 80+ Gold Efficiency, 2 EPS Connectors, 120mm HDB Fan

Zalman - S2 - ATX Mid-Tower PC Case - Full Acrylic Side Panel - Mesh Front Panel15.6" Nitro SpatialLabs View Monitor120MM Super High Airflow 275 CFM 5200 RPM 4Wire PWM Fan DC 12V (120X120X38 MM)

windows 11 home 23H2

Contact Info



  • ThomSwiss
    ThomSwiss Member Posts: 23 Troubleshooter

    Does the issue still exist, after you went to settings (in SpatialLabs Experience Center) and changed from side-to-side to 2d (or from 2d to side-to-side)? Did you set the shortcuts to activate the 3D mode? The default setting is [Alt+G] to get into the mode and [Alt+T] to exit it. For 3D movies I would suppose to use the dedicated Spatiallabs Player. It should work independently from the above activation.

  • PinkieAnomaly
    PinkieAnomaly Member Posts: 5



    that wasn't the issue SpatialLabs Display Service.exe crashed and opened back up nonstop constantly, I downgrade back to the old version and it keeps updating after I’ve blocked spatiallabs experience center. In the latest version of SpatialLabs Experience Center 1.3.201 i was able to get SpatialLabs Display Service.exe to stop its nonstop constant crashing and reopening cycle by replacing it with SpatialLabs Display Service.exe from version 1.3.169 of spatialLabs Experience center, i hoped that would fix the problems, it did not, I’ve taken it to geek squad at best buy and they said they think its the monitor. I have tried it out on a fresh install of windows and SpatialLabs Experience Center 1.3.201 had the same problems that the old install of windows 11 had, there were no asterisks in the device manager