PH517-5 Acer Laptop HDD completely inaccesible on windows

oyobembe2
oyobembe2 Member Posts: 5 New User

I have a Acer Predator PH517-5, with both an SSD and HDD, both internal,
I've cleaned them both using shred in Linux more than once, without any
problems until one day when I shredded them both the HDD was completely
invisible to windows, most of the details I've talked about in this thread: https://www.ntlite.com/community/index.php?threads/laptops-hdd-completely-missing-in-windows-10.4257/ , here's the most important details that I'll be listing before you ask me about it:

Can't see the HDD in Disk management, File Explorer, Diskpart, or any third party software, it's like it doesn't exist
The Bios shows as follows:
HDD0 Model Name: HFS256G39TND-N210A
HDD1 Model Name: None
HDD1 Model Name: WDC WD10SPZX-21Z10T0
And I know it's not a hardware issue because the drive is read and works
correctly in Linux so there is no physical conection missing, nor any
damage.

I'm reposting this because I lost access to my old account.

Answers

  • StevenGen
    StevenGen ACE Posts: 9,916 Trailblazer
    edited February 29

    Is the boot HDD0 the Hynix 256GB M.2 SATA shown in Disk Management, because if its showing in bios it should show in Disk Management and it could be that its not initialized because of Linux. See the Fix Grub Not Showing for Windows and Linux Dual Boot System .

    If this answers your question and solved your query please "Click on Yes" or "Click on Like" if you find my answer useful👍

  • oyobembe2
    oyobembe2 Member Posts: 5 New User

    You have misunderstood, I don't have a dual boot, I only boot into Linux from a Live USB, and the only one missing is the HDD, and only in Windows. And by the way I've noticed an error in my post, this one: WDC WD10SPZX-21Z10T0, is the HDD2

  • KJN9000000
    KJN9000000 Member Posts: 399 Seasoned Practitioner WiFi Icon

    What is the HHD formatted to? Have you tried changing the format NTFS, ExFat, Fat 32 etc.

  • oyobembe2
    oyobembe2 Member Posts: 5 New User

    I've tried everything, and by everything I mean no partition table, only partition table, partition table and unformatted partition, and every popular format that Windows 10 uses, basically the three that you mentioned.

    Perhaps you're checking if my drive is on ext4, a format "not supported" by windows, and therefore that's why It's being ignored, no that's not the case, even in the past the same drive freshly shredded (no partition table) was able to be read by disk manager to make the table and a NTFS partition, and working.