Aspire ZG5 (Pinky) can't/won't connect to Internet

I'll try to keep this short. Haven't used Pinky in a couple of years, but it started up beautifully, I cleared a lot of junk and since it was previously connected to Explorer, I wanted to connect to Chrome. Couldn't set up a wireless network, and got messages there were Port issues, so I enabled the ports. Restarted, tried again, same message. Totally disabled the Firewall, same message. The network shows up in the list of active networks, with a strong signal, but Pinky says low/no connectivity. Tried to repair, can't assign a new IP address. Tried to to connect by cable to the modem. Didn't work. Called my ISP, and we tried a couple of things. NO GO. My laptop, tablet and 2 cell phones are all connecting and my ISP checked the modem and everything is fine. The tech did say it could be something that's corrupt, and he did mention what but I can't remember what he said. Anyone else experienced this type of problem, or can someone advise on how I can get this thing connecting to the internet again.

Thanks in advance for the help.

Answers

  • billsey
    billsey ACE Posts: 31,679 Trailblazer

    IIRC the AOA150 models came with 802.11g and possibly a draft version of n. It might not support the current encryption used for WiFi. You may have to use WEP or disable encryption entirely to connect.

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.