Does anyone know how to fix WHEA-logger 17? Acer Predator PO5-650,

R3dH00dy
R3dH00dy Member Posts: 24 Troubleshooter
edited February 22 in Predator Desktops

So I have a Acer Predator PO5-650, but I have noticed that since buying it 2-3 months ago I have gotten the WHEA-logger 17 error once or a twice a day when booting up my PC.

It has seemingly not caused any problems, but I have tried to reinstall windows 11 to no avail.

Online forums don't mention anything of this sorts so while I have tried some suggestions like updating the unit in question to a generic PCI cable for example non of it has removed the error.

"Der er opstået en rettet hardwarefejl.

Komponent: PCI Express Root Port
Fejlkilde: Advanced Error Reporting (PCI Express)

Primær bus:Enhed:Funktion: 0x0:0x1C:0x0
Sekundær bus:Enhed:Funktion: 0x0:0x0:0x0
Navn på primær enhed:PCI\VEN_8086&DEV_7A3A&SUBSYS_164E1025&REV_11
Navn på sekundær enhed:"

I hope this helps even if it is written in danish.

[Edited the thread to add model name to the title]

Answers

  • Axxo
    Axxo Member, Ally Posts: 193

    Came across a forum where someone had a similar problem, and basically a response was about isolating the faulty driver. To do that, go to:Device Manager --> System devices --> Click on "Intel PCI Express Root Port #5" (The problem device) once.Then click on the "View" Panel --> Select "Device by connection"When you do that you will see the devices connected to the port. In my case it was the Nvidia MX150 GPU. From that i identified it as the culprit.
    The device was at the latest version. I tried to roll it back to the version available on the Acer website, unfortunately that didn't solved my problem (My computer shutting off randomly) but there was a reduction
    in the "WHEA" messages. The radical solution i found for stopping these message was to disable the GPU driver. I don't need it on all the time, and if i need to play a game i can enable it manually. That at least
    seemed to have stopped the message, i have none since 5-6 hours now. For you i don't know, try to disable it or update/roll back driver to see if it helps. Good luck, hope you solve your problem.