predator sense not working in my Helio neo 16

manas_konda
manas_konda Member Posts: 1 New User
edited February 22 in Predator Laptops

i have acer predator helio neo 16, keyboard backlight was stuck predator sense was not responding related to it so i uninstalled predator sense and reinstall it again and now predator sense is not working fully. please give solution for it

[Edited the thread to add model number to the title and to add issue detail]

Answers

  • JackE
    JackE ACE Posts: 44,473 Trailblazer

    (1) If the OEM factory windows is still installed, close PredatorSense.

    (2) Search start menu 'add or remove'. Click 'add or remove programs' near top of menu.

    (3) Click PredatorSense. Click reset button if it exists.

    Then try running PredatorSense again.

    Jack E/NJ

  • William_mk2
    William_mk2 Ally Posts: 4,084

    @manas_konda

    Predator sense not working

    Try ctrl + shift + esc
    Go to task manager
    check whether you see any item called predatorsense on the list below processes
    right click on predatorsense – endtask. Close the taskmanager
    Now try to open the application..

    Sometimes a simple system restore will fix the issue..

    Try windows x
    click on power shell admin or command prompt admin or Terminal admin if it is windows 11
    type rstrui
    chose an earlier date on which your computer was working fineclick on next, finish, yes
    It will restore your computer to an earlier date
    if you get an message - system restore not completed - click on close
    It will show you all the icons..
    Try and check whether it is working now ..

    If it is still not working
    Try windows + r - On the run window
    Type msconfig
    go to services - check hide all microsoft service - disable and enable all. Go to the General Tab on the top
    chose normal startup if it is in selective startup – click on apply - ok
    restart the computer
    It should work now

    If it is still not working try to create a new user - set it up as admin. Logout and login as new user and check.

    Try windows + r - On the run window
    Type control

    It will go to control panel
    Click on User accounts
    Again click on User accounts
    Manage another account – Add a new user in PC settings - Click on add someone else to this PC or Click on “Make changes to my account in PC settings”
    Go to Family & other users
    Go to Other users
    Click on add someone else to this PC
    Click on “I don’t have this person’s sign in information
    Click on Add a user without a Microsoft account
    Type the user name and password
    Click on the user – change account type
    Change the Standard user to Administrator
    Click on ok
    Sign out and Sign in as new user
    You can even create a Microsoft account instead of local account.

    Sign out and Sign in and it should work fine

    If it is still not working...

    Try windows + x

    on run - type appwiz.cpl

    It will show you the list of programs

    remove any items related with predator sense

    Go to support.acer.com
    chose your country
    type snid or chose your model
    go to drivers - application
    Download and install the predator sense

    It will work fine....

    Click on "Like" if you find my answer useful 

    Click on "Yes" if it answers your question.


    Please click YES if I answered your question

    I am not an ACER employee
    B  Thank you and have a BLESSED AND HAPPY DAY  B


                                         ★★ WILLIAM - MRK ★★

  • alex2024b
    alex2024b Member Posts: 1 New User

    reinstalling doesn't help, waste of time…

  • krunal_P
    krunal_P Member Posts: 15 Troubleshooter

    After reinstalling driver from acer website still not working😥

  • JackE
    JackE ACE Posts: 44,473 Trailblazer

    Do you still have the original Acer factory OEM Win11 version installed, not the generic Microsoft Win11 version?

    Jack E/NJ

  • Nishchay_Mistry6396
    Nishchay_Mistry6396 Member Posts: 6 New User

    i also have the same problem man

  • ScootrV
    ScootrV Member Posts: 2 New User

    So - after getting no help technically from the "support" line, I dug all over the internet looking for solutions to a problem that is obviously software related. I don't know specifically what within the predator sense software and the way it interacts with Windows is causing the problem, only that the company has zero knowledge or willpower to resolve this…

    Here is how I solve(d) the issue. If you go to the support site for the Predator PH16-72 (NOT THE NEO 16 support site) - then scroll down to the applications section, you will see a version of predator sense that is numbered as version 5.0.1133. (this was interesting to me because it is a newer version of predator sense than you can download on the Neo 16's support site… )

    Uninstall your old predator sense then install version 5.0.1133. This program will function the way it is supposed to….. UNTIL you power down your computer or use the battery only. Then it locks up the same way the old one did, stuck on the balanced setting. This is how I know it is a software related issue. When it does this, just simply uninstall your new version and then reinstall it. It will work fine. UNTIL you power down again, etc.

    But hey - at least my non computer science brain was able to solve the issue - at least temporarily - that proved beyond the huge corporation's tech support. I am sure in several months they will figure it out - then release a patch that will do something like limit your machine cycles for convenience.