My Aspire C27-1655 has no power. I’ve tried a new power supply and am getting no lights or sounds.

Options
00909
00909 Member Posts: 1 New User

I am getting no power no lights no sounds of anything trying to come on like fans or anything. What do I try next? I’ve already tried another power supply.

Answers

  • Commodore_1995#
    Options

    sIf the LEDs do not light up, it is because some primary voltage is missing or the main voltage may be shorted.

    Oi! Eu não sou sou a cortana! Mas estou aqui para ajudar! Hi! I'm not the cortana! But I'm here to help!
    Se você gostou da minha resposta, marque como solução clicando em sim! If you liked my answer, mark it as a solution by clicking on yes!
    Aceite somente a resposta que ajudou a solucionar o seu problema! Please accept only the response that helped to solve your problem!
    Detection tool click here to find the serial number or partnumber of your model!                                                          
                                                      
                                                     egydiocoelho Trailblazer
     
    ProductKey clique aqui para descobrir o serial do windows! click here to discover the windows serial!
    Para usuários da comunidade inglesa, espanhola, francesa e alemã, usarei o google tradutor! :)
    For users of the English, Spanish, French and German community, I will be using google translator! :) 
  • billsey
    billsey ACE Posts: 32,267 Trailblazer
    Options

    Was the other power supply large enough? You need 135W@19.5V to drive it…

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • Larryodie
    Larryodie Member Posts: 1,453 Supercomputer Wrangler WiFi Icon
    Options

    If that is a plug in unit then most likely the the female jack needs resoldering or rework on the mother board. If you don't know soldering, take to a computer repair shop.