Predator X32 monitor: Need help updating firmware (can't start update process)

Options
21Kingshill
21Kingshill Member Posts: 4 New User
edited January 17 in Predator Monitors

Hi all, I hope anyone can give me a hint how to upgrade the Predator X32 monitor successfully.

Current FW on my monitor is V02.00.009, which I wanted to upgrade to x.x.015 with following steps:

  1. Downloaded Firmware_Acer_2.00.015_A_A
  2. Formated two different USB sticks on Mac with FAT32 and stored the bin file in root
  3. removed all cables from monitor, used the USB slot on the left hand side (as far away from power as possible) and plugged in the power supply

The screen turned on and told that there is no input signal. After a while it turned into sleep. No update process started at all.

The description in the FW archive is very short and no further guidance is available on official sides.

Did I miss any step or is there any other option to try?

Any help is appreciated.

Thanks, Tom

[Edited the thread to add model number to the title and to add issue detail]

Answers

  • StevenGen
    StevenGen ACE Posts: 10,685 Trailblazer
    edited January 15
    Options

    The firmware update is clearly explained in the attached PDF guide.

    Before starting USB firmware upgrade, make sure that
    1. The monitor is not in factory mode
    2. The monitor is in normal use mode (power on and blue light)
    3. Remove all input cable

    Read the "USB firmware upgrade SOP" and follow this guide below as instructed in the PDF guide:

    1. Step1. Copy MERGE.bin (that is in the firmware folder) to the root of a USB drive formatted to a "File system: FAT32".
    2. Step2. Plug in USB drive to the USB port that is farthest from the power jack.
    3. >You haven't followed or done this step > Step3. Unplug and plug power cord to upgrade firmware automatically (please don’t remove USB device and power core at will, before installation finish)
    4. >You haven't followed or done this step > Step4. Unplug and Plug power cord to complete update.
    5. Step5. After updating firmware completely, monitor would be in factory mode. Pressing navigation key to open factory menu to check whether.
      9U14RV4(FW1) and 3302(FW2) version are correct or not. Please don’t change any value on the factory menu, to make sure the monitor run normally.
    6. Step6. Press power key to turn off the device to exit factory mode and
      then press power key again to turn on the monitor in normal (user) mode.

    If this answers your question and solved your query please "Click on Yes" or "Click on Like" if you find my answer useful👍

  • 21Kingshill
    21Kingshill Member Posts: 4 New User
    Options

    Hi Steven

    Thanks for the answer, but it doesn't help.

    I followed all steps exactly as described in the PDF but step 3 is failing. This is what I wanted to explain:

    USB is connected, power cord too and screen is showing a blue light. If I disconnect and connect power, the screen is jumping through the different inputs, obviously doesn't find any and tells me that there is no cable connected. After a while it goes into sleep (orange) and nothing is happening or blinking at all.

    It seems the monitor does not recognize the firmware file on the USB drive or it's struggling with the way MacOS is formatting the drive.

  • billbutler1969
    billbutler1969 Member Posts: 1 New User
    Options

    I have the same issue. I'm following the instructions and the monitor is never completing the update cycle with a FAT32 formatted USB and MERGE.bin coped onto the root level of the USB.

    The monitor indicates that it cannot find an signal on the input and it stys in powersave mode (amber light), never progressing to the blue/amber alternating as suggested by the firmware update instructions.

  • billsey
    billsey ACE Posts: 32,740 Trailblazer
    Options

    What size of flash drive is it? Maybe it only recognizes some small ones…

    Click on "Like" if you find my answer useful or click on "Yes" if it answers your question.
  • 21Kingshill
    21Kingshill Member Posts: 4 New User
    Options

    I had the same thought when it failed the first time (using a 32 GB stick). So I tried 8GB afterwards - with the same failure. I do not own smaller sizes (and I doubt that a smaller size would change anything.)

    @billbutler1969 : Did you raise that a support ticket already? If not, I would open one…

  • 21Kingshill
    21Kingshill Member Posts: 4 New User
    Options

    I got a very quick answer from the support. However, they have no idea and suggest a repair request.

    As I'm not that happy with the monitor, I'll live with the current issues and look forward to later the year when the new 32" OLED screens arrive.