Acer Predator Triton 14 Pt14-51 won't see Wi-Fi 6E.the SSID isn't hidden

ShaunIOW
ShaunIOW Member Posts: 5

Tinkerer

edited February 9 in Predator Laptops

I've got a Wi-Fi 6E router (ASUS RT-AXE7800), 6E is enabled, the SSID isn't hidden, the three bands (2.4GHz, 5GHz and 6GHz) are all separate with unique SSID names, but the laptop only sees the 2.4 and 5GHz SSID's.

I've checked the network card drivers and they're the latest version, and have rebooted the laptop and router.

I know the 6E is working as my Samsung S23 mobile can see it and is connected to it (as is an Amazon Fire TV Gen3 Cube that is also 6E), and I've tried a wi-fi analyser on the phone and it shows everything is ok with the 6Ghz band and the signal is strong next to where the laptop is placed (which is only about 15 feet from the router anyway).

Any ideas?

Cheers

Answers

  • KJN9000000
    KJN9000000 Member Posts: 399 Seasoned Practitioner WiFi Icon
    edited February 9
  • StevenGen
    StevenGen ACE Posts: 9,933 Trailblazer

    Your WLAN card should see the 6E as its a Killer 1675i type card and its Wi-Fi CERTIFIED* to Wi-Fi 6E (802.11ax) and Bluetooth Version 5.3. Install the Intel® Driver & Support Assistant and do a scan of your system and get the WLAN driver updated properly, as the Killer 1675i is a Wi-Fi 6E card. Good luck and hope this helps you out.

    If this answers your question and solved your query please "Click on Yes" or "Click on Like" if you find my answer useful👍

  • KJN9000000
    KJN9000000 Member Posts: 399 Seasoned Practitioner WiFi Icon

    This one might be better if you feel like trying to install a new one Intel® Wi-Fi 6E AX211 https://dsadata.intel.com/installer

  • ShaunIOW
    ShaunIOW Member Posts: 5

    Tinkerer

    Cheers for the replies and the links, I've installed the Intel app and it updated 2 drivers (bluetooth and intel graphics) and the Killer wireless drivers but it still only detects the 2.4G and 5G SSID's I have and not the 6G one even after a few reboots, but it does seem an intermittent issue as for a couple of days it won't show the 6G one and then out of the blue one day it will, so I am wondering if it is a fault with the laptop as I do also have some other issues with it and only had it 2 months.

    I tried a full reformat and reinstall (setup as a new PC so no settings carried over) after getting the following issues:

    On booting I got a message saying Windows had to create a temp page file even though it is system managed anyway, and I still go the message when I set one myself.

    After a while I get a constant knocking/clicking noise from the laptop.

    The Intel Optane software reported the hard drive was degrading a couple of times, but now says it good since the reformat.

    The sound from the Bluetooth drops for no reason although the speaker is still showing as connected.

    Since the reformat/reinstall it was all fine for about a week then I got all the same issues except the Intel Optane report.

    This is all with the laptop plugged into the mains and not on battery and is set to best performance.